Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
sunuOffline
15 Post subject: Some ruby libraries want to go (solved)  PostPosted: 11.09.2011, 00:57



Joined: 2010-09-11
Posts: 11

Status: Offline
In a dist-upgrade the following ruby libraries want to go:

The following packages will be REMOVED:
libkde4-ruby1.8 libplasma-ruby libplasma-ruby1.8 libqt4-ruby1.8 libqtruby4shared2 plasma-scriptengine-ruby

Any idea?
Thanks
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject: RE: Some ruby libraries want to go  PostPosted: 11.09.2011, 17:44
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
Probably because of plasma-scriptengines, which is a metapackage to install all plasma script engines, which is a kdebase-workspace module
      Code:
    dep: plasma-scriptengine-googlegadgets (>= 4:4.6.5-2)
        Google Gadgets script engine for Plasma

    dep: plasma-scriptengine-javascript (>= 4:4.2.95)
        JavaScript script engine for Plasma

    dep: plasma-scriptengine-python (>= 4:4.6.5-2)
        Python script engine for Plasma

    dep: plasma-scriptengine-ruby (>= 4:4.6.5-2)
        Ruby script engine for Plasma

    dep: plasma-scriptengine-webkit (>= 4:4.6.5-2)
        Web and Mac OS X dashboard widget support for Plasma

    rec: plasma-scriptengine-superkaramba
        SuperKaramba theme support for the Plasma Workspaces

    sug: plasma-scriptengine-kimono
        Kimono Plasma script engine

      Code:
The following packages have unmet dependencies:
 ffmpeg : Depends: libavcodec53 (>= 5:0.8.3) but it is not going to be installed
          Depends: libavdevice53 (>= 5:0.8.3) but it is not going to be installed
          Depends: libavfilter2 (>= 5:0.8.3) but it is not going to be installed
          Depends: libavformat53 (>= 5:0.8.3) but it is not going to be installed
          Depends: libavutil51 (>= 5:0.8.3) but it is not going to be installed
          Depends: libpostproc51 (>= 5:0.8.3) but it is not going to be installed
          Depends: libswscale2 (>= 5:0.8.3) but it is not going to be installed
 ffmpeg2theora : Depends: libavcodec52 (>= 4:0.6-1~) but it is not installable or
                          libavcodec-extra-52 (>= 4:0.6-1~) but it is not installable
                 Depends: libavdevice52 (>= 4:0.6-1~) but it is not installable or
                          libavdevice-extra-52 (>= 4:0.6-1~) but it is not installable
                 Depends: libavformat52 (>= 4:0.6-1~) but it is not installable or
                          libavformat-extra-52 (>= 4:0.6-1~) but it is not installable
                 Depends: libavutil50 (>= 4:0.6-1~) but it is not installable or
                          libavutil-extra-50 (>= 4:0.6-1~) but it is not installable
                 Depends: libpostproc51 (>= 4:0.6-1~) but it is not going to be installed or
                          libpostproc-extra-51 (>= 4:0.6-1~) but it is not installable
                 Depends: libswscale0 (>= 4:0.6-1~) but it is not installable or
                          libswscale-extra-0 (>= 4:0.6-1~) but it is not installable
 libk3b6-extracodecs : Depends: libavcodec52 (>= 4:0.6-1~) but it is not installable or
                                libavcodec-extra-52 (>= 4:0.6-1~) but it is not installable
                       Depends: libavformat52 (>= 4:0.6-1~) but it is not installable or
                                libavformat-extra-52 (>= 4:0.6-1~) but it is not installable
                       Depends: libavutil50 (>= 4:0.6-1~) but it is not installable or
                                libavutil-extra-50 (>= 4:0.6-1~) but it is not installable
 libxine1-ffmpeg : Depends: libavcodec53 (>= 5:0.8.2) but it is not going to be installed
                   Depends: libavutil51 (>= 5:0.8.2) but it is not going to be installed
                   Depends: libpostproc51 (>= 5:0.8.2) but it is not going to be installed
 mozilla-plugin-vlc : Depends: vlc-nox (= 1:1.1.11-2.1) but it is not going to be installed
 plasma-scriptengines : Depends: plasma-scriptengine-ruby (>= 4:4.6.5-2) but it is not going to be installed
 upower : Depends: libimobiledevice2 (>= 0.9.7) but it is not installable
 vlc : Depends: vlc-nox (= 1:1.1.11-2.1) but it is not going to be installed
       Depends: libavcodec53 (>= 5:0.8.2) but it is not going to be installed
       Depends: libavutil51 (>= 5:0.8.2) but it is not going to be installed
E: Broken packages

_________________
debian sid | apt-get into it
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject: RE: Some ruby libraries want to go  PostPosted: 11.09.2011, 21:31
Moderator


Joined: 2010-09-11
Posts: 468

      Code:

 ffmpeg : Depends: libavcodec53 (>= 5:0.8.3) but it is not going to be installed
  ...

 vlc : Depends: vlc-nox (= 1:1.1.11-2.1) but it is not going to be installed
       Depends: libavcodec53 (>= 5:0.8.2) but it is not going to be installed
       Depends: libavutil51 (>= 5:0.8.2) but it is not going to be installed


libavcodec53 on debian is 4:0.7.1-5 and I don't see any of these packages
depends on 5:0.8.2. I suspect you have multimedia repo (or other repo) enabled.
      Code:

$ apt-cache show vlc
...
Depends: ttf-freefont, vlc-nox (= 1.1.11-2+b3), libaa1 (>= 1.4p5), libavcodec53 (>= 4:0.7-1) | libavcodec-extra-53 (>= 4:0.7-1), libavutil51 (>= 4:0.7-1) | (...)
...

$ apt-cache show ffmpeg
...
Depends: libavcodec53 (>= 4:0.7.1-5) | libavcodec-extra-53 (>= 4:0.7.1), libavcodec53 (<< 4:0.7.1-99) | libavcodec-extra-53 (<< 4:0.7.1.99), (...)
...
 
 View user's profile Send private message  
Reply with quote Back to top
sunuOffline
Post subject:   PostPosted: 12.09.2011, 09:45



Joined: 2010-09-11
Posts: 11

Status: Offline
Running

      Code:
apt-get -o Debug::pkgProblemResolver=yes dist-upgrade


I get:

      Code:
Investigating (0) libqtruby4shared2 [ amd64 ] < 4:4.4.5-7 > ( libs )
Broken libqtruby4shared2:amd64 Depends on libsmokeqtcore4-3 [ amd64 ] < 4:4.4.5-7 -> 4:4.7.0-1+b1 > ( libs ) (= 4:4.4.5-7)
  Considering libsmokeqtcore4-3:amd64 52 as a solution to libqtruby4shared2:amd64 6
  Removing libqtruby4shared2:amd64 rather than change libsmokeqtcore4-3:amd64
Investigating (0) libkde4-ruby1.8 [ amd64 ] < 4:4.4.5-7 > ( ruby )
Broken libkde4-ruby1.8:amd64 Depends on libqtruby4shared2 [ amd64 ] < 4:4.4.5-7 > ( libs ) (= 4:4.4.5-7)
  Considering libqtruby4shared2:amd64 6 as a solution to libkde4-ruby1.8:amd64 2
  Removing libkde4-ruby1.8:amd64 rather than change libqtruby4shared2:amd64
Investigating (0) libqt4-ruby1.8 [ amd64 ] < 4:4.4.5-7 > ( ruby )
Broken libqt4-ruby1.8:amd64 Depends on libqtruby4shared2 [ amd64 ] < 4:4.4.5-7 > ( libs ) (= 4:4.4.5-7)
  Considering libqtruby4shared2:amd64 6 as a solution to libqt4-ruby1.8:amd64 2
  Removing libqt4-ruby1.8:amd64 rather than change libqtruby4shared2:amd64
Investigating (0) libplasma-ruby1.8 [ amd64 ] < 4:4.4.5-7 > ( ruby )
Broken libplasma-ruby1.8:amd64 Depends on libqtruby4shared2 [ amd64 ] < 4:4.4.5-7 > ( libs ) (= 4:4.4.5-7)
  Considering libqtruby4shared2:amd64 6 as a solution to libplasma-ruby1.8:amd64 2
  Removing libplasma-ruby1.8:amd64 rather than change libqtruby4shared2:amd64
Investigating (0) libplasma-ruby [ amd64 ] < 4:4.4.5-7 > ( ruby )
Broken libplasma-ruby:amd64 Depends on libplasma-ruby1.8 [ amd64 ] < 4:4.4.5-7 > ( ruby )
  Considering libplasma-ruby1.8:amd64 2 as a solution to libplasma-ruby:amd64 1
  Removing libplasma-ruby:amd64 rather than change libplasma-ruby1.8:amd64
Investigating (0) plasma-scriptengine-ruby [ amd64 ] < 4:4.6.5-2 > ( kde )
Broken plasma-scriptengine-ruby:amd64 Depends on libplasma-ruby [ amd64 ] < 4:4.4.5-7 > ( ruby ) (>= 4:4.2.0)
  Considering libplasma-ruby:amd64 1 as a solution to plasma-scriptengine-ruby:amd64 0
  Removing plasma-scriptengine-ruby:amd64 rather than change libplasma-ruby:amd64


Investigating further these packages depend in a flurry of libsmoke* packages that are to be upgraded from 4:4.4.5-7 to 4:4.7.0-1+b1 while they want 4:4.4.5-7.
 
 View user's profile Send private message  
Reply with quote Back to top
mheyesOffline
Post subject: Re: RE: Some ruby libraries want to go  PostPosted: 12.09.2011, 16:40



Joined: 2011-02-10
Posts: 40

Status: Offline
[quote="muchan"]
      Quote:

I suspect you have multimedia repo (or other repo) enabled.


wow. well, commenting out the multimedia repo took care of my problems (removing amarok, vlc, etc). Thanks.
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject: RE: Re: RE: Some ruby libraries want to go  PostPosted: 12.09.2011, 20:36
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
muchan

mythtv (multimedia repo) Wink

_________________
debian sid | apt-get into it
 
 View user's profile Send private message  
Reply with quote Back to top
hefeeOffline
Post subject: RE: Re: RE: Some ruby libraries want to go  PostPosted: 03.10.2011, 22:16



Joined: 2010-09-14
Posts: 26

Status: Offline
new libplasma-ruby1.8 etc. are now in incoming - the related bug http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=642243 is now marked as solved. Give it a try in some hours ...

EDIT: now the packages are on my pc - without removing anything.
 
 View user's profile Send private message  
Reply with quote Back to top
sunuOffline
Post subject: RE: Re: RE: Some ruby libraries want to go  PostPosted: 05.10.2011, 16:23



Joined: 2010-09-11
Posts: 11

Status: Offline
Yes everything is ok now.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio