Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
CrustOffline
Post subject: 3.1-4.slh.5 -> linux-image-3.1-4.slh.6-aptosid-686  PostPosted: 08.12.2011, 00:06



Joined: 2010-09-12
Posts: 30

Status: Offline
The wireless NIC below stopped working after the kernel update.

      Code:
02:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6200 [8086:422c] (rev 35)


Does anyone have any idea on how to fix this issue?
 
 View user's profile Send private message  
Reply with quote Back to top
BodOffline
Post subject: RE: 3.1-4.slh.5 -> linux-image-3.1-4.slh.6-aptosid-686  PostPosted: 08.12.2011, 17:57



Joined: 2011-04-18
Posts: 11

Status: Offline
Try to upgrade to this 3.1-4.slh.7-aptosid-686
 
 View user's profile Send private message  
Reply with quote Back to top
CrustOffline
Post subject:   PostPosted: 09.12.2011, 05:46



Joined: 2010-09-12
Posts: 30

Status: Offline
The problem is fixed, but I don't know why as the kernel that wasn't working now works. Maybe some random hardware issues.
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject:   PostPosted: 09.12.2011, 16:32



Joined: 2010-08-25
Posts: 736

Status: Offline
There was no (directly) iwl-legacy related change between .6 and .7 (however there was between .5 and .6, but everything that went into .6 is also in .7), so breakage or fixes are unlikely to be related to the kernel package.
 
 View user's profile Send private message  
Reply with quote Back to top
CrustOffline
Post subject:   PostPosted: 13.12.2011, 05:41



Joined: 2010-09-12
Posts: 30

Status: Offline
slh, Thanks for confirming. It must have been a random hardware glitch.
 
 View user's profile Send private message  
Reply with quote Back to top
AjenOffline
Post subject:   PostPosted: 18.12.2011, 20:20



Joined: 2011-12-18
Posts: 1

Status: Offline
Hi I'm posting because I got the same wireless device as Crust (03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)) and I have problems connecting to my WiFi with "current" Kernels.

I'm on 64bit and this is for i686 so if I should open a new Thread for this please let me know.

However I first experienced problems when I booted the 3.1-5.slh.1 Kernel. The previously installed and used Kernel was 3.1-4.slh.5. As slh mentioned there were some iwl-related changes from .5 to.6 which continue to be in newer Kernels.

When I boot the 3.1-4.slh.5 Kernel everything works fine, I got WiFi, Internet etc. All newer Kernels failed i got constant disconnect and connecting messages from KNemo however even when it tells I'm connected I can neither access any webpages nor my Router.

There were no changes to my Router-Setup or changes to my wireless connection on my aptosid-box ... well until i started to fiddle a bit to get the newer Kernels working (etc by reconfiguring with Ceni) but to no success. Older kernels are still working.

Hoping somebody can share some insight I will try to provide necessary information.

Greetings Ajen
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject:   PostPosted: 21.12.2011, 18:30



Joined: 2010-09-13
Posts: 497
Location: Pößneck / Thüringen
Status: Offline
Since it seemes, that with 3.1.5 there is a regression for some iwlagn chipsets, slh could try this patch, as discussed here: https://bugzilla.redhat.com/show_bug.cgi?id=767173
      Code:
--- a/drivers/net/wireless/iwlwifi/iwl-agn-rxon.c
+++ b/drivers/net/wireless/iwlwifi/iwl-agn-rxon.c
@@ -606,8 +606,8 @@ int iwlagn_mac_config(struct ieee80211_hw *hw, u32 changed)
                        if (ctx->ht.enabled) {
                                /* if HT40 is used, it should not change
                                 * after associated except channel switch */
-                               if (iwl_is_associated_ctx(ctx) &&
-                                    !ctx->ht.is_40mhz)
+                               if (!ctx->ht.is_40mhz ||
+                                               !iwl_is_associated_ctx(ctx))
                                        iwlagn_config_ht40(conf, ctx);
                        } else
                                ctx->ht.is_40mhz = false;
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio