Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
cphayes0882Offline
Post subject: Netgear WG111v3(rtl8187) constantly disconnects  PostPosted: 13.12.2011, 01:12



Joined: 2011-07-22
Posts: 7

Status: Offline
Never had this problem before with this USB wireless adapter. Im running 3.1-5.slh.1-aptosid-686, now it constantly disconnects, and hangs often with using Ceni. I use Ceni only. Anyone else having this problem? Anything that can be done other than using an older kernel?

Netgear WG111v3 with the rtl8187 chip.
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: Netgear WG111v3(rtl8187) constantly disconnects  PostPosted: 13.12.2011, 02:35



Joined: 2010-08-25
Posts: 749

Status: Offline
The important question is which was the last known-working kernel, if there are any error messages in dmesg or what happens when you monitor the session with wpa_cli - also of interest are modes of operation (unencrypted, WEP{64,128}, WPA1PSK/ TKIP, WPA2PSK/ CCMP, etc.). RealTek has produced two different MAC versions under this chipset flavour (rtl8187 and rtl8187b) coupled with different PHYs, so further information about your particular device would be quite important (there are subtle differences between them). In general the rtl8180l and rtl8187 drivers enjoy little development these days, which at the same time reduce regressions, but also means there's little hope for future improvements.

Be aware that the stability of wlan equipment also depends on external factors, like interference (a new microwave oven, $neighbour got a wireless AV transceiver, bluetooth gear, etc.) or interoperability with the AP (802.11g generally "works" by now, but 802.11n may expose significant throughput differences between the interoperating chipsets).
 
 View user's profile Send private message  
Reply with quote Back to top
cphayes0882Offline
Post subject: RE: Netgear WG111v3(rtl8187) constantly disconnects  PostPosted: 13.12.2011, 13:32



Joined: 2011-07-22
Posts: 7

Status: Offline
Thanks for the quick reply slh, Ill try to include all info I can, wifi is not my specialty by any means.

Its not interference, nothing new in the house etc. I live far enough away from my neighbors that I seriously doubt Im getting interference from a neighbor's house.

Problem I believe lies in signal strength. This has happened to me before, a while ago with an ubuntu kernel where an upgraded kernel caused low signal strength(this was a broadcom card, but same thing happened).

My chip is RTL8187BvE-PHY0(copying from DMESG). Im using at the moment unencrypted wireless. The last working kernel was 3.1-4.slh.7-aptosid-686.

This is more of an annoyance really. I am able to move my WIFI across the room via extension cable, just wasnt sure if this would be a kernel problem(as I said, I have had that happen before) or not. Luckily I have an alternate WIFI/wired connection, so regardless Im ok. I will however check tonight when I have the time, Ill download something large and see if this occurs again to rule out interference from other computers(possible?), as several ppl in my house will be using wireless at the same time. Havent had that happen before, but I want to check all possibilities.

If Im missing any info, just let me know and Ill try to get it. Im not in a hurry to fix this as it is definitely does not make or break my interent connection, but if this does solve a problem Id love to help, this is about the best way I can try and help the aptosid community being as I am not a computer wiz.

_________________
aptosidbox 3.1-5.slh.2-aptosid-686
 
 View user's profile Send private message  
Reply with quote Back to top
cphayes0882Offline
Post subject: RE: Netgear WG111v3(rtl8187) constantly disconnects  PostPosted: 16.12.2011, 13:42



Joined: 2011-07-22
Posts: 7

Status: Offline
Well, let me update what is going on with my wireless. Seems after a few shutdowns, the connection goes back to normal. Same thing just happened when I upgraded to the most recent kernel. The connection kept going in and out, but after a few shutdowns and clearing out ceni a couple of times, the connection then goes back to normal. Im no expert at all on wireless, so if anyone knows why this could be happening please either post, or email/pm me as Im curious. Thanks. Guess this thread is solved/closed....

_________________
aptosidbox 3.1-5.slh.2-aptosid-686
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: Netgear WG111v3(rtl8187) constantly disconnects  PostPosted: 16.12.2011, 15:23



Joined: 2010-08-25
Posts: 749

Status: Offline
"Clearing out ceni a couple of times" or "a few shutdowns" cannot have any effect on this, as no state is kept between reboots (and Ceni just writes a static config files processed by wpasupplicant, which doesn't differ just you recreated it with the same values).
 
 View user's profile Send private message  
Reply with quote Back to top
broweOffline
Post subject: RE: Netgear WG111v3(rtl8187) constantly disconnects  PostPosted: 22.12.2011, 14:34



Joined: 2010-09-12
Posts: 152
Location: Canada
Status: Offline
If the device behaves differently on reboot it could be a hardware issue with either your wireless USB or your router. One wireless port might work better than another one, also different frequencies might get better signal in your particular arrangement. Check the router stats for signal strength, perhaps use another wireless channel, and check what channels your neighbours are using if they show up at all.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio