Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
npfpOffline
Post subject: aptitude safe-upgrade 21.12.2011, iceweasel-error  PostPosted: 21.12.2011, 08:50



Joined: 2011-12-21
Posts: 4
Location: Mainz
Status: Offline
Hello!
my first posting, so please excuse possible reporting-misbehaviour from my side ...
Did the usual aptitude update, aptitude safe-upgrade (which always worked flawlessly), then by restarting system, logging-in, starting iceweasel 9.01 (freshly-upgraded from 8.01), received XML-Error (chrome-related) which prevented iceweasel from starting. Already mentionned as bug in former iceweasel-versions. Seems to be the problem of corresponding localized-language-packs getting released a bit later than the iceweasel-version.... 'will stay with the un-localized version (us/english) 'til the new language-pack for 9.01 is released...

greetings,
npfp
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
belzeOffline
Post subject: RE: aptitude safe-upgrade 21.12.2011, iceweasel-error  PostPosted: 21.12.2011, 09:28



Joined: 2010-09-13
Posts: 100

Status: Offline
according to aptosid manual: http://manual.aptosid.com/en/sys-admin-apt-en.htm#apt-upgrade
      Quote:
NEVER DIST-UPGRADE [or UPGRADE] with adept, synaptic or aptitude:

And you may note also
      Quote:
An 'upgrade' only of 'debian sid' is not recommended.

That said, i'm waiting too for language packages Wink
 
 View user's profile Send private message  
Reply with quote Back to top
npfpOffline
Post subject: Re: RE: aptitude safe-upgrade 21.12.2011, iceweasel-error  PostPosted: 21.12.2011, 10:08



Joined: 2011-12-21
Posts: 4
Location: Mainz
Status: Offline
      belze wrote:
according to aptosid manual: http://manual.aptosid.com/en/sys-admin-apt-en.htm#apt-upgrade
      Quote:
NEVER DIST-UPGRADE [or UPGRADE] with adept, synaptic or aptitude:

And you may note also
      Quote:
An 'upgrade' only of 'debian sid' is not recommended.

That said, i'm waiting too for language packages Wink



Thanks for the quick answering Smile
Of course, I did the mistake by using 'aptitude', I will correct this behaviour in future-times ! (Even until now I luckily did not break my system, running a modified "LXDE-only"-version of aptosid).

greetings,
npfp
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
drbOffline
Post subject:   PostPosted: 21.12.2011, 11:40



Joined: 2010-09-11
Posts: 96

Status: Offline
Same problem here with a dist-upgrade outside of x using 'pure' apt
 
 View user's profile Send private message  
Reply with quote Back to top
snvvOffline
Post subject: iceweasel broken  PostPosted: 21.12.2011, 13:37



Joined: 2010-09-13
Posts: 295

Status: Offline
Hello
After last DU iceweasel is broken with the following error on a window:

      Quote:
XML Parsing Error: undefined entity
Location: chrome://browser/content/browser.xul
Line Number 789, Column 7: <menuitem id="context-inspect"
------^


Actually I broken the browser on purpose after reading the http://www.aptosid.com/index.php?name=P ... amp;t=2021 post just to confirm the bug Smile

Lets hope that the issue will be solved.
Regards
snvv
 
 View user's profile Send private message  
Reply with quote Back to top
belzeOffline
Post subject: workaraound  PostPosted: 21.12.2011, 13:45



Joined: 2010-09-13
Posts: 100

Status: Offline
as said in the first post, the problem is a language extension. You can run in a terminal iceweasel in safe mode
      Code:
$ iceweasel --safe-mode

and than disable all language puligns. Restart iceweasel and it will run normally.
As a language package for your language will be available, you can safely install and use it.
 
 View user's profile Send private message  
Reply with quote Back to top
drbOffline
Post subject:   PostPosted: 21.12.2011, 14:33



Joined: 2010-09-11
Posts: 96

Status: Offline
This was posted here earler . . . and moved to software. The issue is the regionalisation files haven't been updated to version 9.
 
 View user's profile Send private message  
Reply with quote Back to top
snvvOffline
Post subject:   PostPosted: 21.12.2011, 14:35



Joined: 2010-09-13
Posts: 295

Status: Offline
Oh ok
In the meanwhile a workaround is:
apt-get install iceweasel/testing
Regards
snvv
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject:   PostPosted: 21.12.2011, 15:42



Joined: 2010-09-13
Posts: 497
Location: Pößneck / Thüringen
Status: Offline
The better workaround would be the remove of the b0rked language-pack.
 
 View user's profile Send private message  
Reply with quote Back to top
snvvOffline
Post subject:   PostPosted: 21.12.2011, 19:16



Joined: 2010-09-13
Posts: 295

Status: Offline
Ok but I have no idea which is the problematic package.
In fact I have only iceweasel-l10n-en-us installed.
 
 View user's profile Send private message  
Reply with quote Back to top
belzeOffline
Post subject:   PostPosted: 21.12.2011, 19:27



Joined: 2010-09-13
Posts: 100

Status: Offline
disable it using iceweasel's extension manager. You will enable it again when a new package will be uploaded. I think this is the cleaner solution. Removing a package will not let you know when a new package is available. Keeping it installed (ad disabled) you will see an update for it in the next days!
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio