Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
domiciusOffline
Post subject: [solved] Can't suspend2ram with newest kernel (3.2-0.slh.2)  PostPosted: 06.01.2012, 13:34



Joined: 2010-09-13
Posts: 35
Location: Zagreb, Croatia
Status: Offline
Yesterday I dist-upgraded to the newest kernel (I think I skipped one, the previous one I was running was 3.1-6.slh.1) and as I usually do at the end of the day, suspended the system to RAM. Or so I thought. Today when I woke up and tried restoring the system from suspend, the battery was drained which was odd because this doesn't usually happen.

Trying to turn the system back on, it stopped at loading the kernel (to the best of my knowledge - all I know is that it went past the grub menu and maybe put out a line or two of text, but then stayed with nothing but an underscore blinking at the top of the display - it didn't even reach the stage when screen "flickers" (is that the word?) for a second and the screen resolution changes).

Didn't know what else I could do at this point but force shutdown (by pressing and holding the power button).

Next bootup was successful, as usual and then after logging into the system and tying to suspend to RAM, the screen turned off, network shut down, but the suspend light was blinking well over several minutes (suspend2ram usually takes a couple of seconds) before I forced a shutdown again. All the time it was blinking I could still hear the fan working but not sure if disk was (because I couldn't feel it's fine vibration I can usually feel at one part of the laptop).

I don't know what info about my system should be relevant here (so please let me know), apart from the fact that I can't remember the days when suspend2ram wasn't working and stable as a rock. Trying the kernel prior to the current (that I have installed), 3.1-6.slh.1, I don't experience the same problem.

Host/Kernel/OS running Linux 3.1-6.slh.1-aptosid-686 i686 [ aptosid 2010-02 Κῆρες - kde-lite - (201009132215) ]
CPU Info Genuine Intel T1300 @ clocked at [ 1667.000 MHz ]
Videocard ATI M52 [Mobility Radeon X1300] X.Org 1.11.2.902 [ 1280x800@60.0hz ]
Processes 179 | Uptime 34min | Memory 734.3/2531.7MB | HDD Size 250GB (69%used) | GLX Renderer Gallium 0.4 on ATI RV515 | GLX Version Yes | Client Shell | Infobash v3.37

I use KDE (and suspend to RAM from it's menu) and yesterday also updated it from experimental per instructions on
pkg-kde.alioth.debian.org to 4.7.4 (everything seems to be running great).

_________________
domicius


Last edited by domicius on 07.04.2012, 22:01; edited 1 time in total
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
domiciusOffline
Post subject: RE: Can't suspend2ram with newest kernel (3.2-0.slh.2)  PostPosted: 07.04.2012, 22:01



Joined: 2010-09-13
Posts: 35
Location: Zagreb, Croatia
Status: Offline
Wow, I didn't realize this has been bothering me for so long... O_o

I did get around to testing enough to figure out (althought thought I wrote it here) that disabling KMS would allow me to suspend/resume normally.

But it took me until I read what slh wrote in this thread to finally solve this problem:
      Quote:
As a suggestion, you should usually leave "Linux command line" in your first screen empty, because KMS capable graphics drivers like intel, nouveau or radeon don't like it and often fail with this set.


After checking my grub setup I found out I had
      Code:
GRUB_CMDLINE_LINUX="gfxpayload=true"
so I removed it and can now again suspend/resume with the latest kernel. Smile

If I remember correctly, I put that option in there around the introduction of KMS and it had something to do with replacing the old "vga=xxx" option. Something still changed after 3.1-6 that made this option to not do good at least on my system.

_________________
domicius
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio