Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
orcaOffline
15 Post subject: (solved) axiom and ROOT uninstallable  PostPosted: 24.01.2012, 10:02



Joined: 2010-09-11
Posts: 10
Location: Rio de Janeiro, Brazil
Status: Offline
I am running the latest aptosid release, very recently upgraded (I guess 2 or 3 days ago).

When I try to install the axiom package, I get:

root@mauricio: orca# apt-get install axiom
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
axiom : Depends: axiom-databases (= 20111101-1) but it is not going to be installed
libroot-core-dev : Depends: libroot-core5.30 (>= 5.30.04) but it is not going to be installed
libroot-graf2d-gpad5.30 : Depends: libroot-core5.30 (>= 5.30.04) but it is not going to be installed
libroot-graf2d-graf5.30 : Depends: libroot-core5.30 (>= 5.30.04) but it is not going to be installed
libroot-graf3d-g3d5.30 : Depends: libroot-core5.30 (>= 5.30.04) but it is not going to be installed
libroot-gui5.30 : Depends: libroot-core5.30 (>= 5.30.04) but it is not going to be installed
libroot-hist5.30 : Depends: libroot-core5.30 (>= 5.30.04) but it is not going to be installed
libroot-io5.30 : Depends: libroot-core5.30 (>= 5.30.04) but it is not going to be installed
libroot-math-mathcore5.30 : Depends: libroot-core5.30 (>= 5.30.04) but it is not going to be installed
libroot-math-mathmore5.30 : Depends: libroot-core5.30 (>= 5.30.04) but it is not going to be installed
libroot-math-matrix5.30 : Depends: libroot-core5.30 (>= 5.30.04) but it is not going to be installed
libroot-math-minuit5.30 : Depends: libroot-core5.30 (>= 5.30.04) but it is not going to be installed
libroot-net5.30 : Depends: libroot-core5.30 (>= 5.30.04) but it is not going to be installed
libroot-tree5.30 : Depends: libroot-core5.30 (>= 5.30.04) but it is not going to be installed
root-plugin-graf2d-asimage : Depends: libroot-core5.30 (>= 5.30.04) but it is not going to be installed
root-system-bin : Depends: libroot-core5.30 (>= 5.30.04) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

When I try to install the libroot package, I get:

root@mauricio: orca# apt-get install libroot-core5.30
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
libroot-core5.30
0 upgraded, 1 newly installed, 0 to remove and 112 not upgraded.
909 not fully installed or removed.
Need to get 0 B/7,083 kB of archives.
After this operation, 29.0 MB of additional disk space will be used.
(Reading database ... 340562 files and directories currently installed.)
Unpacking libroot-core5.30 (from .../libroot-core5.30_5.30.04-1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libroot-core5.30_5.30.04-1_amd64.deb (--unpack):
trying to overwrite '/etc/ld.so.conf.d/root.conf', which is also in package libroot-core5.28 5.28.00+p06-1
configured to not write apport reports
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/libroot-core5.30_5.30.04-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any suggestions??


Last edited by orca on 25.01.2012, 12:44; edited 1 time in total
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
towoOnline!
Post subject: RE: axiom and ROOT uninstallable  PostPosted: 24.01.2012, 10:07



Joined: 2010-09-13
Posts: 499
Location: Pößneck / Thüringen
Status: Online!
dpkg --purge libroot-core5.28 5.28.00+p06-1 && apt-get -f install
 
 View user's profile Send private message  
Reply with quote Back to top
orcaOffline
Post subject: RE: axiom and ROOT uninstallable  PostPosted: 25.01.2012, 09:16



Joined: 2010-09-11
Posts: 10
Location: Rio de Janeiro, Brazil
Status: Offline
Following towo's suggestion, I checked the installed versions of all libroot-* packages and found out that there were several old 5.28 versions. I was able to purge everyone one of them out, except for 4 of them: libroot-core5.28, libroot-math-mathcore5.28, libroot-io5.28, and libroot-net5.28. The typical error message issued is (this happens as well when I try to purge any of the other 3 recalcitrant packages):

root@mauricio: orca# dpkg --purge libroot-core5.28 && apt-get -f install
dpkg: dependency problems prevent removal of libroot-core5.28:
libroot-math-mathcore5.28 depends on libroot-core5.28 (>= 5.28.00+p06).
libroot-io5.28 depends on libroot-core5.28 (>= 5.28.00+p06).
libroot-net5.28 depends on libroot-core5.28 (>= 5.28.00+p06).
dpkg: error processing libroot-core5.28 (--purge):
dependency problems - not removing
Errors were encountered while processing:
libroot-core5.28


This keeps preventing me from upgrading to libroot-core5.30, despite there being already (according to packagesearch) some other libroot-*5.30 packages installed (SIC), possibly from previous tries...

Any further directions??
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
orcaOffline
15 Post subject: RE: axiom and ROOT uninstallable  PostPosted: 25.01.2012, 12:43



Joined: 2010-09-11
Posts: 10
Location: Rio de Janeiro, Brazil
Status: Offline
Problem solved: In order to avoid a catch-22 (vicious circle) situation, I had to purge simultaneously (in the same command line) all 4 recalcitrant packages:

dpkg --purge libroot-core5.28 libroot-math-mathcore5.28 libroot-io5.28 libroot-net5.28

Thanks again
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio