Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
finottiOffline
Post subject: [solved] no sound in amarok  PostPosted: 29.01.2012, 14:53



Joined: 2010-09-12
Posts: 294

Status: Offline
Dear all,

Amarok has a feel glitches now for me. It used to work fine, but I
hadn't used it in a while. Now:

* some files show as playing, but has not sound

* some files don't play

In both cases the files are MP3s encoded with lame. With the latter I
get a little error window with "Too many errors encountered in the
playlist. Playback stopped". audacious plays all files just fine.


I've noticed some audio updates, so maybe it is related to those...

Some info:

      Code:

[snip]
05:09.0 Multimedia audio controller: C-Media Electronics Inc CMI8788 [Oxygen HD Audio]


      Code:

root@debian[/home/finotti]# cat /proc/asound/cards
 0 [Claro          ]: CMI8788 - HT-Omega Claro
                      C-Media Oxygen HD Audio at 0x8c00, irq 17


      Code:

root@debian[/home/finotti]# infobash -v3
Host/Kernel/OS  "debian" running Linux 3.2-2.slh.2-aptosid-amd64 x86_64 [ aptosid 2010-02 Κῆρες - kde-full - (201009132215) ]                                                                                               
CPU Info        2x Intel Core2 Duo E8400 @ 6144 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 3000.052 MHz ]                                                                                                             
Videocard       nVidia G86 [GeForce 8500 GT]  X.Org 1.11.3.901  [ 1280x1024@60.0hz ]                         
Network cards   nVidia MCP55                                                                                 
                nVidia MCP55                                                                                 
Processes 166 | Uptime 1:19 | Memory 2183.0/7991.1MB | HDD WDC WD1500ADFD-0,ST31000528AS,WDC WD1001FALS-0,WDC WD10EALS-00Z Size 3150GB (47%used) | GLX Renderer Gallium 0.4 on NV86 | GLX Version Yes | Client Shell | Infobash v3.41




Here are the error messages from the terminal, showing some phonon
errors:

      Code:

debian[~]$ amarok
KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x1618dd0)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
 QUrl( "http://ws.audioscrobbler.com/2.0/?api_key=&lang=en&method=user.getNeighbours&user=" ) 
 QUrl( "http://ws.audioscrobbler.com/2.0/?api_key=&lang=en&method=user.getFriends&user=" ) 
 QUrl( "http://ws.audioscrobbler.com/2.0/?api_key=&lang=en&method=user.getTopTags&user=" ) 
 QUrl( "http://ws.audioscrobbler.com/2.0/?api_key=&lang=en&method=user.getTopArtists&user=" ) 
amarok(9010)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
amarok(9010)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
amarok(9010)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
amarok(9010)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0)
amarok(9010)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0)
amarok(9010)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0)
amarok(9010)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0)
QWidget::insertAction: Attempt to insert null action
amarok(9010)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
**********************************************************************************************
** AMAROK WAS STARTED IN NORMAL MODE. IF YOU WANT TO SEE DEBUGGING INFORMATION, PLEASE USE: **
** amarok --debug                                                                           **
**********************************************************************************************
debian[~]$ QMetaObject::invokeMethod: No such method App::onWsError(lastfm::ws::Error)
lastfm::ws::Error
Expected node absent: topartists
Expected node absent: neighbours
Expected node absent: friends
QString::arg: Argument missing: /PendingTrack, /org/mpris/MediaPlayer2
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x1622170)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
QString::arg: Argument missing: /PendingTrack, /org/mpris/MediaPlayer2
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x2bb3ae0)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x161e470)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
QString::arg: Argument missing: /PendingTrack, /org/mpris/MediaPlayer2
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x7ff84420e5b0)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
QString::arg: Argument missing: /PendingTrack, /org/mpris/MediaPlayer2
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x7ff8444fd4f0)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x7ff8581f4850)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
QString::arg: Argument missing: /PendingTrack, /org/mpris/MediaPlayer2
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x2630870)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
QString::arg: Argument missing: /PendingTrack, /org/mpris/MediaPlayer2
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x7ff85849b4e0)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x3632ba0)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
QString::arg: Argument missing: /PendingTrack, /org/mpris/MediaPlayer2
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x7ff8584988f0)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
QString::arg: Argument missing: /PendingTrack, /org/mpris/MediaPlayer2
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x7ff8441dbf30)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
QString::arg: Argument missing: /PendingTrack, /org/mpris/MediaPlayer2
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x26747c0)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
QString::arg: Argument missing: /PendingTrack, /org/mpris/MediaPlayer2
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x7ff84418a360)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x7ff8581ddf50)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
QString::arg: Argument missing: /PendingTrack, /org/mpris/MediaPlayer2
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x7ff844210390)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
QString::arg: Argument missing: /PendingTrack, /org/mpris/MediaPlayer2
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x7ff8581dddc0)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
QString::arg: Argument missing: /PendingTrack, /org/mpris/MediaPlayer2
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x7ff84420d3a0)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
QString::arg: Argument missing: /PendingTrack, /org/mpris/MediaPlayer2
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x21ddb40)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
QString::arg: Argument missing: /PendingTrack, /org/mpris/MediaPlayer2
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x7ff8441cf440)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
QString::arg: Argument missing: /PendingTrack, /org/mpris/MediaPlayer2
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0x7ff858523240)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
amarok(9010)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
amarok(9010)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
amarok(9010)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:


Any help or insight would be greatly appreciated.

Best to all,

Luis


Last edited by finotti on 30.01.2012, 01:17; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
x-un-i
Post subject: RE: no sound in amarok  PostPosted: 29.01.2012, 20:33
Team Member


Joined: 2010-08-26
Posts: 170

Please make sure that you are using either the gstreamer or the vlc backend of phonon.

phonon-xine-backend is deprecated and should no longer be used

_________________
Why do strong arms fatigue themselves with frivolous dumbbells?
To dig a vineyard is worthier exercise for men.
Marcus Valerius Martialis, römischer Satiriker und Epigrammdichter

Será que o diabo perdeu a virgindade?
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: no sound in amarok  PostPosted: 30.01.2012, 01:16



Joined: 2010-09-12
Posts: 294

Status: Offline
Thanks, x-un-i! That did the trick for no sound.

The problem with not playing a file was a problem with a directory which had an apostrophe in its name... All is well now.

Thanks again,

Luis
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio