Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
dorinOffline
15 Post subject: smbclient+CUPS don't work on shared WinXP printer  PostPosted: 24.02.2012, 10:51



Joined: 2011-01-20
Posts: 18
Location: Vatra Dornei, Romania
Status: Offline
After install the aptosid 2011-3 kde-full, cups stop working on a shared winXP (HP LaserJet 1020)
The usual error is:
"Session setup failed: NT_STATUS_LOGON_FAILURE"
The cups error_log is:
      Code:
W [24/Feb/2012:07:35:23 +0200] failed to CreateProfile: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [24/Feb/2012:07:35:23 +0200] failed to CreateDevice: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [24/Feb/2012:10:18:21 +0200] failed to CreateProfile: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [24/Feb/2012:10:18:21 +0200] failed to CreateDevice: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [24/Feb/2012:10:54:06 +0200] failed to CreateProfile: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [24/Feb/2012:10:54:06 +0200] failed to CreateDevice: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
E [24/Feb/2012:11:00:44 +0200] Avahi client failed, closing client to allow a clean restart
W [24/Feb/2012:11:01:36 +0200] failed to CreateProfile: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [24/Feb/2012:11:01:36 +0200] failed to CreateDevice: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
E [24/Feb/2012:11:02:58 +0200] [Job 29] Session setup failed: NT_STATUS_LOGON_FAILURE
W [24/Feb/2012:11:02:58 +0200] failed to CreateProfile: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [24/Feb/2012:11:02:58 +0200] failed to CreateDevice: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
E [24/Feb/2012:11:02:58 +0200] [Job 29] Session setup failed: NT_STATUS_UNSUCCESSFUL
E [24/Feb/2012:11:02:58 +0200] [Job 29] Session setup failed: NT_STATUS_LOGON_FAILURE
W [24/Feb/2012:11:02:58 +0200] failed to CreateProfile: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [24/Feb/2012:11:02:58 +0200] failed to CreateDevice: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
E [24/Feb/2012:11:02:58 +0200] [Job 29] Tree connect failed (NT_STATUS_ACCESS_DENIED)
W [24/Feb/2012:11:02:58 +0200] failed to CreateProfile: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [24/Feb/2012:11:02:58 +0200] failed to CreateDevice: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files

On this box I've install 3 systems (WinXP, aptosid 2011-2 and aptosid 2011-3).
I have a user name & password on Win server.
I can setup and print on a shared printer from WinXp & aptosid 2011-2 with:
      Code:
smb://User.Name:passwd@domain.local/asistentfelie/HPLaserJ

I can't print from aptosid 2011-3.
I've tested allso from live dvd with the same results;2011-2 work, 2011-3 don't work.
infobash -v3:
      Code:
Host/Kernel/OS  "aptosidbox" running Linux 3.2-7.slh.3-aptosid-686 i686 [ aptosid 2011-02 Ἡμέρα - kde-full - (201107131633) ]
CPU Info        2x Intel Celeron E1200 @ 512 KB cache flags( sse3 ht nx lm ) clocked at [ 1200.000 MHz ]
Videocard       nVidia G98 [GeForce 8400 GS]  X.Org 1.11.3.901  [ 1440x900@50.0hz ]
Network cards   Atheros L2 Fast
Processes 152 | Uptime 1:02 | Memory 509.6/1009.9MB | HDD WDC WD2500AAKS-0 Size 250GB (46%used) | GLX Renderer GeForce 8400 GS/PCIe/SSE2 | GLX Version 3.3.0 NVIDIA 295.20 | Client Shell | Infobash v3.42

      Code:
dorin@aptosidbox:~$ smbclient -V
Version 3.6.3

cups version 1.5.2
      Code:
dorin@aptosidbox:~$ lpstat -p -d
printer Laser-1020 is idle.  enabled since Fri 24 Feb 2012 11:02:58 AM EET
        Tree connect failed (NT_STATUS_ACCESS_DENIED)
no system default destination

      Code:
dorin@aptosidbox:~$ smbclient -L primariavd.local/asistentfelie -U Dorin.Vatavu
Enter Dorin.Vatavu's password:
Domain=[PRIMARIAVD] OS=[Windows Server 2003 R2 3790 Service Pack 2] Server=[Windows Server 2003 R2 5.2]

        Sharename       Type      Comment
        ---------       ----      -------
        C$              Disk      Default share
        LEX             Disk     
        KITS            Disk     
        WsusContent     Disk      A network share to be used by Local Publishing to place published conten
        fisier_contabil Disk     
        Avantax         Disk     
        F$              Disk      Default share
        My Disc (D)     Disk     
        IPC$            IPC       Remote IPC
        TRANSFER        Disk     
        ADMIN$          Disk      Remote Admin
        USERS           Disk     
        CONTABILITATE   Disk     
        WSUSTemp        Disk      A network share used by Local Publishing from a Remote WSUS Console Inst
        E$              Disk      Default share
        SYSVOL          Disk      Logon server share                                                                       
        NETLOGON        Disk      Logon server share                                                                       
        DRIVERS         Disk                                                                                               
session request to PRIMARIAVD.LOCAL failed (Called name not present)                                                       
session request to PRIMARIAVD failed (Called name not present)
Domain=[PRIMARIAVD] OS=[Windows Server 2003 R2 3790 Service Pack 2] Server=[Windows Server 2003 R2 5.2]

        Server               Comment
        ---------            -------
-- same stations--
     
        ASISTENTFELIE       
--many other stations--
        SERVER-PDC           
--many other stations--

        Workgroup            Master
        ---------            -------
        PRIMARIA             APP-SERVER
        PRIMARIAVD           SERVER-PDC
        WORKGROUP            INF

On installed system I've try to reinstall and then to downgrade cups & smbclient + samba but with no lak.
Any suggestions?


Last edited by dorin on 27.03.2012, 19:08; edited 2 times in total
 
 View user's profile Send private message  
Reply with quote Back to top
hubiOffline
Post subject: Re: smbclient+CUPS don't work on shared WinXP printer  PostPosted: 24.02.2012, 12:30
Moderator


Joined: 2010-09-11
Posts: 228
Location: Vienna (AT)
Status: Offline
This has to be wrong:
      dorin wrote:
      Code:
smb://User.Name:passwd/domain.local/asistentfelie/HPLaserJ


Try
      Code:
smb://User.Name:passwd@domain.local/asistentfelie/HPLaserJ


With my personal laptop the same setup works flawlewssly with a bunch of printers at work.

hubi

_________________
Tilos Rádió Budapest
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
dorinOffline
Post subject: RE: Re: smbclient+CUPS don  PostPosted: 24.02.2012, 12:55



Joined: 2011-01-20
Posts: 18
Location: Vatra Dornei, Romania
Status: Offline
You've right. Is my mistake on typing the post but I do not the same in my connections.
The problem still exist. I will try to correct the post on forum.
 
 View user's profile Send private message  
Reply with quote Back to top
dorinOffline
Post subject: RE: Re: smbclient+CUPS don  PostPosted: 24.02.2012, 14:27



Joined: 2011-01-20
Posts: 18
Location: Vatra Dornei, Romania
Status: Offline
I install the latest kernel on the working system (aptosid 2011-2) and is not the fault of kernel version.
Here I have cups 1.4.6 and smbclient 3.5.9.
With this versions the printer work.
Something happening between this versions.(cups 1.5.2 & smbclient 3.6.3)
P.S. Sorry for bad English!
 
 View user's profile Send private message  
Reply with quote Back to top
dorinOffline
15 Post subject: RE: Re: smbclient+CUPS don  PostPosted: 26.03.2012, 10:27



Joined: 2011-01-20
Posts: 18
Location: Vatra Dornei, Romania
Status: Offline
I solve the problem:
1.I modify the connection string in CUPS like this
      Code:
smb://workgroup\User.Name:passwd@domain.local/asistentfelie/HPLaserJ

2.In my case I need to use a newer foo2zjs driver and installation instructions from http://foo2zjs.rkkda.com/INSTALL because is a old HP LaserJet 1020.
Maybe could be included in manual something about different case of samba connection.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio