Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
IsraelOffline
Post subject: Debootstrap Dependancy Problem in the Repos?  PostPosted: 13.05.2012, 02:45



Joined: 2010-11-23
Posts: 11
Location: Hades
Status: Offline
Think I found a dependancy problem while building an environment for chroot. (At least on kernel 3.3-2)


I tried running the following:
      Code:

/usr/sbin/debootstrap --arch=i386 sid /srv/chroot/Debian_Sid http://ftp.de.debian.org/debian


Half-way through it times out with this error:
      Code:
I: Installing core packages...
W: Failure trying to run: chroot /srv/chroot/Debian_Sid dpkg --force-depends --install /var/cache/apt/archives/base-files_6.7_i386.deb /var/cache/apt/archives/base-passwd_3.5.24_i386.deb
W: See /srv/chroot/Debian_Sid/debootstrap/debootstrap.log for details (possibly the package libept1 is at fault)


I inspect debootstrap.log and get this:
      Code:
Errors were encountered while processing:
 base-files
gpgv: Signature made Sat May 12 07:43:12 2012 CDT using RSA key ID 473041FA
gpgv: Good signature from "Debian Archive Automatic Signing Key (6.0/squeeze) <ftpmaster>"
dpkg: warning: parsing file '/var/lib/dpkg/status' near line 5 package 'dpkg':
 missing description
dpkg: warning: parsing file '/var/lib/dpkg/status' near line 5 package 'dpkg':
 missing architecture
Selecting previously unselected package base-files.
dpkg: regarding .../base-files_6.7_i386.deb containing base-files, pre-dependency problem:
 base-files pre-depends on awk
  awk is not installed.
dpkg: warning: ignoring pre-dependency problem!
(Reading database ... 287 files and directories currently installed.)
Unpacking base-files (from .../base-files_6.7_i386.deb) ...
Selecting previously unselected package base-passwd.
Unpacking base-passwd (from .../base-passwd_3.5.24_i386.deb) ...
dpkg: base-passwd: dependency problems, but configuring anyway as you requested:
 base-passwd depends on libc6 (>= 2.1); however:
  Package libc6 is not installed.
Setting up base-passwd (3.5.24) ...
dpkg: base-files: dependency problems, but configuring anyway as you requested:
 base-files depends on awk; however:
  Package awk is not installed.
Setting up base-files (6.7) ...
cp: not writing through dangling symlink `/etc/motd'
dpkg: error processing base-files (--install):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 base-files


Is this a dependancy problem with the repos?
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
DonKultOffline
Post subject: RE: Debootstrap Dependancy Problem in the Repos?  PostPosted: 14.05.2012, 08:56
Team Member


Joined: 2010-09-02
Posts: 481

Status: Offline
sid (unstable) is broken at times. You don't see most of the breakage as you aren't setting up a new system from scratch out of sid every few hours if you are not setting up a chroot or building a cd, so you usually only see the "big" breakages which end up as warnings in the forum.

If you need this chroot NOW try building a testing chroot and upgrade this one to unstable afterward. This might work.

(The messages about "pre-dependency" problem aren't the problem if these are coming at the start of the log: While setting up a system you usually have an hen-or-egg problem… -- thats why dpkg is instructed by debootstrap to ingore these problems. -- What the specific problem is i don't know yet, i am a bit out of the loop currently…)

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio