Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
MerryMurrayOffline
Post subject: dpkg: error processing libldap-2.4-2:i386 (--configure):  PostPosted: 04.07.2012, 00:00



Joined: 2011-12-05
Posts: 12
Location: Canada
Status: Offline
Hi
Enjoy Aptosid, using it from the beginning. Received useful info from the forum in the past.

Did a dist-upgrade a few days ago and now get the following messages whenever I update. Looking for a way to resolve these error messages:

dpkg: dependency problems prevent configuration of libldap-2.4-2:i386:
libldap-2.4-2:i386 depends on libsasl2-2 (>= 2.1.24); however:
Package libsasl2-2:i386 is not installed.

dpkg: error processing libldap-2.4-2:i386 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcurl3:i386:
libcurl3:i386 depends on libldap-2.4-2 (>= 2.4.7); however:
Package libldap-2.4-2:i386 is not configured yet.

dpkg: error processing libcurl3:i386 (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libldap-2.4-2:i386
libcurl3:i386

Thanks kindly in advance.

Murray
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 04.07.2012, 07:04



Joined: 2010-09-11
Posts: 183

Status: Offline
Did you already try an
      Code:
apt-get -f install
?

In my case libldap will be upgraded next time, too. But libsasl is installed fine:

apt-cache policy libsasl2-2
libsasl2-2:
Installed: 2.1.25.dfsg1-4+b1

arwa
 
 View user's profile Send private message  
Reply with quote Back to top
MerryMurrayOffline
Post subject:   PostPosted: 04.07.2012, 23:51



Joined: 2011-12-05
Posts: 12
Location: Canada
Status: Offline
Thanks for the reply,

Yes, tried apt-get -f install. No effect.

Tried apt-cache policy libsasl2-2
finished ok but no change to update.

Should have said using 64bit Aptosid.

Thanks

Murray
 
 View user's profile Send private message  
Reply with quote Back to top
oldieOffline
Post subject:   PostPosted: 06.07.2012, 14:10



Joined: 2010-09-12
Posts: 27

Status: Offline
--configure -a

apt-get install libldap-2.4-2:i386

apt-get -f install
 
 View user's profile Send private message  
Reply with quote Back to top
MerryMurrayOffline
Post subject:   PostPosted: 06.07.2012, 20:54



Joined: 2011-12-05
Posts: 12
Location: Canada
Status: Offline
Thanks for the help, Tried
dpkg --configure -a
But got:
dpkg: dependency problems prevent configuration of libldap-2.4-2:i386:
libldap-2.4-2:i386 depends on libsasl2-2 (>= 2.1.24); however:
Package libsasl2-2:i386 is not installed.

dpkg: error processing libldap-2.4-2:i386 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcurl3:i386:
libcurl3:i386 depends on libldap-2.4-2 (>= 2.4.7); however:
Package libldap-2.4-2:i386 is not configured yet.

dpkg: error processing libcurl3:i386 (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libldap-2.4-2:i386
libcurl3:i386
 
 View user's profile Send private message  
Reply with quote Back to top
oldieOffline
Post subject:   PostPosted: 06.07.2012, 21:06



Joined: 2010-09-12
Posts: 27

Status: Offline
apt-get install libldap-2.4-2:i386
 
 View user's profile Send private message  
Reply with quote Back to top
Luis_POffline
Post subject:   PostPosted: 07.07.2012, 06:45



Joined: 2010-09-11
Posts: 151
Location: Barcelona, Spain
Status: Offline
I've also been bitten for this problem:
      Code:

root@myxbox:/home/lluis# apt-get install libldap-2.4-2:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libldap-2.4-2:i386 is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libldap-2.4-2:i386 : Depends: libsasl2-2:i386 (>= 2.1.24) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

root@myxbox:/home/lluis# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libsasl2-2:i386
Recommended packages:
  libsasl2-modules:i386
The following NEW packages will be installed:
  libsasl2-2:i386
0 upgraded, 1 newly installed, 0 to remove and 100 not upgraded.
96 not fully installed or removed.
Need to get 0 B/119 kB of archives.
After this operation, 232 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 223926 files and directories currently installed.)
Unpacking libsasl2-2:i386 (from .../libsasl2-2_2.1.25.dfsg1-4+b1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libsasl2-2_2.1.25.dfsg1-4+b1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libsasl2-2/changelog.Debian.gz', which is different from other instances of package libsasl2-2:i386
Errors were encountered while processing:
 /var/cache/apt/archives/libsasl2-2_2.1.25.dfsg1-4+b1_i386.deb
[ Rootkit Hunter version 1.4.0 ]
File updated: searched for 168 files, found 139
E: Sub-process /usr/bin/dpkg returned an error code (1)

root@myxbox:/home/lluis# infobash -v2
Host/Kernel/OS  "myxbox" running Linux 3.4-4.slh.2-aptosid-amd64 x86_64 [ Debian GNU/Linux wheezy/sid ]
CPU Info        2x AMD Athlon II X2 250 clocked at [ 3000.000 MHz ]
Videocard       Advanced Micro Devices [AMD] nee ATI RV730 PRO [Radeon HD 4650]  X.Org 1.12.1.902  [ 1280x1024@60.0hz ]
Network cards   NVIDIA MCP77
                Realtek RTL-8139/8139C/8139C+
Processes 145 | Uptime 13min | Memory 498.8/2008.4MB | HDD ST3250318AS,Maxtor 6Y080L0 Size 332GB (18%used) | GLX Renderer Gallium 0.4 on AMD RV730 | GLX Version Yes | Client Shell | Infobash v3.45


Any advice will be appreciated.

Luis_P.
 
 View user's profile Send private message  
Reply with quote Back to top
oldieOffline
Post subject:   PostPosted: 07.07.2012, 13:20



Joined: 2010-09-12
Posts: 27

Status: Offline
rename "changelog.Debian.gz" to changelog.DebianLuis.gz

restart the Upgrade
 
 View user's profile Send private message  
Reply with quote Back to top
Luis_POffline
Post subject:   PostPosted: 07.07.2012, 19:19



Joined: 2010-09-11
Posts: 151
Location: Barcelona, Spain
Status: Offline
Thank you, oldie, the trick worked! Very Happy
 
 View user's profile Send private message  
Reply with quote Back to top
prp5627Offline
Post subject:   PostPosted: 09.07.2012, 23:01



Joined: 2012-07-09
Posts: 2
Location: Londrina
Status: Offline
Hi!
First cd / var / cache / apt / archives /
Within the directory dpkg-i - force-overwrite -> put in sequence the names of
packages with problems and hit enter.
After apt-get-f install.
Done the above mentioned use the Ctrl + Alt + F2.
Now again dist-upgrade.
I hope this helps.

_________________
always aptosid
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
vlly-sprtlOffline
Post subject:   PostPosted: 12.07.2012, 17:12



Joined: 2012-01-21
Posts: 5
Location: Oakland, California
Status: Offline
I see

/debian/pool/main/c/cyrus-sasl2/libsasl2-2_2.1.25.dfsg1-4+v1_i386.deb ,

dated June 9, sitting there in my usual favorite mirror.

Your quote includes "(>= 2.1.24)". I see that 2.1.23 is in the same mirror directory, along with the 2.1.25. Perhaps apt is trying to get 2.1.24 and it is not there. You could simply get the 2.1.25 version and try to install with dpkg.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio