Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
gryphonOffline
15 Post subject: [solved] Plugging in earphones no longer auto-mutes speakers  PostPosted: 20.06.2012, 23:21



Joined: 2012-04-02
Posts: 9

Status: Offline
After upgrading today, now on KDE 4.8.3,
Linux debianbox 3.4-3.slh.1-aptosid-amd64

Now plugging in headphones does not redirect sound from the speakers. Speakers keep playing and there is no sound on my earphones. Checking volumes etc sheds no light on why. Will investigate further but posting now in case anyone else is seeing this.

gryphon


Last edited by gryphon on 23.06.2012, 18:04; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
LawskiOffline
Post subject:   PostPosted: 21.06.2012, 15:46



Joined: 2012-05-04
Posts: 6
Location: Florida, USA
Status: Offline
Same thing happened here, latest kernel, recent du.

64bit kernel, with Intel HDA audio. I

I had qasmixer installed from a previous sound issue, but had not used it since. I ran Qasmixer and it had seperate volume controls for speaker and headphone, and 'Auto-Mute' toggle.

As soon as I enabled auto-mute, headphone plugging worked properly.

I can only guess new sound driver in kernel changed some settings for my particular hardware.
 
 View user's profile Send private message  
Reply with quote Back to top
kb0haeOffline
Post subject:   PostPosted: 21.06.2012, 19:41



Joined: 2010-09-12
Posts: 50

Status: Offline
Hmmmm...must be using software to make the switch then. This switching used to be done mechanically via the headphone jack.
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject:   PostPosted: 21.06.2012, 19:47
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
deleted identical post

_________________
debian sid | apt-get into it
 
 View user's profile Send private message  
Reply with quote Back to top
gryphonOffline
Post subject:   PostPosted: 23.06.2012, 18:03



Joined: 2012-04-02
Posts: 9

Status: Offline
@Lawski - I tried that and it worked for me too. Many thanks! I wasn't aware there was an auto-mute override. Of course now I see this in alsamixer - wonder why I never saw that before.

gryphon
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio