Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
apogarteOffline
15 Post subject: [SOLVED]iceweasel not starting after du (xfce)  PostPosted: 10.08.2012, 12:00



Joined: 2011-01-25
Posts: 83

Status: Offline
hello

i've got a new problem following a dist upgrade on an xfce
aptosid (i686) version (hd install)

dist-upgrade went wrong, i got several issues like uncomplete and missing stuff, wich was finally solved after
several apt-get -f install, dpkg --configure -a, and du again.
after what, i had a strange issue where i was unable to start a session after login screen (entering password was sending me back to login screen). did apt-get update, du again , that was finally ok.

but, as iceweasel is not starting anymore, i did a complete uninstall of iceweasel using apt-get purge,(but this did not removed the package ...?)

after what i did a reinstall : idem

using the xdg-browser-laucher gives me an input-output error,
trying to launch iceweasel from menu gives nothing. exit iceweasel !

if somebody would be kind enough to help me solve this issue, i would be very gratefull.

apog


Last edited by apogarte on 27.01.2013, 12:40; edited 4 times in total
 
 View user's profile Send private message  
Reply with quote Back to top
x-un-i
Post subject: RE: iceweasel not starting after du (xfce)  PostPosted: 10.08.2012, 14:33
Team Member


Joined: 2010-08-26
Posts: 170

open a terminal and start it there, that could give some more information.
you can also try in safe mode using "iceweasel -safe-mode" that would disable all plugins you have installed and could help to find the problem

_________________
Why do strong arms fatigue themselves with frivolous dumbbells?
To dig a vineyard is worthier exercise for men.
Marcus Valerius Martialis, römischer Satiriker und Epigrammdichter

Será que o diabo perdeu a virgindade?
 
 View user's profile Send private message  
Reply with quote Back to top
apogarteOffline
Post subject: RE: iceweasel not starting after du (xfce)  PostPosted: 13.08.2012, 10:24



Joined: 2011-01-25
Posts: 83

Status: Offline
hello x-un-i

starting iceweasel in a console like you suggest gives this :
      Quote:

$iceweasel -safe-mode
XPMCOMGlueLoad error for file /usr/lib/xulrunner-10.0/libxpcom.so:
libxul.so : cannot open shared object file : No such file or directory
could'nt load XPCOM


i've tried to install chrome, same stuf

Elinks works well

can you give me your advice ?

thanks,

apog
 
 View user's profile Send private message  
Reply with quote Back to top
x-un-i
Post subject: RE: iceweasel not starting after du (xfce)  PostPosted: 13.08.2012, 15:42
Team Member


Joined: 2010-08-26
Posts: 170

      Code:
apt-get install xulrunner-10.0

_________________
Why do strong arms fatigue themselves with frivolous dumbbells?
To dig a vineyard is worthier exercise for men.
Marcus Valerius Martialis, römischer Satiriker und Epigrammdichter

Será que o diabo perdeu a virgindade?
 
 View user's profile Send private message  
Reply with quote Back to top
apogarteOffline
Post subject: RE: iceweasel not starting after du (xfce)  PostPosted: 14.08.2012, 08:37



Joined: 2011-01-25
Posts: 83

Status: Offline
hello

already tried, this gave no result...

and same error message as before... i wonder if there is a PATH related issue ? 've read something related to it and modified the LD_LIBRARY_PATH :

      Quote:

export LD_LIBRARY_PATH=/usr/lib/xulrunner-10.0


error messages says now libnss3.so is missing (instead of libxul)

so i tried :

      Quote:

#apt-get install libnss3


wich told me libnss3 was already the latest version...

after what, i did a reinstall of libnss3 :

      Quote:

#apt-get install --reinstall libnss3


and after starting successfully in safe mode, i now can start iceweasel normally. I am not quite certain everything is fixed yet, because iceweasel continues randomly to close unexpectedly, wich was already an issue before i did the du.

apog
 
 View user's profile Send private message  
Reply with quote Back to top
rueXOffline
Post subject: RE: iceweasel not starting after du (xfce)  PostPosted: 10.09.2012, 16:27



Joined: 2011-05-16
Posts: 53

Status: Offline
iceweasel
XPMCOMGlueLoad error for file /usr/lib/xulrunner-10.0/libxpcom.so:
libxul.so : cannot open shared object file : No such file or directory
could'nt load XPCOM

This day I made du with the older computer (last du Mai2012)

situation: Iceweasel can't start

Solution: way:

apt-cache policy libnss3-1*
libnss3-dbg:
Installiert: (keine)
Installationskandidat: 2:3.13.6-1
Versionstabelle:
2:3.13.6-1 0
500 http://ftp.de.debian.org/debian/ unstable/main i386 Packages
libnss3-dev:
Installiert: (keine)
Installationskandidat: 2:3.13.6-1
Versionstabelle:
2:3.13.6-1 0
500 http://ftp.de.debian.org/debian/ unstable/main i386 Packages
libnss3-tools:
Installiert: (keine)
Installationskandidat: 2:3.13.6-1
Versionstabelle:
2:3.13.6-1 0
500 http://ftp.de.debian.org/debian/ unstable/main i386 Packages
libnss3-1d-dbg:
Installiert: (keine)
Installationskandidat: (keine)
Versionstabelle:
libnss3-1d:
Installiert: 2:3.13.6-1
Installationskandidat: 2:3.13.6-1
Versionstabelle:
*** 2:3.13.6-1 0
500 http://ftp.de.debian.org/debian/ unstable/main i386 Packages
100 /var/lib/dpkg/status


solution:
apt-get install libnss3-dbg
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Die folgenden NEUEN Pakete werden installiert:
libnss3-dbg

apt-get install libnss3-dev
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
libnspr4-dev
Die folgenden NEUEN Pakete werden installiert:
libnspr4-dev libnss3-dev

Well:
Iceweasel runs ! ( the tipp is "partely" from towo...)
 
 View user's profile Send private message  
Reply with quote Back to top
apogarteOffline
Post subject: Re: RE: iceweasel not starting after du (xfce)  PostPosted: 25.09.2012, 17:19



Joined: 2011-01-25
Posts: 83

Status: Offline
      rueX wrote:

.../
Well:
Iceweasel runs ! ( the tipp is "partely" from towo...)


hi

i just ended reading your post and did the trick : it apparently works !

thanks,

apog

EDIT

i lately re-used that machine and get again in trouble concerning iceweasel : it closes unexpectedly with no special warning.
So i am about to switch that machine to debian 6.06 because i consider aptosid to be untrustable again (xfce version), and i have not so much time to spend looking for solutions (been again spending hours trying to figure out what's going on)
 
 View user's profile Send private message  
Reply with quote Back to top
apogarteOffline
Post subject: RE: Re: RE: iceweasel not starting after du (xfce)  PostPosted: 02.10.2012, 13:01



Joined: 2011-01-25
Posts: 83

Status: Offline
This leads me to speak about my feelings concerning aptosid : don't know what's going on with aptosid but i am really disapointed with it. This was my favorite os since recently, but too many difficulties lead me to use kubuntu on my laptop, because of several little misbeahvings i already tried to solve with no success and no answers on my kde aptosid install ... (trouble with pad; no resume after closing lead, trouble with wifi management, strange graphical artifacts, and others : to the point i stopped my contribution to the manual translation because aptosid became unusable and i was often obliged to restart the machine after wrong resuming after closing lead or even after a "normal" sleeping time : and NO, i don't want to edit aptosid french manual pages from an ubuntu OS this makes no sense !)

i am not trusting ubuntu that much, i do not like it that much, it is buggy and heavy, but ... it works.

As no solutions shows up concerning aptosid on my laptop, i will probably switch to debian 6.06 (kde) if i can get it working fine after a testing period in order to get rid of kubuntu (i have 2 partitions for testing purposes in addition to the "main" aptosid os partition).

I understand aptosid is a small community and you guys have much more things to think about but basic users, but now i tell you : I need a working system, included those little things developpers might consider secondary... and i am again looking for an alternative, although i've been doing a lot of advocacy to support aptosid, wich once upon a time was the very best debian distro for me.

apog
 
 View user's profile Send private message  
Reply with quote Back to top
x-un-i
Post subject: RE: Re: RE: iceweasel not starting after du (xfce)  PostPosted: 03.10.2012, 10:26
Team Member


Joined: 2010-08-26
Posts: 170

iceweasel started in safe-mode should always work as it disables all plugins

as last resort remove all things related with iceweasel and reinstall them


      Code:
apt-get purge xulrunner-* libnspr4* iceweasel*

and then reinstall iceweasel
      Code:

apt-get install iceweasel

before starting the weasel again backup (and move your profile away)
      Code:

mv ~/.mozilla .mozilla.backup

_________________
Why do strong arms fatigue themselves with frivolous dumbbells?
To dig a vineyard is worthier exercise for men.
Marcus Valerius Martialis, römischer Satiriker und Epigrammdichter

Será que o diabo perdeu a virgindade?
 
 View user's profile Send private message  
Reply with quote Back to top
apogarteOffline
Post subject: RE: Re: RE: iceweasel not starting after du (xfce)  PostPosted: 14.10.2012, 16:56



Joined: 2011-01-25
Posts: 83

Status: Offline
hi thanks x-un-i

i really apreciate you tried helping, still i feel tired of trying various things for hours with no result.
i was reinstalling completely from scratch (i mean, aptosid), doing upgrades, etc. this took me a long time,
i have not installed any plugin and shortly after restarting machine got again this sudden closing of iceweasel and no way to restart it normally.

as i was saying just before i will stay away from aptosid because i think i spend way too much time trying to solve unsolvable things. i will come back sometimes here, well, say because i think maybe some things will change in aptosid
but my hope is weak.
Too bad because aptosid is a great distro... but i was probably too pretentious thinking i may use it as my main distro.
i'm on the way to switch to an other debian derivated or debian itself...

thanks again, and maybe to see you again in a while,

apog
 
 View user's profile Send private message  
Reply with quote Back to top
apogarteOffline
Post subject: RE: Re: RE: iceweasel not starting after du (xfce)  PostPosted: 27.01.2013, 12:47



Joined: 2011-01-25
Posts: 83

Status: Offline
hi to all

i've finnaly got to make a complete reinstall on that machine and got a functionnal iceweasel. i believe there where some messing in the upgrades i did later last year ? anyways i now have again two machines running 2012-01 with xfce4 and things are fine.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio