Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
sunratOffline
15 Post subject: How to restore framebuffer console  PostPosted: 09.10.2010, 07:38



Joined: 2010-09-22
Posts: 7
Location: Melbourne
Status: Offline
My installation is a regularly dist-upgraded Moros which has run smoothly through KDE3>4, change from sidux>aptosid and GRUB 1>2. Since the aptosid and GRUB2 upgrade, my text console and boot messages have reverted to plain old VGA instead of the nice framebuffer console. I've searched a bit and found various conflicting advice so will ask here. How do I enable framebuffer console (and get Tux back at boot)? Apparently VGA=791 is deprecated in GRUB 2, which is what I had originally. Monitor is 1280x1024.


Last edited by sunrat on 15.10.2010, 07:33; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject: RE: How to restore framebuffer console  PostPosted: 09.10.2010, 08:03



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
search https://wiki.ubuntu.com/Grub2 for gfxpayload
but read the whole paragraph, you need 2 entries there.
sorry, in a hurry....

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
ibgbOffline
Post subject: RE: How to restore framebuffer console  PostPosted: 09.10.2010, 08:46



Joined: 2010-09-11
Posts: 42

Status: Offline
Sounds a lot like what was addressed by slh here:
http://aptosid.com/index.php?name=PNphp ... t+size#111
 
 View user's profile Send private message  
Reply with quote Back to top
sunratOffline
Post subject: RE: How to restore framebuffer console  PostPosted: 11.10.2010, 07:44



Joined: 2010-09-22
Posts: 7
Location: Melbourne
Status: Offline
Cool, thanks guys. Just needed to do as suggested by slh:
      Quote:
you can add "vga=791" (or "vga=794") to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub and run update-grub afterwards.

No need for gfxpayload entry which is one I'd seen suggested while searching previously.

For the sake of completeness, here is the relevant excerpt from the wiki devil linked to, apparently this is the new way to do it:
      Quote:
#GRUB_GFXMODE=640x480
* Uncomment (remove '#' from beginning of the line) to change (increase) resolution of your boot loader. Use one of classic (4:3 rate):
o GRUB_GFXMODE=640x480 (is used if isn't here a proper value)
o GRUB_GFXMODE=800x600
o GRUB_GFXMODE=1024x768
o GRUB_GFXMODE=1600×1200
or make experiments with some others nonstandards like widescreen (16:10 ratio in my case), here is list of most of commonly use Display resolution:
o GRUB_GFXMODE=640x400
o GRUB_GFXMODE=800x500
o GRUB_GFXMODE=1024x640
o GRUB_GFXMODE=1280x800
o GRUB_GFXMODE=1680x1050
* If you don't know what modes are supported by your graphics card, go to the grub command line and run 'vbeinfo'. It will list all available modes. (You might need to run 'insmod vbe' first if the vbe module isn't loaded yet)

GRUB_GFXPAYLOAD_LINUX=640x480x8
* Use this setting to set the framebuffer resolution (replaces the vga= kernel option). It uses the GFXMODE values with additional color depth. Use 'vbeinfo' from the grub command line to list what modes are available to you.
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject: RE: How to restore framebuffer console  PostPosted: 11.10.2010, 09:25



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
vga=foo is deprecated if you use KMS (kernel-mode-setting)
there gfxmode and gfxpayload are mandatory

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio