Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
alexkOffline
15 Post subject: KMail reports semantic desktop system not enabled [Solved]  PostPosted: 25.07.2013, 02:22



Joined: 2010-10-01
Posts: 181
Location: Bay state
Status: Offline
Today, KMail reports this every time I create a new message:
      Code:
You do not have the semantic desktop system enabled. The following features will not work correctly:

Recipient auto-completion
Distribution lists
Per-contact crypto preferences

It gives me a Configure button that takes me to the Desktop Search settings. There, everything is enabled and seems to be running fine. That screen shows "Desktop search services are active" and "File indexing service not running". Search in Dolphin works well.

KMail seems to be lying because recipient auto-completion seems to be working fine. Perhaps the best thing is just to hit the "x" button to make KMail not display this message any more. But it's strange. Confused


Last edited by alexk on 28.07.2013, 16:58; edited 1 time in total
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
alexkOffline
Post subject: RE: KMail reports semantic desktop system not enabled  PostPosted: 25.07.2013, 02:43



Joined: 2010-10-01
Posts: 181
Location: Bay state
Status: Offline
Known issue, bug report is kmail complains about the semantic destkop not running, when it is.

soprano-virtuoso.log in /$HOME/.kde/share/apps/nepomuk/repository/main/data/virtuosobackend/ shows:
      Code:
      Wed Jul 24 2013
22:27:07 Malformed data received from IP [0.0.0.0] : Bad incoming tag 111. Disconnecting the client
22:27:07 Invalid log entry in replay. Delete transaction log /home/alex/.kde/share/apps/nepomuk/repository/main/data/virtuosobackend/soprano-virtuoso.trx or truncate at point of error. Valid data may exist after this record. A log record begins with bytes 193 188 5 188 0. Error at offset 0
22:27:07 Searching for the next valid header signature starting at 1
22:27:07 No valid looking header found.

Deleting soprano-virtuoso.trx and restarting Nepomuk at least got virtuoso-t showing in my process list again. And Nepomuk now shows "File indexer is idle" instead of "not running".
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
roliOffline
Post subject:   PostPosted: 04.08.2013, 18:58



Joined: 2010-09-14
Posts: 18

Status: Offline
Hi alexk,

i've got the same error message. Can you use the search function in KMail? On my system it's not working. Every search is finished within milisecondes without result. Is this fixed by deleting "soprano-virtuoso.trx"?
In my soprano-virtuoso.log i see:
      Code:
20:08:56 SQL Error: 42001 : SR185: Undefined procedure DB.DBA.KEY_DELETE_REPLAY.

this several times.

Thx
 
 View user's profile Send private message  
Reply with quote Back to top
alexkOffline
Post subject:   PostPosted: 10.08.2013, 15:14



Joined: 2010-10-01
Posts: 181
Location: Bay state
Status: Offline
Yes, all search functions work fine for me in KMail and they're fast.
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio