Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
hyOffline
Post subject: phpmyadmin broken after d-u  PostPosted: 25.07.2013, 15:26



Joined: 2010-09-14
Posts: 163
Location: Costa Teguise
Status: Offline
Hi while running today a d-u I got an error regarding configuring phpmyadmin.
I tried to remove phpmyadmin and add it again, but theres an error I can't solve:
      Code:

apt-get remove phpmyadmin  --purge
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  phpmyadmin
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 20.5 MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 330638 files and directories currently installed.)
Removing phpmyadmin ...
apache2-maintscript-helper invoked from a modified environment. Please hint required arguments manually
dpkg: error processing phpmyadmin (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
 phpmyadmin
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@ubique:/media/work/center.dat# apt-get install phpmyadmin 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
phpmyadmin is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/4,077 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: error processing phpmyadmin (--configure):
 package phpmyadmin is not ready for configuration
 cannot configure (current status `half-installed')
Errors were encountered while processing:
 phpmyadmin
E: Sub-process /usr/bin/dpkg returned an error code (1)



Any help appreciated ...
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: phpmyadmin broken after d-u  PostPosted: 25.07.2013, 17:41



Joined: 2010-08-25
Posts: 736

Status: Offline
There are currently two RC-severity bugs open against phpmyadmin, http://bugs.debian.org/717476 and http://bugs.debian.org/717713, apparently it didn't fare well with the transition to apache 2.4.
 
 View user's profile Send private message  
Reply with quote Back to top
hyOffline
Post subject: RE: phpmyadmin broken after d-u  PostPosted: 25.07.2013, 18:27



Joined: 2010-09-14
Posts: 163
Location: Costa Teguise
Status: Offline
ok I can wait. Hope to be notified as soon as there is any solution.
THANKS slh for the quick response.
 
 View user's profile Send private message  
Reply with quote Back to top
roliOffline
Post subject:   PostPosted: 28.07.2013, 16:07



Joined: 2010-09-14
Posts: 18

Status: Offline
fixed with phpmyadmin_4.0.4.2-1_all.deb to be found here: http://packages.debian.org/de/sid/all/phpmyadmin/download
 
 View user's profile Send private message  
Reply with quote Back to top
hyOffline
Post subject:   PostPosted: 30.07.2013, 12:45



Joined: 2010-09-14
Posts: 163
Location: Costa Teguise
Status: Offline
I edited the phpmyadmin scripts in
/var/lib/dpkg/info
and commented out the statements
set -e
after that I could remove phpmyadmin with:
dpkg --remove --force-remove-reinstreq phpmyadmin

After this the reinstall worked with the new phpmyadmin_4.0.4.2-1_all.deb. Thanks
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio