Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
manulOffline
Post subject: Repos not in sync?  PostPosted: 27.08.2013, 14:28



Joined: 2010-09-13
Posts: 85

Status: Offline
      Code:
root@siddie-new:/home/manul# apt-get update && apt-get dist-upgrade -d
Hit http://mirrors.kernel.org sid InRelease
Hit http://mirrors.kernel.org sid/main amd64 Packages/DiffIndex             
Hit http://oscar.aptosid.com sid InRelease           
Hit http://mirrors.kernel.org sid/contrib amd64 Packages/DiffIndex
Hit http://oscar.aptosid.com sid/main amd64 Packages
Hit http://mirrors.kernel.org sid/non-free amd64 Packages/DiffIndex
Hit http://mirrors.kernel.org sid/contrib Translation-en/DiffIndex
Hit http://oscar.aptosid.com sid/fix.main amd64 Packages
Hit http://mirrors.kernel.org sid/main Translation-en/DiffIndex
Hit http://mirrors.kernel.org sid/non-free Translation-en/DiffIndex
Ign http://oscar.aptosid.com sid/fix.main Translation-en_US
Ign http://oscar.aptosid.com sid/fix.main Translation-en
Ign http://oscar.aptosid.com sid/main Translation-en_US
Ign http://oscar.aptosid.com sid/main Translation-en
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Failed
The following packages have unmet dependencies:
 libenchant1c2a : Depends: aspell-en but it is not going to be installed or
                           myspell-dictionary or
                           aspell-dictionary or
                           ispell-dictionary or
                           hunspell-dictionary
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
root@siddie-new:/home/manul#


On another machine:

      Code:
root@lenovosid:~# apt-get update
Get:1 http://cdn.debian.net sid InRelease [204 kB]
Get:2 http://oscar.aptosid.com sid InRelease [23.5 kB]                               
Get:3 http://oscar.aptosid.com sid/main amd64 Packages [30.3 kB]                     
Get:4 http://cdn.debian.net sid/main amd64 Packages/DiffIndex [7,876 B]
Get:5 http://cdn.debian.net sid/contrib amd64 Packages/DiffIndex [7,819 B]
Hit http://oscar.aptosid.com sid/fix.main amd64 Packages 
Get:6 http://cdn.debian.net sid/non-free amd64 Packages/DiffIndex [7,819 B]
Get:7 http://oscar.aptosid.com sid/main i386 Packages [30.5 kB]
Get:8 http://cdn.debian.net sid/main i386 Packages/DiffIndex [7,876 B]
Hit http://oscar.aptosid.com sid/fix.main i386 Packages             
Get:9 http://cdn.debian.net sid/contrib i386 Packages/DiffIndex [7,819 B]
Get:10 http://cdn.debian.net sid/non-free i386 Packages/DiffIndex [7,819 B]
Hit http://cdn.debian.net sid/contrib Translation-en/DiffIndex
Get:11 http://cdn.debian.net sid/main Translation-en/DiffIndex [7,876 B]
Get:12 http://cdn.debian.net sid/non-free Translation-en/DiffIndex [7,819 B]
Get:13 http://cdn.debian.net sid/main amd64 2013-08-18-0230.37.pdiff [5,820 B]
Get:14 http://cdn.debian.net sid/contrib amd64 2013-08-18-2033.32.pdiff [722 B]
................................
................................
Get:306 http://cdn.debian.net sid/main amd64 2013-08-27-0834.19.pdiff [17.5 kB]
Get:307 http://cdn.debian.net sid/main i386 2013-08-27-0834.19.pdiff [17.3 kB]
Get:308 http://cdn.debian.net sid/main i386 2013-08-27-0834.19.pdiff [17.3 kB]
Fetched 1,276 kB in 1min 52s (11.3 kB/s)
Reading package lists... Done
root@lenovosid:~# apt-get dist-upgrade -d
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Failed
The following packages .have unmet dependencies:
 kde-workspace-bin : Depends: kde-runtime (>= 4:4.10.2) but it is not going to be installed
                     Depends: kde-style-oxygen (= 4:4.10.5-3) but it is not going to be installed
                     Depends: plasma-desktop (= 4:4.10.5-3) but it is not going to be installed or
                              plasma-netbook (= 4:4.10.5-3) but it is not going to be installed
 kdm : Depends: kde-runtime (> 4:4.10) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
root@lenovosid:~# apt-cache policy kde-workspace-bin
kde-workspace-bin:
  Installed: 4:4.10.5-3
  Candidate: 4:4.10.5-3
  Version table:
 *** 4:4.10.5-3 0
        500 http://cdn.debian.net/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status
root@lenovosid:~# apt-cache policy kde-runtime
kde-runtime:
  Installed: 4:4.10.5-1
  Candidate: 4:4.10.5-1
  Version table:
 *** 4:4.10.5-1 0
        500 http://cdn.debian.net/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status
root@lenovosid:~#


Some strange thing here is that apt-cache policy reports I have kde-workspace-bin 4.10.5-3 already installed AND kde-runtime 4.10.5-1 already installed as well; so how could this happen if kde-workspace-bin 4.10.5-3 depends on kde-runtime>= 4:4.10.2 in the first place?

Both systems completely clean install & d-u upgraded since (no 3rd repos etc).
 
 View user's profile Send private message  
Reply with quote Back to top
bluewaterOffline
Post subject:   PostPosted: 27.08.2013, 14:35
Team Member


Joined: 2010-08-26
Posts: 58
Location: Hobart, Australia
Status: Offline
manul:

its part of the perl transition

http://aptosid.com/index.php?name=PNphp ... 6631#16631

I also recommend that you change .cdn to a mirror near you, ( not that it will help in this matter however you will find switching to another mirror superior to cdn, as we use cdn as a 'catch all' mirror for releases)

_________________
If all else fails, get the instructions back out of the rubbish bin and read them. http://manual.aptosid.com/
 
 View user's profile Send private message  
Reply with quote Back to top
manulOffline
Post subject:   PostPosted: 27.08.2013, 22:17



Joined: 2010-09-13
Posts: 85

Status: Offline
Thanks bluewater.
I'll change .cdn with some of the other mirrors.

Just educationally: "apt-cache policy reports I have kde-workspace-bin 4.10.5-3 already installed AND kde-runtime 4.10.5-1 already installed as well; so how could this happen if kde-workspace-bin 4.10.5-3 depends on kde-runtime>= 4:4.10.2 in the first place?"

Or, the meta-info about dependencies for a package (i.e. kde-workspace-bin 4.10.5-3) can be updated without this package version increased as well?
 
 View user's profile Send private message  
Reply with quote Back to top
DonKultOffline
Post subject:   PostPosted: 28.08.2013, 09:36
Team Member


Joined: 2010-09-02
Posts: 481

Status: Offline
      manul wrote:
Just educationally: "apt-cache policy reports I have kde-workspace-bin 4.10.5-3 already installed AND kde-runtime 4.10.5-1 already installed as well; so how could this happen if kde-workspace-bin 4.10.5-3 depends on kde-runtime>= 4:4.10.2 in the first place?"


What you see is a description of the system you would end up with if you would APT allow to proceed. Usually this is done by showing which packages are installed/removed/upgraded and you are asked to confirm this solution. If APT can't find a solution the output looks instead like the one above showing which dependencies it couldn't satisfy after trying hard to do so. That you "had" the package installed doesn't mean that this package is still installed in the solution: APT probably decided here to remove these "leaf" packages to get the upgrade done for the important perl stuff and runs into a problem down the route. Try adding the options:
-o Debug::pkgProblemResolver=1 -o Debug::pkgDepCache::Marker=1
to your apt-get command and be amazed/amused about how APT thinks (lots of output, so do a simulation (-s) instead and read in a pager ( 2>&1 | less ).

      manul wrote:
Or, the meta-info about dependencies for a package (i.e. kde-workspace-bin 4.10.5-3) can be updated without this package version increased as well?


No. (There is a way, which works in this way by accident as it is meant for something else – and same-version uploads are not possible and also forbidden in Debian.)

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio