Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
alexkOffline
15 Post subject: Can't send e-mail from KMail 4.10.5 [Solved]  PostPosted: 14.07.2013, 20:51



Joined: 2010-10-01
Posts: 184
Location: Bay state
Status: Offline
Ever since the upgrade and migration, incoming e-mail works, but outgoing is a no-go. I've tried deleting my accounts and reconfiguring using the wizard or manually, I've tried using other smtp servers such as gmail. All sent e-mails just stay in Local Folders/outbox and never go anywhere. The "Default send method" is "Send Now".

On a test login on which I had never used KMail, sending e-mail works with the exact same server settings, after wizard setup. If I delete my $HOME/.kde folder and reconfigure KMail (and everything else in KDE), then e-mail sending works again, but I have no access to my old e-mails. I tried changing my MailDir folder to where my old e-mails are and forcing a migration by deleting some KMail migration files, but that gave me only my inbox back, no other folders.

I had two Imap accounts in KMail which I just tried deleting but this didn't help.

Any ideas how I can send e-mail from KMail AND keep my old e-mails? I cannot figure out what is preventing KMail from sending e-mails. I don't get any errors, they just sit forever in the outboox.

      Code:
$ ll -d .kde/share/apps/kmail-migrator/migration.log
-rw-r--r-- 1 alex alex 2954 Jul 14 15:50 .kde/share/apps/kmail-migrator/migration.log

$ cat .kde/share/apps/kmail-migrator/migration.log
[Sun Jul 14 15:50:21 2013] Info   : Starting migration...
[Sun Jul 14 15:50:21 2013] Info   : Beginning KMail migration...
[Sun Jul 14 15:50:21 2013] Info   : Trying to migrate 'email1@server.domain' to resource...
[Sun Jul 14 15:50:21 2013] Info   : Creating instance of type akonadi_imap_resource
[Sun Jul 14 15:50:21 2013] Info   : Created imap resource
[Sun Jul 14 15:50:21 2013] Info   : Starting cache migration for folder INBOX of account email1@server.domain
[Sun Jul 14 15:50:22 2013] Info   : Starting cache migration for folder Archive of account email1@server.domain
[Sun Jul 14 15:50:22 2013] Info   : Starting cache migration for folder Drafts of account email1@server.domain
[Sun Jul 14 15:50:22 2013] Info   : Starting cache migration for folder Junk Mail of account email1@server.domain
[Sun Jul 14 15:50:22 2013] Info   : Starting cache migration for folder Sent Items of account email1@server.domain
[Sun Jul 14 15:50:22 2013] Info   : Starting cache migration for folder Trash of account email1@server.domain
[Sun Jul 14 15:50:29 2013] Success: Migration of 'email1@server.domain' succeeded.
[Sun Jul 14 15:50:29 2013] Info   : Trying to migrate 'email2@server.domain' to resource...
[Sun Jul 14 15:50:29 2013] Info   : Creating instance of type akonadi_imap_resource
[Sun Jul 14 15:50:29 2013] Info   : Created imap resource
[Sun Jul 14 15:50:30 2013] Info   : Starting cache migration for folder INBOX of account email2@server.domain
[Sun Jul 14 15:50:30 2013] Info   : Starting cache migration for folder Archive of account email2@server.domain
[Sun Jul 14 15:50:30 2013] Info   : Starting cache migration for folder Drafts of account email2@server.domain
[Sun Jul 14 15:50:30 2013] Info   : Starting cache migration for folder Junk Mail of account email2@server.domain
[Sun Jul 14 15:50:30 2013] Info   : Starting cache migration for folder Sent Items of account email2@server.domain
[Sun Jul 14 15:50:30 2013] Info   : Starting cache migration for folder Trash of account email2@server.domain
[Sun Jul 14 15:50:30 2013] Success: Migration of 'email2@server.domain' succeeded.
[Sun Jul 14 15:50:30 2013] Info   : Trying to migrate 'server2.domain' to resource...
[Sun Jul 14 15:50:30 2013] Info   : Creating instance of type akonadi_pop3_resource
[Sun Jul 14 15:50:30 2013] Info   : Created pop3 resource
[Sun Jul 14 15:50:30 2013] Success: Migration of 'server2.domain' succeeded.
[Sun Jul 14 15:50:30 2013] Info   : Migrating local folders in '/home/alex/Mail'...
[Sun Jul 14 15:50:30 2013] Info   : Creating instance of type akonadi_mixedmaildir_resource
[Sun Jul 14 15:50:31 2013] Info   : Created local maildir resource.
[Sun Jul 14 15:50:31 2013] Info   : Keeping 'Local Folders' for default outbox, sent mail, trash, etc.
[Sun Jul 14 15:50:31 2013] Success: Local folders migrated successfully.
[Sun Jul 14 15:50:31 2013] Success: Migration successfully completed.
[Sun Jul 14 15:50:31 2013] Info   : Migration finished.


Last edited by alexk on 14.07.2013, 23:09; edited 1 time in total
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
alexkOffline
Post subject: RE: Can  PostPosted: 14.07.2013, 23:06



Joined: 2010-10-01
Posts: 184
Location: Bay state
Status: Offline
I fixed this by resetting all my KDE settings again, re-adding my primary mail account as a "KMail Mail Folder", then using the tip Local Folders is added over and over under KMail/FAQs Hints and Tips to stop the use of Local Folders. I didn't see the simple tip KMail2 doesn't send mail until my fix was well under way. If this worked, it would have been much simpler.
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
LadyCuddlesOffline
Post subject: RE: Can  PostPosted: 03.08.2013, 20:10



Joined: 2010-09-11
Posts: 5
Location: Salt Lake City, Utah
Status: Offline
I had the same problem, email came in fine, but, no outgoing mail. All the email just sat in the outbox.

I checked your "KMail2 doesn't send mail" location, alexk, and the config file was correct, so I was about to do the clean instal and rebuild my complete KMail settings, when I had stopped the akonadi server, and the akonadi server plus the sql server dropped, I figured I'd test before going all Hari-Kari on my mail configs, and just restarted KMail. It actually worked. Ever since dist-upgrading, the akonadi and sql server have been active processes of 15-20% of my CPU usage, and once I stopped, and let akonadi start up again, its been all quiet. Just lucky I guess ?
 
 View user's profile Send private message  
Reply with quote Back to top
alexkOffline
Post subject: RE: Can  PostPosted: 04.08.2013, 16:37



Joined: 2010-10-01
Posts: 184
Location: Bay state
Status: Offline
I had also stopped the Akonadi server at one point and used most of the tips in Clean start after a failed migration. I don't believe that solved the problem for me at the time, but I'm not exactly sure any more of the sequence in which I did things, so it's possible it helped. I hadn't noticed any excessive CPU usage.
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
hubiOffline
Post subject: RE: Can  PostPosted: 28.08.2013, 18:07
Moderator


Joined: 2010-09-11
Posts: 228
Location: Vienna (AT)
Status: Offline
Just for the record, because I missed this thread. This way migration worked flawlessly for me:

    1. Dist upgrade which pulls everything for kmail2
    2. Let the kmail2 migration tool do it's work
    3. Quit kmail/kontact
    4. Relogin into a new KDE session
    5. Start kmail/kontact

_________________
Tilos Rádió Budapest
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio