Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
BodOffline
Post subject: Linux 3.11-0.slh.1-aptosid-686 fails load prop. nvidia  PostPosted: 03.09.2013, 11:39



Joined: 2011-04-18
Posts: 11

Status: Offline
      Quote:
Preparing to replace linux-image-aptosid-686 3.10-25 (using .../linux-image-aptosid-686_3.11-1_i386.deb) ...
Unpacking replacement linux-image-aptosid-686 ...
Setting up linux-image-3.11-0.slh.1-aptosid-686 (3.11-1) ...
Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.11-0.slh.1-aptosid-686 /boot/vmlinuz-3.11-0.slh.1-aptosid-686
run-parts: executing /etc/kernel/postinst.d/dkms 3.11-0.slh.1-aptosid-686 /boot/vmlinuz-3.11-0.slh.1-aptosid-686
Error! Bad return status for module build on kernel: 3.11-0.slh.1-aptosid-686 (i686)
Consult /var/lib/dkms/nvidia/325.08/build/make.log for more information.

make.log from /var/lib/dkms/nvidia/325.08/build/make.log look in this link:

http://pastebin.com/Yz2ZzKTN

Video Card - GeForce 8400M GS
 
 View user's profile Send private message  
Reply with quote Back to top
DonKultOffline
Post subject: RE: Linux 3.11-0.slh.1-aptosid-686 fails load prop. nvidia  PostPosted: 03.09.2013, 12:56
Team Member


Joined: 2010-09-02
Posts: 482

Status: Offline
You are using dkms… The manual recommends dmakms (not really related, but still).
You are using outdated nvidia packaging (325.08 ) from experimental (in experimental is now 325.15; sid has 304.108).

So this isn't a valid upgrade warning. The version in sid builds fine with dmakms against slh kernels at the moment.

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
BodOffline
Post subject: RE: Linux 3.11-0.slh.1-aptosid-686 fails load prop. nvidia  PostPosted: 03.09.2013, 13:25



Joined: 2011-04-18
Posts: 11

Status: Offline
Thanks for the clarification!
 
 View user's profile Send private message  
Reply with quote Back to top
etorixOffline
Post subject: RE: Linux 3.11-0.slh.1-aptosid-686 fails load prop. nvidia  PostPosted: 03.09.2013, 14:21
Team Member


Joined: 2010-08-26
Posts: 137

Status: Offline
The version in sid builds fine with dkms against current slh kernel
 
 View user's profile Send private message  
Reply with quote Back to top
broweOffline
Post subject: RE: Linux 3.11-0.slh.1-aptosid-686 fails load prop. nvidia  PostPosted: 08.09.2013, 16:42



Joined: 2010-09-12
Posts: 155
Location: Canada
Status: Offline
Not sure if this is a similar problem or if another work-around is required:

      Code:

root@siduxbox64a:/usr/bin# apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libgl1-nvidia-legacy-304xx-glx
Suggested packages:
  nvidia-legacy-304xx-kernel-dkms nvidia-legacy-304xx-kernel-source
The following NEW packages will be installed:
  libgl1-nvidia-legacy-304xx-glx
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
76 not fully installed or removed.
Need to get 0 B/6,597 kB of archives.
After this operation, 37.0 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 465982 files and directories currently installed.)
Unpacking libgl1-nvidia-legacy-304xx-glx:amd64 (from .../libgl1-nvidia-legacy-304xx-glx_304.108-2_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libgl1-nvidia-legacy-304xx-glx_304.108-2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/tls/libnvidia-tls.so.304.108', which is also in package libgl1-nvidia-glx:amd64 304.108-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libgl1-nvidia-legacy-304xx-glx_304.108-2_amd64.deb
localepurge: Disk space freed in /usr/share/locale: 0 KiB
localepurge: Disk space freed in /usr/share/man: 0 KiB
localepurge: Disk space freed in /usr/share/gnome/help: 0 KiB
localepurge: Disk space freed in /usr/share/omf: 0 KiB
localepurge: Disk space freed in /usr/share/doc/kde/HTML: 0 KiB

Total disk space freed by localepurge: 0 KiB

E: Sub-process /usr/bin/dpkg returned an error code (1)
root@siduxbox64a:/usr/bin#

 
 View user's profile Send private message  
Reply with quote Back to top
broweOffline
Post subject: RE: Linux 3.11-0.slh.1-aptosid-686 fails load prop. nvidia  PostPosted: 08.09.2013, 22:39



Joined: 2010-09-12
Posts: 155
Location: Canada
Status: Offline
Some poor package management I'm guessing... anyway I figured out a work-around for anyone else that has a similar problem:

      Code:

dpkg -i --force-all /var/cache/apt/archives/libgl1-nvidia-legacy-304xx-glx_304.108-2_amd64.deb
apt-get install -f
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio