Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
hightimeOffline
Post subject: [SOLVED] problem starting service ssh  PostPosted: 13.10.2013, 21:43



Joined: 2010-09-11
Posts: 14
Location: USA
Status: Offline
I just did a fresh install of 2013-01. I want ssh to start at boot. Following the manual, I ran "update-rc.d ssh defaults" but it fails with this message:

      Code:
update-rc.d: using dependency based boot sequencing
innserv: warning: current start runlevel(s) (empty) of script 'ssh' overrides LSB defaults (2 3 4 5).
innserv: warning: current stop runlevel(s) (2 3 4 5) of script 'ssh' overrides LSB defaults (0 1 6).


I tried googling and searching the forum, but didn't find anything that helped.

What causes this and how do I fix it?


Last edited by hightime on 17.10.2013, 23:12; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: problem starting service ssh  PostPosted: 13.10.2013, 22:30



Joined: 2010-08-25
Posts: 724

Status: Offline
Those warnings are kind of bogus[1]. The actual problem is that the ssh service is not just removed (which would re-enable itself upon updates of openssh-server), but rather because it's (intentionally[2]) in a disabled state[3].

There are two ways to change this:
a) hit the checkbox to start ssh on boot while installing aptosid (within the installer).
b) using the afforemention enable|disable API of update-rc.d, namely "update-rc.d ssh enable". The ssh initscript will now be hooked up into the init sequence again and started upon subsequent system reboots.
c) various manual tricks avoiding the proper APIs which are not recommended.

[1] boring background info: up and until wheezy, despite dependency based (parallel) booting has been the default for 2 (almost 3) release cycles, it was mandatory to retain the ("useless") manual sequence numbers required for non-dependency based booting. Now, with wheezy out of the door, maintainers are supposed to finally put the manual (effectively unmaintained and broken) sequencing to a rest and to rely on init dependencies alone. Therefore, to "remind" maintainers, usage of this sequencing is getting noisier in various paths - however there is no functional problem with using it for now.
[2] it's an outward facing network service, which would expose potentially weak user passwords to the open internet, therefore we disable it by default for security reasons. openssh-server itself is secure, but it requires strong passwords (or better, key based auth) which are sadly not always common with users.
[3] read up the update-rc.d(8) man file about the "update-rc.d [-n] name disable|enable [ S|2|3|4|5 ]" API.
 
 View user's profile Send private message  
Reply with quote Back to top
hightimeOffline
Post subject: RE: problem starting service ssh  PostPosted: 17.10.2013, 23:11



Joined: 2010-09-11
Posts: 14
Location: USA
Status: Offline
Thank you very much. Your explanation was very helpful.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio