Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
finottiOffline
Post subject: ALPS touchpad [Solved]  PostPosted: 04.11.2013, 23:03



Joined: 2010-09-12
Posts: 312

Status: Offline
Dear all,

I've just installed aptosid on a Dell Latitude E6400.

      Code:

ut-laptop[~]$ infobash -v3
Host/Kernel/OS  "ut-laptop" running Linux 3.11-6.slh.2-aptosid-686 i686 [ aptosid 2013-01 Ἑσπερίδες - kde-full - (201305050307) ]
CPU Info        2x Intel Core2 Duo P8800 @ 3072 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 800.000 MHz ]
Videocard       NVIDIA G98M [Quadro NVS 160M]  X.Org 1.14.3  [ 1440x900@60.1hz ]
Network cards   Intel 82567LM Gigabit
                PCI device 0x4243:0x432b
Processes 165 | Uptime 9:04 | Memory 557.2/2014.0MB | HDD ST980412ASG Size 96GB (24%used) | GLX Renderer Gallium 0.4 on NV98 | GLX Version Yes | Client Shell | Infobash v3.46



Things seem to be working, but I'm having a hard time configuring the touchpad, which is an ALPS one.

The basics work, including tapping. But there is no scrolling and, my main complain, I cannot "accelerate" it: it moves way too slow, so it is hard to move from one side of the desktop to another.

Googling, it seems that there are some problems with this, and people say it seems to be recognized as a PS2 mouse. I think it might be the case (although I am not sure):

      Code:

ut-laptop[~]$ xinput --list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                        id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ HID 413c:8157                             id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=12   [slave  keyboard (3)]


I've installed "kde-config-synaptics", which gives me a TouchPad configuration on KDE's systemsettings, but it crashes as soon as I click on it (perhaps because it is not synaptics).

I've tried tpconfig, but I get:

      Code:

ut-laptop[~]$ tpconfig
Could not open PS/2 Port [/dev/psaux].


I saw this post, but did not want to install something unofficial unless I really need to.

Any help would be greatly appreciated!

Best to all,

Luis


Last edited by finotti on 09.11.2013, 02:10; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: ALPS touchpad  PostPosted: 04.11.2013, 23:25



Joined: 2010-08-25
Posts: 736

Status: Offline
Unfortunately I no longer have access to devices with ALPS touchpads, since my old P3-1000 notebook died about a year ago.

But the referenced post doesn't appear to be useful. X.org/ Debian defaults often tend to leave tapping/ scrolling unconfigured, but the functionality itself should already be there, just not configured. Adding 3rd party software should not be necessary and may be actually harmful.
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: ALPS touchpad  PostPosted: 05.11.2013, 11:22



Joined: 2010-09-12
Posts: 312

Status: Offline
Thanks, slh. But how does one configure options for an ALPS touch pad? A file in xorg.conf.d (or other configuration file)? Or with some utility? And how can I tell if it is recognized correctly?

Thanks,

Luis

P.S.: off-topic, but FYI the "Notify me when a reply is posted" in the forum is not working (and hasn't worked for a while).
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: ALPS touchpad  PostPosted: 09.11.2013, 02:09



Joined: 2010-09-12
Posts: 312

Status: Offline
OK, gpointing-device-settings seems to work! I can disable tapping and configure acceleration. Two finger scrolling is not working, but maybe the device itself is not capable.

Thanks all,

Luis
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: ALPS touchpad  PostPosted: 13.11.2013, 02:22



Joined: 2010-09-12
Posts: 312

Status: Offline
OK, here is some info, just in case anyone finds a similar problem.

gpointing-device-settings worked, but did not save the settings, so I had to use it every time. For some reason, though, a lot of the options I had eventually disappeared. I could not make them come back. I then copied 10-evdev.conf and 51-synaptics-aptosid.conf to /etc/X11/xorg.conf.d/ altered them accordingly and options came back.

Now, with the new KDE (4.11) the KDE touchpad settings (kde-config-touchpad) works now too. So, all is working.

Best to all,

Luis
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio