Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
alexkOffline
Post subject: KDE switch user and suspend don't work  PostPosted: 26.10.2014, 03:33



Joined: 2010-10-01
Posts: 192

Status: Offline
For probably a couple of months, or maybe since systemd came in, KDE switch user and suspend don't work. "systemctl suspend" works fine, but with the KDE functions, the symptoms with both switch user and suspend are the same, namely I get a "fish tank" desktop where I can see the desktop activity, can move the mouse pointer but can't interact with anything and the only solution I've found is to restart X (Ctrl-Alt-Backspace). Any ideas? This system is fully upgraded.

      Code:
$ infobash -v3
Host/Kernel/OS  "MSAK1" running Linux 3.17-1.slh.3-aptosid-amd64 x86_64 [ sidux 2009-02 Αιθήρ - kde-full - (200907141427) ]
CPU Info        4x Intel Core i5-2500K @ 6144 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 2310.257 MHz ]
Videocard       Intel 2nd Generation Core Processor Family Integrated Graphics Controller  X.Org 1.16.1  [ 1280x1024@60.02hz ]
Network cards   Intel 82579V Gigabit
                ATHEROS USB2.0 WLAN
Processes 209 | Uptime 16:10 | Memory 2091.3/15961.6MB | HDD WDC WD3200AAKS-0 Size 320GB (45%used) | Client Shell | Infobash v3.47
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
alexkOffline
Post subject: RE: KDE switch user and suspend don  PostPosted: 26.10.2014, 14:53



Joined: 2010-10-01
Posts: 192

Status: Offline
To be more precise, switching to a new user with KDE works, but I get the "fish tank" syndrome when switching back to the previous user, using the menu option or Ctrl-Alt-Fn, making that login unusable. Also, suspending the computer with KDE works, except that the computer cannot be used once woken up, because of getting the same "fish tank" syndrome. So, these two issues seem to be related.
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
AnungOffline
Post subject: RE: KDE switch user and suspend don  PostPosted: 26.10.2014, 23:09



Joined: 2010-12-01
Posts: 9

Status: Offline
You might find some answers in the KDE and Debian BTS see [1] & [2], also found [3] usefull.

going on memory and .bash_history; I tried these commands both as regular user and as root on a VT (Ctrl+Alt+F1) prefixed with
      Code:
export DISPLAY=:0
      Code:
qdbus | grep kscreenlocker_greet | xargs -I {} qdbus {} /MainApplication quit

dbus-send --session --type=method_call --dest=org.freedesktop.ScreenSaver /ScreenSaver org.freedesktop.ScreenSaver.SetActive boolean:false

I might had success (it's a while ago) killing the kscreenlocker_greet process as root to get back to a usable login dialog.

Circumvented the issue by going in System Settings > Display and Monitor > Screen Locker
and picked the "Simple Locker" as Screen locker type.

someone (#10) in [3] suggested it might be related to the chosen Window Decoration style (transparent-oxygen).
Ritesh suggests in [2] it might be caused by old settings cruft over the years that is now conflicting.

hth,

[1] https://bugs.kde.org/show_bug.cgi?id=314989
[2] https://bugs.debian.org/cgi-bin/bugrepo ... bug=733026
[3] https://bbs.archlinux.org/viewtopic.php?id=157712
 
 View user's profile Send private message  
Reply with quote Back to top
alexkOffline
Post subject: RE: KDE switch user and suspend don  PostPosted: 27.10.2014, 02:49



Joined: 2010-10-01
Posts: 192

Status: Offline
Interesting. Switching to the Simple Locker seems to have fixed this issue, both with user switching and waking up from suspend. I had been using the Desktop Widgets locker.
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio