Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
finottiOffline
Post subject: [SOLVED] SysV Slow Boot  PostPosted: 01.07.2014, 03:10



Joined: 2010-09-12
Posts: 325

Status: Offline
I previously had systemd-shim installed, and as suggested, I've purged after installing systemd-sysv.

Things seem to be working (a bit too early), but boot is now *very* slow: 1 minute and 20 second with an SSD. (It used to be incredibly fast. I'd guess 20 seconds or less.)

/var/log/messages show no messages from the beginning of the boot process until a minute later. It started at 22:41:12 (approximately). You can see it here: http://bpaste.net/show/423754/.

The screen also does not show much during boot, just systemd.fsck messages (and stays there for a long time).

The system has been fully updated today (06/30).

Also, it seems that the virtual consoles (Ctrl+Alt+Fn) are gone, except for F1. Can I get them back?

Here is the system info:

      Code:

root@debian[/home/finotti]# infobash -v3
Host/Kernel/OS  "debian" running Linux 3.15-2.slh.6-aptosid-amd64 x86_64 [ aptosid 2010-02 Κῆρες - kde-full - (201009132215) ]
CPU Info        8x Intel Core i7-4771 @ 8192 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 3618.808 MHz ]
Videocard       Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller     [  ]
Network cards   Intel I217-V
Processes 227 | Uptime 20min | Memory 2003.9/15738.1MB | HDD WDC WD10EALS-00Z,Samsung SSD 840,WDC WD20EARX-00P,WDC WD20EARX-00P,WDC WD1500ADFD-0 Size 5407GB (38%used) | Client Shell | Infobash v3.47


P.S.: Probably not related, but just in case: I just installed Debian Stable in a different partition. It seems that it messed up grub, as it would not boot. I logged in aptosid and updated grub, which worked (aptosid and Debian boot now), but booting after the install was when I've first noticed it the problem described. (I hadn't rebooted in a while...) I checked that I had already systemd-sysv installed (which surprised me) and then updated the system and purged systemd-shim to see if that was the problem, but it did not change anything.


Last edited by finotti on 01.07.2014, 10:20; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: SysV Slow Boot  PostPosted: 01.07.2014, 03:33



Joined: 2010-08-25
Posts: 758

Status: Offline
"journalctl -b" might shed some light into this, probably it's waiting for a timeout for some failing initscript or unit (systemd is a bit pickier about broken settings). Hopefully you'll see an error message (often coloured in red by journalctl) or at least see what happens immediately before- and after the gap.

Regarding grub2, the ABI between bootsector (generic to the whole drive) and /boot/grub/ (specific to each linux installation) needs to match exactly. By installing Debian stable, you probably let it install itself into the bootsector, which made bootsector and /boot/grub/ of Debian stable use grub2 1.99-27+deb7u2, while aptosid is on 2.02~beta2-10 - which are incompatible to each other (in that situation you can boot the last installed OS/ grub, but not the other one). There are two options for this:
- installing grub2 into the partition, rather than the MBR (master boot record). But this is strongly discouraged with grub2 and is also likely not to work anymore (grub2 stage1 has gotten a bit large).
- removing all grub packages from the secondary OS installs (wheezy?) and letting os-prober on your primary OS (aptosid?) detect wheezy from within the unstable/sid grub2 installation/ boot menu.
If this remains to be an issue (if you encounter a grub update in wheezy, doesn't happen very often, but it's not impossible either, it will overwrite aptosid's/ unstable/sid's grub again, breaking booting again - therefore it's better to remove the grub package from your secondary installs (wheezy?)), it would be better to split off that discussion from this thread, as both issues are unrelated.
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: SysV Slow Boot  PostPosted: 01.07.2014, 10:22



Joined: 2010-09-12
Posts: 325

Status: Offline
Thanks, slh. The installation formatted the swap partition, changing the UUID (compared to fstab), and it hanged there. Fixing it made boot incredibly quick, now. I just wish I could see the messages as it boots (as before).

As far as grub goes, I will take your advice and remove it from stable.

Also, the consoles (ttyn) are back... (I don't know what happened, but it is working now.)

Thanks, again!
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: SysV Slow Boot  PostPosted: 01.07.2014, 11:57



Joined: 2010-08-25
Posts: 758

Status: Offline
Yes, while sysvinit (wrongly) ignored missing partitions (and swap is the perfect culprit here, as you usually won't notice it missing - while it's also a prime target for distributions to reformat while installing, just 'cause (yes, we do that as well[1])) defined in fstab, systemd (rightfully) throws a hitch.

[1] there are mostly two reasons for always reformatting the swap partitions while installing linux, old mkswap versions didn't set a UUID for swap partitions, which is required to swapon these days and to clear stale hibernation signatures (or similar) from an existing swap. So while there are good (required) reasons for reformatting swap, it comes at the cost of invalidating its UUID for distributions installed in parallel.
 
 View user's profile Send private message  
Reply with quote Back to top
CarnophageOffline
Post subject: RE: SysV Slow Boot  PostPosted: 02.07.2014, 21:17



Joined: 2010-09-12
Posts: 59

Status: Offline
As for messages during boot, this did the trick for me
      Code:

diff --git a/default/grub b/default/grub
index b2f1931..4b89a86 100644
--- a/default/grub
+++ b/default/grub
@@ -6,7 +6,7 @@
 GRUB_DEFAULT=0
 GRUB_TIMEOUT=3
 GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
-GRUB_CMDLINE_LINUX_DEFAULT="quiet"
+GRUB_CMDLINE_LINUX_DEFAULT="loglevel=4"
 GRUB_CMDLINE_LINUX=""
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
finottiOffline
Post subject: Re: RE: SysV Slow Boot  PostPosted: 03.07.2014, 10:09



Joined: 2010-09-12
Posts: 325

Status: Offline
      Carnophage wrote:
As for messages during boot, this did the trick for me
      Code:

diff --git a/default/grub b/default/grub
index b2f1931..4b89a86 100644
--- a/default/grub
+++ b/default/grub
@@ -6,7 +6,7 @@
 GRUB_DEFAULT=0
 GRUB_TIMEOUT=3
 GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
-GRUB_CMDLINE_LINUX_DEFAULT="quiet"
+GRUB_CMDLINE_LINUX_DEFAULT="loglevel=4"
 GRUB_CMDLINE_LINUX=""


That's great! Thanks!
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio