Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
LatOffline
Post subject: [Solved]apt-transport-https wants to be installed  PostPosted: 03.07.2014, 17:48



Joined: 2010-09-19
Posts: 164

Status: Offline
Good day,
I ran today apt-get update and got a notification inquiring whether apt-transport-https was installed or not. If I try to install that package I get an error that it can't be authenticated. Should I just install it anyways?
Thank you
      Code:
apt-get update
...
...
E: The method driver /usr/lib/apt/methods/https could not be found.
N: Is the package apt-transport-https installed?


root@gg4:/home/sfe# apt-get install apt-transport-https
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libapt-pkg4.13
The following NEW packages will be installed:
  apt-transport-https libapt-pkg4.13
0 upgraded, 2 newly installed, 0 to remove and 219 not upgraded.
Need to get 922 kB of archives.
After this operation, 3,305 kB of additional disk space will be used.
Do you want to continue? [Y/n]
WARNING: The following packages cannot be authenticated!
  libapt-pkg4.13 apt-transport-https
Install these packages without verification? [y/N] n
E: Some packages could not be authenticated


apt-cache policy debian-archive-keyring
debian-archive-keyring:
  Installed: 2012.4
  Candidate: 2012.4
  Version table:
 *** 2012.4 0
        500 http://ftp.us.debian.org/debian/ testing/main amd64 Packages
        500 http://ftp.us.debian.org/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status



Last edited by Lat on 04.07.2014, 03:30; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: apt-transport-https wants to be installed  PostPosted: 03.07.2014, 22:56



Joined: 2010-08-25
Posts: 736

Status: Offline
One of your local mirrors listed in /etc/apt/sources.list.d/*.list or /etc/apt/sources.list probably uses https (not a very common scenario for package mirrors), in which case you need the package mentioned above (apt versions below 0.9.15.3 fell back to plain http, if https was unavailable).

Regarding the unauthenticated warning, when running apt-get update for a https mirror without apt-transport-https installed, you probably invalidated your cached (sources) data, as a side effect invalidating the signatures - this should fix itself after running "apt-get update" again (you might have to revert to a non-https mirror temporarily).
 
 View user's profile Send private message  
Reply with quote Back to top
LatOffline
Post subject: RE: apt-transport-https wants to be installed  PostPosted: 04.07.2014, 02:05



Joined: 2010-09-19
Posts: 164

Status: Offline
Ok, I took all the sources files and started putting them back one by one. It turned out that deb http://repository.spotify.com stable non-free is the culprit ( http://repository.spotify.com directs to https://www.spotify.com/us/ ). Did they drop the Linux repo? :<

Thank you for your attention
 
 View user's profile Send private message  
Reply with quote Back to top
ghstryderOffline
Post subject: RE: apt-transport-https wants to be installed  PostPosted: 04.07.2014, 14:02



Joined: 2010-09-12
Posts: 95
Location: Detroit
Status: Offline
It seems they changed the address. Change to:
      Code:
deb http://repository-origin.spotify.com stable non-free
 
 View user's profile Send private message  
Reply with quote Back to top
LatOffline
Post subject: Re: RE: apt-transport-https wants to be installed  PostPosted: 05.07.2014, 04:04



Joined: 2010-09-19
Posts: 164

Status: Offline
      ghstryder wrote:
It seems they changed the address.
Thank you!

PS: Spotify Release notes
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio