Rootserver Sponsor

webtropia"

Donations

Please support your operating system's further development:

donate"

Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
casaOffline
Post subject: d-u with Force-Loopbreak?  PostPosted: 22.05.2015, 09:00



Joined: 2011-12-01
Posts: 8

Status: Offline
Just tried to run a dist-upgrade on another machine.
Received an error message:

      Quote:

E: Dieser Installationslauf erfordert, dass vorübergehend das essentielle Paket util-linux:i386 aufgrund einer Konflikt-/Vor-Abhängigkeitsschleife entfernt wird. Das ist oft schlimm, aber wenn Sie es wirklich tun wollen, aktivieren Sie bitte die Option APT::Force-LoopBreak.
E: Internal Error, Could not early remove util-linux:i386 (2)


Should I stay (wait) or should I go (doing it)?

Regards,
casa
 
 View user's profile Send private message  
Reply with quote Back to top
Luis_POffline
Post subject: Same error  PostPosted: 22.05.2015, 15:04



Joined: 2010-09-11
Posts: 171
Location: Barcelona, Spain
Status: Offline
I've got the same error on amd64. The question is also the same: is wise to continue?
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: Same error  PostPosted: 22.05.2015, 17:07



Joined: 2010-08-25
Posts: 949

Status: Offline
While that should be resolved by now, you can circumvent the problem by
      Code:
# apt-get update
# apt-get install util-linux/testing sysv-rc/testing sysvinit-utils/testing
# apt-get dist-upgrade
(testing needs to be enabled in addition to unstable in your /etc/apt/sources.list.d/debian.list)
 
 View user's profile Send private message  
Reply with quote Back to top
casaOffline
Post subject: RE: Same error  PostPosted: 22.05.2015, 17:50



Joined: 2011-12-01
Posts: 8

Status: Offline
Thanks for the info.
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: Same error  PostPosted: 22.05.2015, 19:33



Joined: 2010-08-25
Posts: 949

Status: Offline
Just to be clear, util-linux 2.26.2-5 (uploaded around noon today, which should have reached a mirror near you by now) should fix this problem without any manual interaction (so with a plain apt-get update && apt-get dist-upgrade).
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio