Rootserver Sponsor

webtropia"

Donations

Please support your operating system's further development:

donate"

Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
nowhiskeyOffline
Post subject: ceni does not 'remember' network settings  PostPosted: 09.09.2015, 00:40



Joined: 2010-10-09
Posts: 18

Status: Offline
hallo,

after i did a d-u, i have to run ceni every time after i boot a computer. otherwise no network.
well, before the d-u i would run ceni, and as long my machine had a access to the same network, as on the last boot, it will be simly connected. now this behaviour changed, and after loggin into x (xfce) there is no network connection until i run ceni another time. after that, all works good.

anyone has an idea, what changed here with ceni. it used to remember the last network settings and autoconnect, but it does not anymore.

cheers,

doc
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: ceni does not  PostPosted: 09.09.2015, 01:00



Joined: 2010-08-25
Posts: 949

Status: Offline
Ceni is nothing but a GUI to configure ifupdown via /etc/network/interfaces, it's not in the business of actually managing interface state (e.g. on boot).

In order to debug this, please post your /etc/network/interfaces - before and after running Ceni (after a fresh reboot); make sure to obfuscate eventual wlan keys or other personal information (just replace those values with XXX).
 
 View user's profile Send private message  
Reply with quote Back to top
nowhiskeyOffline
Post subject:   PostPosted: 09.09.2015, 01:48



Joined: 2010-10-09
Posts: 18

Status: Offline
thanks slh for taking time on this.

well, the /etc/network/interfaces looks pretty the same bevore and after running ceni (after a fresh reboot).

bevore:
      Code:

# /etc/network/interfaces - configuration file for ifup(8), ifdown(8)

# The loopback interface
auto lo
iface lo inet loopback

iface default inet dhcp

#auto eth1
#iface eth1 inet dhcp
#       wpa-psk XXXXX
#       wpa-ssid XXXXXX

allow-hotplug eth0
iface eth0 inet dhcp

allow-hotplug eth1
iface eth1 inet dhcp
        wpa-key-mgmt NONE
        wpa-ssid AP1.freifunk.net


and after:

      Code:

# /etc/network/interfaces - configuration file for ifup(8), ifdown(8)

# The loopback interface
auto lo
iface lo inet loopback

iface default inet dhcp

#auto eth1
#iface eth1 inet dhcp
#       wpa-psk XXXXXX
#       wpa-ssid XXXXXX

allow-hotplug eth0
iface eth0 inet dhcp

allow-hotplug eth1
iface eth1 inet dhcp
        wpa-key-mgmt NONE
        wpa-ssid AP1.freifunk.net



have to go to sleep now.

see ya and thanks for trying to help,

doc
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject:   PostPosted: 09.09.2015, 02:17



Joined: 2010-08-25
Posts: 949

Status: Offline
You have a stray "iface default inet dhcp" in line 7, which needs to be removed.

Furthermore you're up for routing trouble, if you enable two different interfaces (eth0 and eth1) each propating its own default route/ gateway via dhcp. Make sure comment out either "allow-hotplug eth0" or "allow-hotplug eth1", only one of them (the preferred default) can be enabled that way (e.g. comment out "allow-hotplug eth1" use "ifdown eth0" and "ifup eth1", if you want to switch to wlan - "ifdown eth1" and "ifup eth0", if you want to go back to the wire).

Unless you do rather specific expert configurations, there can only be one active network interface - so either eth0 XOR eth1. What you accomplish by continuously calling Ceni is just making sure that the last configured interface temporarily wins the battle for the default route, by breaking the other interface (until your DHCP lease times out, which then rolls the dice again) - and that's bad practice.
 
 View user's profile Send private message  
Reply with quote Back to top
nowhiskeyOffline
Post subject:   PostPosted: 09.09.2015, 09:24



Joined: 2010-10-09
Posts: 18

Status: Offline
hallo slh,

i am not sure that i completely understood what the file has to look like.

anyway, i edited it and in the moment it looks bevor and after running ceni (after a fresh reboot) like this:

      Code:


# /etc/network/interfaces - configuration file for ifup(8), ifdown(8)

# The loopback interface
auto lo
iface lo inet loopback


#auto eth1
#iface eth1 inet dhcp
#       wpa-psk singmitmir
#       wpa-ssid Monster Ronson's

#allow-hotplug eth0
#iface eth0 inet dhcp

allow-hotplug eth1
iface eth1 inet dhcp
        wpa-key-mgmt NONE
        wpa-ssid AP1.freifunk.net


but still i am not getting autoconnected after booting.
yes, the prefered interface here is eth1 (wlan).


cheers,

doc
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio