Rootserver Sponsor

webtropia"

Donations

Please support your operating system's further development:

donate"

Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
burkhardOffline
19 Post subject: [workaround] hpaio and sane not working after d-u  PostPosted: 08.11.2015, 13:05



Joined: 2011-01-15
Posts: 8

Status: Offline
After the last dist-upgrade of my 64Bit system this week I encountered that my HP 5520 was no longer supported by sane.
Versions:

libsane-hpaio 3.14.6-1+b3 amd64
sane 1.0.14-11 amd64

While printing was no problem I guessed this would not be a hardware or a connection problem (USB).
A "scanimage -L" told be the were no devices found, so did xsane.
Using strace while starting scanimage I fond this line:

open("/usr/lib/x86_64-linux-gnu/sane/libsane-hpaio.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)

The libsane-hpaio package places the libs only in /usr/lib/sane/libsane-hpaio.so.1.0.0, so sane is not able to find it.
Workaround is here to place a symlink in usr/lib/x86_64-linux-gnu/sane/

ln -s /usr/lib/sane/libsane-hpaio.so.1.0.0 /usr/lib/x86_64-linux-gnu/sane/libsane-hpaio.so.1

Afterwards sanning worked again perfectly.
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: [workaround] hpaio and sane not working after d-u  PostPosted: 08.11.2015, 16:55



Joined: 2010-08-25
Posts: 949

Status: Offline
That is a rather dangerous workaround, the SONAME of libraries changes because they're not binary-compatible (not necessarily obviously at first sight). If you force it in via symlinks like this, chances are very high that you will experiences crashes - perhaps not all the time, but whenever library functions whose signature has changed are called (and it can become even worse, if you load libraries of different SONAMEs into one process, then all hell can break loose); SONAMEs aren't there for fun, they're used to prevent breakage.

If the SONAME bump wasn't properly reflected in the packaging (by changing the package relation), this is a bug, which needs to be fixed by adapting them and rebuilding depending packages as needed - but not by introducing spurious symlinks.
 
 View user's profile Send private message  
Reply with quote Back to top
burkhardOffline
Post subject: RE: [workaround] hpaio and sane not working after d-u  PostPosted: 08.11.2015, 21:51



Joined: 2011-01-15
Posts: 8

Status: Offline
Thanks a lot for your kindly hint. Of course, I do agree not to spoil a system package by placing a symlink (without bad need). I am always happy about people who are able to help each other in friendliness. Smile
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio