Rootserver Sponsor

webtropia"

Donations

Please support your operating system's further development:

donate"

Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
alexkOffline
Post subject: RE: KDE Transition  PostPosted: 20.08.2016, 01:16



Joined: 2010-10-01
Posts: 288

Status: Offline
KDE appears to be in transition again, with 202 packages to be removed.
      Code:
apt-get -d dist-upgrade 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  accountwizard akregator ark baloo-kf5 bluedevil breeze digikam-doc dolphin dragonplayer ffmpegthumbs filelight
  frameworkintegration gdebi-kde gwenview k4dirstat kactivitymanagerd kaddressbook kaffeine kamera kate kcalc kcharselect
  kde-baseapps kde-cli-tools kde-config-cron kde-config-gtk-style kde-config-mailtransport kde-config-screenlocker
  kde-config-sddm kde-plasma-desktop kde-style-breeze kde-style-breeze-qt4 kde-style-oxygen-qt5 kde-style-qtcurve-qt5 kded5
  kdenetwork-filesharing kdepim-addons kdepim-runtime kdepim-themeeditors kf5-kdepimlibs-kio-plugins kgamma5 khelpcenter
  khelpcenter4 khotkeys kinfocenter kinit kio kio-extras kleopatra kmail kmenuedit knotes konsole konsole-kpart konversation
  korganizer kross kscreen ksshaskpass kstars ksysguard ktexteditor-katepart ktimer ktnef kwalletmanager kwin-common
  kwin-wayland kwin-wayland-backend-drm kwin-x11 kwrite libkf5akonadiagentbase5 libkf5akonadicalendar5 libkf5akonadicontact5
  libkf5akonadicore-bin libkf5akonadicore5 libkf5akonadimime5 libkf5akonadisearchdebug5 libkf5akonadisearchpim5
  libkf5akonadiwidgets5 libkf5alarmcalendar5 libkf5baloo5 libkf5baloowidgets5 libkf5bookmarks5 libkf5calendarcore5
  libkf5calendarsupport5 libkf5calendarutils5 libkf5declarative5 libkf5emoticons-bin libkf5emoticons5 libkf5eventviews5
  libkf5gapicalendar5 libkf5gapicontacts5 libkf5gapicore5 libkf5gapitasks5 libkf5globalaccel-bin libkf5globalaccelprivate5
  libkf5grantleetheme-plugins libkf5grantleetheme5 libkf5gravatar5 libkf5iconthemes-bin libkf5iconthemes5
  libkf5identitymanagement5 libkf5imap5 libkf5incidenceeditor-bin libkf5incidenceeditor5 libkf5jsembed5
  libkf5kaddressbookgrantlee5 libkf5kcmutils5 libkf5kdelibs4support5 libkf5kdelibs4support5-bin libkf5kdepimdbusinterfaces5
  libkf5khtml-bin libkf5khtml5 libkf5kiocore5 libkf5kiofilewidgets5 libkf5kiogui5 libkf5kiontlm5 libkf5kiowidgets5
  libkf5kmanagesieve5 libkf5kontactinterface5 libkf5krosscore5 libkf5krossui5 libkf5ksieveui5 libkf5libkdepim-plugins
  libkf5libkdepim5 libkf5libkleo5 libkf5mailcommon-plugins libkf5mailcommon5 libkf5mailimporter5 libkf5mailtransport5
  libkf5messagecomposer5 libkf5messagecore5 libkf5messagelist5 libkf5messageviewer5 libkf5newstuff5 libkf5notifyconfig5
  libkf5parts-plugins libkf5parts5 libkf5people5 libkf5peoplewidgets5 libkf5pimcommon-plugins libkf5pimcommon5
  libkf5pimtextedit5 libkf5plasma5 libkf5plasmaquick5 libkf5quickaddons5 libkf5runner5 libkf5style5 libkf5su-bin libkf5su5
  libkf5syndication5 libkf5templateparser5 libkf5texteditor5 libkf5textwidgets5 libkf5tnef5 libkf5wallet-bin libkf5wallet5
  libkf5webkit5 libkf5xmlgui-bin libkf5xmlgui5 libkf5xmlrpcclient5 libkfontinst5 libkfontinstui5 libkolab1 libkscreenlocker5
  libkwalletbackend5-5 libkwin4-effect-builtins1 libpowerdevilcore2 libtaskmanager5 libweather-ion7 milou muon-notifier
  muon-updater plasma-dataengines-addons plasma-desktop plasma-discover-private plasma-discover-updater plasma-framework
  plasma-integration plasma-pa plasma-runners-addons plasma-wallpapers-addons plasma-widgets-addons plasma-workspace
  polkit-kde-agent-1 powerdevil print-manager python3-pykde4 qapt-batch qml-module-org-kde-draganddrop
  qml-module-org-kde-extensionplugin qml-module-org-kde-kcoreaddons qml-module-org-kde-kio qml-module-org-kde-kquickcontrols
  qml-module-org-kde-kquickcontrolsaddons qml-module-org-kde-kwindowsystem qml-module-org-kde-runnermodel sddm
  sddm-theme-breeze systemsettings user-manager yakuake
The following NEW packages will be installed:
  libtidy5 linux-image-4.7.0-1.slh.2-aptosid-amd64
The following packages have been kept back:
  digikam-private-libs konq-plugins libavcodec-extra showfoto
The following packages will be upgraded:
  appstream apt apt-transport-https apt-utils avidemux avidemux-common avidemux-plugins avidemux-qt binutils
  breeze-icon-theme dh-python djvulibre-bin djvulibre-desktop fonts-liberation gir1.2-ges-1.0 gir1.2-gst-plugins-base-1.0
  gir1.2-gstreamer-1.0 gir1.2-gtk-3.0 gnustep-base-common gnustep-base-runtime gstreamer1.0-alsa gstreamer1.0-libav
  gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio gstreamer1.0-x
  gtk-update-icon-cache gxmessage icedove icu-devtools kdelibs-bin kdelibs5-data kdelibs5-plugins kdenlive-data kdoctools
  kdoctools5 konsole4-kpart kpackagetool5 libappstream3 libappstreamqt1 libapt-inst2.0 libapt-pkg5.0 libdjvulibre-text
  libdjvulibre21 libgcrypt20 libgcrypt20:i386 libgcrypt20-dev libges-1.0-0 libgnustep-base1.24
  libgstreamer-plugins-base1.0-0 libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0 libgstreamer1.0-0:i386 libgtk-3-0
  libgtk-3-bin libgtk-3-common libicu57 libicu57:i386 libinput-bin libinput10 libkcmutils4 libkde3support4 libkdeclarative5
  libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkf5archive5 libkf5attica5 libkf5auth-data
  libkf5auth5 libkf5bluezqt-data libkf5bluezqt6 libkf5codecs-data libkf5codecs5 libkf5completion-data libkf5completion5
  libkf5config-bin libkf5config-data libkf5configcore5 libkf5configgui5 libkf5configwidgets-data libkf5configwidgets5
  libkf5coreaddons-data libkf5coreaddons5 libkf5crash5 libkf5dbusaddons-bin libkf5dbusaddons-data libkf5dbusaddons5
  libkf5dnssd-data libkf5dnssd5 libkf5filemetadata-bin libkf5filemetadata-data libkf5filemetadata3 libkf5guiaddons5
  libkf5i18n-data libkf5i18n5 libkf5idletime5 libkf5itemmodels5 libkf5itemviews-data libkf5itemviews5 libkf5jobwidgets-data
  libkf5jobwidgets5 libkf5networkmanagerqt6 libkf5notifications-data libkf5notifications5 libkf5package-data libkf5package5
  libkf5plotting5 libkf5pty-data libkf5pty5 libkf5service-bin libkf5service-data libkf5service5 libkf5solid5
  libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5 libkf5threadweaver5 libkf5unitconversion-data
  libkf5unitconversion5 libkf5waylandclient5 libkf5waylandserver5 libkf5widgetsaddons-data libkf5widgetsaddons5
  libkf5windowsystem-data libkf5windowsystem5 libkfile4 libkhtml5 libkidletime4 libkio5 libkjsapi4 libkjsembed4
  libkmediaplayer4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkpathsea6 libkprintutils4
  libkpty4 libkrosscore4 libktexteditor4 libmlt++3 libmlt-data libmlt6 libnepomuk4 libnepomukquery4a libnepomukutils4
  libpam-systemd libpcre16-3 libpcre3 libpcre3:i386 libpcre3-dev libpcre32-3 libpcrecpp0v5 libplasma3 libsolid4 libsystemd0
  libsystemd0:i386 libthreadweaver4 libudev-dev libudev1 libudev1:i386 libvirt-clients libvirt-daemon libvirt-daemon-system
  libvirt0 linux-image-aptosid-amd64 melt mess-data nano oxygen-icon-theme plasma-discover-common python-debian
  python-gst-1.0 python-pyparsing python3-debian python3-gst-1.0 python3-pyparsing qml-module-org-kde-bluezqt
  qml-module-org-kde-solid systemd systemd-sysv ttf-liberation udev
191 upgraded, 2 newly installed, 202 to remove and 4 not upgraded.
Need to get 206 MB of archives.
After this operation, 128 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
alexkOffline
Post subject: RE: KDE Transition  PostPosted: 25.08.2016, 02:31



Joined: 2010-10-01
Posts: 288

Status: Offline
Now there are still 15 packages to be removed. It seems like we should still wait to upgrade:
      Code:
Calculating upgrade... Done
The following packages will be REMOVED:
  digikam-doc kde-plasma-desktop khelpcenter khelpcenter4 kinfocenter kio-extras libkf5jsembed5 libkf5khtml-bin libkf5khtml5
  plasma-desktop plasma-widgets-addons plasma-workspace sddm sddm-theme-breeze systemsettings
The following NEW packages will be installed:
  kactivities-bin libaqhbci23 libboost-program-options1.61.0 libkf5sane-data libkf5sane5 libtidy5
  linux-image-4.7.0-2.slh.1-aptosid-amd64 qml-module-org-kde-activities
The following packages have been kept back:
  digikam-private-libs konq-plugins libavcodec-extra plasma-discover-common showfoto
The following packages will be upgraded:
  appstream apt apt-transport-https apt-utils avidemux avidemux-common avidemux-plugins avidemux-qt baloo-kf5 binutils
  breeze-icon-theme browser-plugin-gnash clementine cmake cmake-data cpp-6 debian-goodies dh-python dh-strip-nondeterminism
  djvulibre-bin djvulibre-desktop dkms fontconfig fontconfig-config fonts-liberation frameworkintegration freeglut3
  freeglut3:i386 g++-6 gcc-6 gcc-6-base gcc-6-base:i386 gcj-6-jre-lib gir1.2-ges-1.0 gir1.2-gst-plugins-base-1.0
  gir1.2-gstreamer-1.0 gir1.2-gtk-3.0 gnash gnash-common gnustep-base-common gnustep-base-runtime gscan2pdf
  gstreamer1.0-alsa gstreamer1.0-libav gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly
  gstreamer1.0-pulseaudio gstreamer1.0-x gtk-update-icon-cache gxmessage icedove icu-devtools kde-runtime kde-runtime-data
  kdebase-runtime kded5 kdelibs-bin kdelibs5-data kdelibs5-plugins kdenlive-data kdoctools kdoctools5 kinit kio klash
  konsole4-kpart kpackagetool5 kross ktexteditor-data ktexteditor-katepart libappstream3 libappstreamqt1 libapt-inst2.0
  libapt-pkg5.0 libaqbanking-data libaqbanking35 libaqbanking35-plugins libaqebics0 libaqofxconnect7 libasan3 libatomic1
  libc-bin libc-dev-bin libc-l10n libc6 libc6:i386 libc6-dbg libc6-dev libc6-dev-i386 libc6-i386 libcc1-0 libcilkrts5
  libcmis-0.5-5v5 libcrack2 libcurses-perl libdjvulibre-text libdjvulibre21 libevdev2 libfile-stripnondeterminism-perl
  libfontconfig1 libfontconfig1:i386 libfontconfig1-dev libgcc-6-dev libgcc1 libgcc1:i386 libgcc1-dbg libgcj17 libgcrypt20
  libgcrypt20:i386 libgcrypt20-dev libgeoip1 libges-1.0-0 libgfortran3 libgnustep-base1.24 libgnutls30 libgnutls30:i386
  libgomp1 libgomp1:i386 libgstreamer-plugins-base1.0-0 libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0
  libgstreamer1.0-0:i386 libgtk-3-0 libgtk-3-bin libgtk-3-common libicu57 libicu57:i386 libinput-bin libinput10
  libio-socket-ssl-perl libitm1 libjbig2dec0 libjsoncpp1 libkcmutils4 libkde3support4 libkdeclarative5 libkdecore5 libkdesu5
  libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkf5activities5 libkf5archive5 libkf5attica5 libkf5auth-data
  libkf5auth5 libkf5baloo5 libkf5balooengine5 libkf5bluezqt-data libkf5bluezqt6 libkf5bookmarks-data libkf5bookmarks5
  libkf5calendarevents5 libkf5codecs-data libkf5codecs5 libkf5completion-data libkf5completion5 libkf5config-bin
  libkf5config-data libkf5configcore5 libkf5configgui5 libkf5configwidgets-data libkf5configwidgets5 libkf5coreaddons-data
  libkf5coreaddons5 libkf5crash5 libkf5dbusaddons-bin libkf5dbusaddons-data libkf5dbusaddons5 libkf5declarative-data
  libkf5declarative5 libkf5dnssd-data libkf5dnssd5 libkf5emoticons-bin libkf5emoticons-data libkf5emoticons5
  libkf5filemetadata-bin libkf5filemetadata-data libkf5filemetadata3 libkf5globalaccel-bin libkf5globalaccel-data
  libkf5globalaccel5 libkf5globalaccelprivate5 libkf5guiaddons5 libkf5i18n-data libkf5i18n5 libkf5iconthemes-bin
  libkf5iconthemes-data libkf5iconthemes5 libkf5idletime5 libkf5itemmodels5 libkf5itemviews-data libkf5itemviews5
  libkf5jobwidgets-data libkf5jobwidgets5 libkf5js5 libkf5kcmutils-data libkf5kcmutils5 libkf5kdelibs4support-data
  libkf5kdelibs4support5 libkf5kdelibs4support5-bin libkf5kiocore5 libkf5kiofilewidgets5 libkf5kiogui5 libkf5kiontlm5
  libkf5kiowidgets5 libkf5krosscore5 libkf5krossui5 libkf5networkmanagerqt6 libkf5newstuff-data libkf5newstuff5
  libkf5notifications-data libkf5notifications5 libkf5notifyconfig-data libkf5notifyconfig5 libkf5package-data
  libkf5package5 libkf5parts-data libkf5parts-plugins libkf5parts5 libkf5people-data libkf5people5 libkf5peoplebackend5
  libkf5peoplewidgets5 libkf5plasma5 libkf5plasmaquick5 libkf5plotting5 libkf5pty-data libkf5pty5 libkf5quickaddons5
  libkf5runner5 libkf5service-bin libkf5service-data libkf5service5 libkf5solid5 libkf5solid5-data libkf5sonnet5-data
  libkf5sonnetcore5 libkf5sonnetui5 libkf5style5 libkf5su-bin libkf5su-data libkf5su5 libkf5texteditor5
  libkf5textwidgets-data libkf5textwidgets5 libkf5threadweaver5 libkf5unitconversion-data libkf5unitconversion5
  libkf5wallet-bin libkf5wallet-data libkf5wallet5 libkf5waylandclient5 libkf5waylandserver5 libkf5webkit5
  libkf5widgetsaddons-data libkf5widgetsaddons5 libkf5windowsystem-data libkf5windowsystem5 libkf5xmlgui-bin
  libkf5xmlgui-data libkf5xmlgui5 libkf5xmlrpcclient-data libkf5xmlrpcclient5 libkfile4 libkhtml5 libkidletime4 libkio5
  libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4
  libkpathsea6 libkprintutils4 libkpty4 libkrosscore4 libktexteditor4 libkwalletbackend5-5 liblsan0 libltdl-dev libltdl7
  libltdl7:i386 liblua50 liblua50-dev liblualib50 liblualib50-dev liblucene2-java libmikmod3 libmlt++3 libmlt-data libmlt6
  libmpx2 libnepomuk4 libnepomukquery4a libnepomukutils4 libnetfilter-conntrack3 libobjc4 libp11-kit-dev libp11-kit0
  libp11-kit0:i386 libpam-systemd libpcre16-3 libpcre3 libpcre3:i386 libpcre3-dev libpcre32-3 libpcrecpp0v5 libplasma3
  libqmobipocket1 libquadmath0 libsolid4 libsoprano-dev libsoprano4 libspectre1 libstdc++-6-dev libstdc++6 libstdc++6:i386
  libsystemd0 libsystemd0:i386 libtext-csv-perl libthreadweaver4 libtool libtool-bin libtorrent-rasterbar9 libtsan0
  libubsan0 libudev-dev libudev1 libudev1:i386 libvirt-clients libvirt-daemon libvirt-daemon-system libvirt0 libvlc5
  libvlccore8 libxkbcommon-x11-0 libxkbcommon0 linux-image-aptosid-amd64 locales lua50 melt mess-data multiarch-support
  mythes-en-us nano oxygen-icon-theme p11-kit p11-kit-modules plasma-framework plasma-scriptengine-javascript
  python-acoustid python-debian python-gst-1.0 python-libtorrent python-lockfile python-lxml python-pyparsing python3-debian
  python3-gst-1.0 python3-pyparsing qml-module-org-kde-bluezqt qml-module-org-kde-draganddrop
  qml-module-org-kde-extensionplugin qml-module-org-kde-kcoreaddons qml-module-org-kde-kio qml-module-org-kde-kquickcontrols
  qml-module-org-kde-kquickcontrolsaddons qml-module-org-kde-kwindowsystem qml-module-org-kde-runnermodel
  qml-module-org-kde-solid rcconf rsyslog soprano-daemon sweeper systemd systemd-sysv ttf-liberation udev vlc vlc-data
  vlc-nox
387 upgraded, 8 newly installed, 15 to remove and 5 not upgraded.
Need to get 424 MB of archives.
After this operation, 95.4 MB of additional disk space will be used.
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
slhOffline
Post subject: RE: KDE Transition  PostPosted: 25.08.2016, 05:03



Joined: 2010-08-25
Posts: 949

Status: Offline
Indeed, among them the most important ones.
 
 View user's profile Send private message  
Reply with quote Back to top
BTOffline
Post subject: RE: KDE Transition  PostPosted: 25.08.2016, 17:53



Joined: 2010-09-12
Posts: 51
Location: Belgium
Status: Offline
only 2 packages remaining to be removed :

The following packages will be REMOVED:
digikam libnss3-1d

Do we have to wait for digikam ?
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: KDE Transition  PostPosted: 25.08.2016, 19:05



Joined: 2010-08-25
Posts: 949

Status: Offline
digikam is a classical leaf package, it's not required for KDE (but there are certainly users who don't want to miss it).
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: KDE Transition  PostPosted: 25.08.2016, 19:13



Joined: 2010-09-12
Posts: 470

Status: Offline
I haven't DUed yet, but as a FYI, it seems that people are having problems with the panel and system tray after the upgrade.
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: KDE Transition  PostPosted: 25.08.2016, 20:09



Joined: 2010-08-25
Posts: 949

Status: Offline
I haven't seen issues with that, you just need to update your 'konsole' quickstart shortcut, as the underlying file name changed from KDE4 to its KDE5 counterpart (remove the old, inactive, one and drag'n'drop the updated one from k-menu/ system).
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: Re: RE: KDE Transition  PostPosted: 25.08.2016, 21:03



Joined: 2010-09-12
Posts: 470

Status: Offline
      slh wrote:
I haven't seen issues with that, you just need to update your 'konsole' quickstart shortcut, as the underlying file name changed from KDE4 to its KDE5 counterpart (remove the old, inactive, one and drag'n'drop the updated one from k-menu/ system).


OK, so I've DUed and had no problems with it yet either. (Except the ones I was already having, due to two monitors, I believe.) Everything seems fine for me.

I did not have problems with the konsole either, though.
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: Re: RE: KDE Transition  PostPosted: 25.08.2016, 21:06



Joined: 2010-08-25
Posts: 949

Status: Offline
dual-monitor is working nicely, at least in the desktop case (configuration via xorg.conf.d/, kscreen disabled).
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: Re: RE: KDE Transition  PostPosted: 25.08.2016, 22:11



Joined: 2010-08-25
Posts: 949

Status: Offline
      finotti wrote:
[...]it seems that people are having problems with the panel and system tray after the upgrade.[...]

As previously mentioned, I personally haven't observed this behaviour, but it appears to known and easily fixable, #835383.
 
 View user's profile Send private message  
Reply with quote Back to top
kenyeeOffline
Post subject: RE: Re: RE: KDE Transition  PostPosted: 29.08.2016, 01:31



Joined: 2010-09-29
Posts: 98

Status: Offline
DU wants to remove:
plasma-desktop plasma-workspace

Are these no longer needed? It's updating these two, but not replacing the ones above:
plasma-framework plasma-integration
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: Re: RE: KDE Transition  PostPosted: 29.08.2016, 03:41



Joined: 2010-08-25
Posts: 949

Status: Offline
They are needed, just give it a few more days.
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: Re: RE: KDE Transition  PostPosted: 31.08.2016, 19:47



Joined: 2010-08-25
Posts: 949

Status: Offline
Should be resolved today.
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: Re: RE: KDE Transition  PostPosted: 01.09.2016, 00:14



Joined: 2010-08-25
Posts: 949

Status: Offline
I have split the thread into separate ones for KDE 5.6 (finished in june) and KDE 5.7 (now in august), as both need pretty individual procedures and shouldn't be mangled together.

Please open a new, individual, thread when KDE 5.8.x arrives, rather than resurrecting either of these.
 
 View user's profile Send private message  
Reply with quote Back to top
alexkOffline
Post subject: RE: Re: RE: KDE Transition  PostPosted: 01.09.2016, 02:16



Joined: 2010-10-01
Posts: 288

Status: Offline
I'm getting an error on apt-get update and apt now shows 75 packages to be removed:
      Code:
# apt-get update
Hit:1 http://ftp.us.debian.org/debian experimental InRelease
Hit:3 http://ftp.debian.org/debian sid InRelease                                               
Hit:4 http://aptosid.office-vienna.at/aptosid/debian sid InRelease                             
Hit:6 http://ftp.debian.org/debian testing InRelease                   
appstreamcli: /build/appstream-0.9.8/obj-x86_64-linux-gnu/src/ascache.pb.h:3644: void ASCache::Url::set_type(ASCache::Url_Type): Assertion `::ASCache::Url_Type_IsValid(value)' failed.
Aborted
Reading package lists... Done
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli; then appstreamcli refresh-cache > /dev/null; fi'
E: Sub-process returned an error code

# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  alien apt-xapian-index build-essential comerr-dev debhelper dh-autoreconf dh-strip-nondeterminism g++ g++-4.4 g++-4.5 g++-4.6
  g++-4.9 g++-5 g++-6 gnome-codec-install libacl1-dev libattr1-dev libbz2-dev libc6-dev libc6-dev-i386 libcaca-dev libcupsimage2-dev
  libexif-dev libexpat1-dev libfontconfig1-dev libfreetype6-dev libgcrypt20-dev libglib2.0-dev libgphoto2-dev libjack-dev
  libjpeg-dev libjpeg62-turbo-dev liblua50-dev liblualib50-dev libncurses5-dev libpci-dev libpcre3-dev libpng-dev libpopt-dev
  libpython-all-dev libpython-dev libpython2.7-dev libpython3-dev libpython3.5-dev libsasl2-dev libslang2-dev libsnmp-dev libssl-dev
  libstdc++-4.9-dev libstdc++-5-dev libstdc++-6-dev libstdc++6-4.4-dev libstdc++6-4.5-dev libstdc++6-4.6-dev libstdc++6-4.7-dev
  libtiff5-dev libtool libtool-bin libusb-dev libxft-dev muon-notifier muon-updater plasma-discover-private plasma-discover-updater
  python-all-dev python-apt python-aptdaemon python-dev python-software-properties python2.6-dev python2.7-dev python3-dev
  python3.5-dev uuid-dev zlib1g-dev

[...]

611 upgraded, 23 newly installed, 75 to remove and 36 not upgraded.
Need to get 513 MB of archives.
After this operation, 324 MB disk space will be freed.
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio