Rootserver Sponsor

webtropia"

Donations

Please support your operating system's further development:

donate"

Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
elishOffline
Post subject: 2015-01 or 2016-01?  PostPosted: 22.10.2015, 14:00



Joined: 2013-11-09
Posts: 33

Status: Offline
Hello Smile

Yep, it is the time of year for "the question"...

Please surprise me this time (not with a ban please)!
 
 View user's profile Send private message  
Reply with quote Back to top
elishOffline
Post subject: RE: 2015-01 or 2016-01?  PostPosted: 25.10.2015, 14:35



Joined: 2013-11-09
Posts: 33

Status: Offline
No reply? Sad
I'll check again in 2017...
 
 View user's profile Send private message  
Reply with quote Back to top
deusdaraOffline
Post subject: RE: 2015-01 or 2016-01?  PostPosted: 25.10.2015, 16:11



Joined: 2010-09-17
Posts: 9

Status: Offline
Hi

You can see on DistroWatch that:

Status: Dormente

http://distrowatch.com/table.php?distribution=aptosid

_________________
[Mobo: Asus Maximus III Formula ][CPU: QuadCore Intel Core i7 860@2.80 GHz][RAM:2x2 GB 1333 MHz DDR3 Corsair][GPU: nVidia GTX 570][HD:Seagate 1,0 TB SATA II][Fonte: Corsair 500w - CMPSU-500CXV2 ][aptosid]
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: 2015-01 or 2016-01?  PostPosted: 25.10.2015, 16:34



Joined: 2010-09-12
Posts: 391

Status: Offline
I don't think DistroWatch really knows what's going on. It simply sees it hasn't been released in a long time.

Although I would also like a more recent install media, my last installations (not too long ago, but before the gcc transition) went really smoothly. Also, aptosid has been rolling really well and support continues to be really good.

@elish: try a new install. It might not be as bad as you'd think.
 
 View user's profile Send private message  
Reply with quote Back to top
elishOffline
Post subject: RE: 2015-01 or 2016-01?  PostPosted: 25.10.2015, 16:58



Joined: 2013-11-09
Posts: 33

Status: Offline
Status dormant - OK no problem, but why not mention it in the start page? how much time does it take to add a few words to a web page?

I don't have the courage for a new install. And what's the point if a once 7 minutes installation is now followed by 70 minutes of dist-upgrade?
 
 View user's profile Send private message  
Reply with quote Back to top
vinurOffline
Post subject: RE: 2015-01 or 2016-01?  PostPosted: 25.10.2015, 19:31



Joined: 2010-09-11
Posts: 82
Location: Lake Oswego
Status: Offline
elish quote "I don't have the courage for a new install. And what's the point if a once 7 minutes installation is now followed by 70 minutes of dist-upgrade?"
@elish,... well maybe because that is how it is done?
Life just keeps rolling along...
enjoy Rolling Eyes
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
finottiOffline
Post subject: RE: 2015-01 or 2016-01?  PostPosted: 26.10.2015, 14:44



Joined: 2010-09-12
Posts: 391

Status: Offline
@elish: Again, I don't think that status is really "dormant", as updates keep rolling and we do have support. Indeed, it has been way too long since last release and I understand your frustration. But, in the big scheme of things, a 70 minute DU is not that bad, IMHO. You can leave it overnight, after a:
      Code:

apt-get update && apt-get -dy dist-upgrade

(which only downloads all packages) and then do the upgrade in the morning. Again, not ideal, but I think it is worth it for having a nice rolling distro with good support. And after the install, you don't need releases anymore. (Also, with sid, even after a couple of months of the release, the DU will probably be pretty long...)

At this point, there were some big changes that make the DU process more painful than usual, but with the commands suggested by slh, I have had no problems. But I agree that a new release would be nice.
 
 View user's profile Send private message  
Reply with quote Back to top
elishOffline
Post subject: RE: 2015-01 or 2016-01?  PostPosted: 26.10.2015, 16:15



Joined: 2013-11-09
Posts: 33

Status: Offline
OK I'll find a spare laptop to experiment.

Are there any changes to the sources list or special actions for Init -> Systemd?
Is the user manual up to date?
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: Re: RE: 2015-01 or 2016-01?  PostPosted: 26.10.2015, 17:18



Joined: 2010-09-12
Posts: 391

Status: Offline
      elish wrote:
OK I'll find a spare laptop to experiment.

Are there any changes to the sources list or special actions for Init -> Systemd?
Is the user manual up to date?


You can also try it in a virtual machine...

The transition to systemd, in my recent installs, went without a problem with no special action required.

The Plasma5 updates I've done with slh last suggestion:
      Code:

# apt update
# apt-get dist-upgrade libstreamanalyzer0v5+ libstreams0v5+ libstreams0- kdeutils+ kdeadmin+ konversation+

I cannot say for sure it is still the best command, but it has worked for me.

I'd also suggest you take a look at my post here: http://www.aptosid.com/index.php?name=PNphpBB2&file=viewtopic&t=2898&highlight=

Good luck!
 
 View user's profile Send private message  
Reply with quote Back to top
manulOffline
Post subject: RE: Re: RE: 2015-01 or 2016-01?  PostPosted: 26.10.2015, 18:14



Joined: 2010-09-13
Posts: 108

Status: Offline
IMHO aptosid as a distro is practically dead.

Since a long time it hardly delivers anything useful on top of the debian unstable (apart of the good/concise manual for not-so-technical oriented debian users - which manual however outdates very fast)
 
 View user's profile Send private message  
Reply with quote Back to top
elishOffline
Post subject: RE: Re: RE: 2015-01 or 2016-01?  PostPosted: 26.10.2015, 19:34



Joined: 2013-11-09
Posts: 33

Status: Offline
Thank you finotti!
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: Re: RE: 2015-01 or 2016-01?  PostPosted: 28.10.2015, 19:35



Joined: 2010-09-12
Posts: 391

Status: Offline
OK, I'm trying a new install in a virtual machine, and I am having trouble...

My first try was to simply issue the apt command above (that I've cited from slh). I've got a message:
      Code:

[snip]
dpkg-maintscript-helper: error: command dir_to_symlink is unknown
Hint: upgrading dpkg to a newer version might help.
[snip]

Many issues of "apt-get -f install" and "dpkg --configure -a" did not solve the problem.

Then, I tried to just do update and try to install apt and dpkg before upgrading, but I ran into the same problem. Here is my last attempt:
      Code:

root@virtapto:/home/finotti# apt-get -f install
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
  adwaita-icon-theme aptosid-art-kdm-hesperides aptosid-art-sddm-hesperides at-spi2-core binutils coinor-libcbc3 coinor-libcgl1
  coinor-libclp1 coinor-libcoinmp1v5 coinor-libcoinutils3v5 coinor-libosi1v5 cpp cpp-5 cups cups-bsd cups-client cups-common
  cups-core-drivers cups-daemon cups-filters cups-filters-core-drivers cups-ppdc cups-server-common dbus dialog dpkg
  fontconfig-config foomatic-db-engine g++ g++-5 gcc gcc-5 gcc-5-base gir1.2-glib-2.0 glib-networking glib-networking-common
  glib-networking-services gnupg-agent gnupg2 gstreamer1.0-plugins-base init-system-helpers irssi kate-data kcharselect
  kde-config-cron libabw-0.1-1 libapparmor1 libasan2 libasound2 libasound2-data libassuan0 libatk-bridge2.0-0 libatk1.0-0
  libatk1.0-data libatomic1 libatspi2.0-0 libaudit-common libaudit1 libboost-date-time1.58.0 libboost-iostreams1.58.0
  libboost-system1.58.0 libcairo2 libcap2-bin libcc1-0 libcdr-0.1-1 libcilkrts5 libclucene-contribs1v5 libclucene-core1v5
  libcmis-0.5-5v5 libcolord2 libcups2 libcupscgi1 libcupsfilters1 libcupsimage2 libcupsmime1 libcupsppdc1 libcurses-perl libdb5.3
  libdbus-1-3 libdouble-conversion1 libdrm-nouveau2 libdrm2 libe-book-0.1-1 libegl1-mesa libeot0 libepoxy0 libetonyek-0.1-1
  libevdev2 libexttextcat-2.0-0 libexttextcat-data libffi6 libfile-fnmatch-perl libfontconfig1 libfontembed1 libfreehand-0.1-1
  libfreetype6 libgail-3-0 libgbm1 libgcc-5-dev libgcc1 libgcrypt20 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgfortran3
  libgirepository-1.0-1 libglew1.10 libglib2.0-0 libgltf-0.0-0v5 libgmp10 libgnutls-deb0-28 libgpg-error0 libgpgme11
  libgraphite2-3 libgssapi-krb5-2 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgtk-3-0 libgtk-3-bin libgtk-3-common
  libharfbuzz-icu0 libharfbuzz0b libhogweed4 libhunspell-1.3-0 libicu55 libinput10 libio-pty-perl libisl13
  libjavascriptcoregtk-3.0-0 libjpeg62-turbo libjson-glib-1.0-0 libjson-glib-1.0-common libk5crypto3 libkeyutils1 libkf5attica5
  libkf5auth-data libkf5auth5 libkf5codecs-data libkf5codecs5 libkf5completion-data libkf5completion5 libkf5config-data
  libkf5configcore5 libkf5configgui5 libkf5configwidgets-data libkf5configwidgets5 libkf5coreaddons-data libkf5coreaddons5
  libkf5crash5 libkf5dbusaddons-data libkf5dbusaddons5 libkf5globalaccel-data libkf5globalaccel5 libkf5guiaddons5 libkf5i18n-data
  libkf5i18n5 libkf5iconthemes-data libkf5iconthemes5 libkf5itemviews-data libkf5itemviews5 libkf5jobwidgets-data
  libkf5jobwidgets5 libkf5kiocore5 libkf5kiowidgets5 libkf5service-bin libkf5service-data libkf5service5 libkf5sonnet5-data
  libkf5sonnetcore5 libkf5sonnetui5 libkf5textwidgets-data libkf5textwidgets5 libkf5widgetsaddons-data libkf5widgetsaddons5
  libkf5windowsystem-data libkf5windowsystem5 libkf5xmlgui-data libkf5xmlgui5 libkrb5-3 libkrb5support0 libksba8
  liblangtag-common liblangtag1 liblapack3 liblcms2-2 libllvm3.7 liblocale-gettext-perl liblsan0 libmodplug1 libmpc3 libmpfr4
  libmpx0 libmspub-0.1-1 libmwaw-0.3-3 libmysqlclient18 libncurses5 libncursesw5 libnettle6 libnpth0 libodfgen-0.1-1 libopenjpeg5
  liborc-0.4-0 liborcus-0.10-0v5 libp11-kit0 libpagemaker-0.0-0 libpango-1.0-0 libpango1.0-0 libpangocairo-1.0-0
  libpangoft2-1.0-0 libpangox-1.0-0 libpangoxft-1.0-0 libpcre16-3 libpcre3 libperl5.20 libpixman-1-0 libpolkit-qt5-1-1
  libpoppler46 libproxy1v5 libpython-stdlib libpython2.7 libpython2.7-minimal libpython2.7-stdlib libqpdf13v5 libqt4-opengl
  libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml libqt5core5a libqt5dbus5 libqt5gui5
  libqt5network5 libqt5printsupport5 libqt5qml5 libqt5quick5 libqt5script5 libqt5svg5 libqt5widgets5 libqt5x11extras5
  libqt5xcbqpa5 libqt5xml5 libqtcore4 libqtgui4 libquadmath0 libraptor2-0 librasqal3 librdf0 libreoffice-base-core
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-impress libreoffice-math
  libreoffice-style-galaxy libreoffice-writer librest-0.7-0 librevenge-0.0-0 librsvg2-2 librsvg2-common libsecret-1-0
  libsecret-common libselinux1 libsoup-gnome2.4-1 libsoup2.4-1 libssl1.0.0 libstdc++-5-dev libstdc++6 libsystemd0 libtalloc2
  libtasn1-6 libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libtiff5 libtinfo5 libtsan0 libubsan0 libudev1
  libval14 libvisio-0.1-1 libwayland-client0 libwayland-cursor0 libwayland-egl1-mesa libwayland-server0 libwbclient0
  libwebkitgtk-3.0-0 libwebkitgtk-3.0-common libwebp5 libwpd-0.10-10 libwpg-0.3-3 libwps-0.4-4 libx11-6 libxatracker2
  libxcb-dri3-0 libxcb-icccm4 libxcb-image0 libxcb-keysyms1 libxcb-randr0 libxcb-render-util0 libxcb-sync1 libxcb-xfixes0
  libxcb-xkb1 libxcb1 libxkbcommon-x11-0 libxkbcommon0 libxrandr2 libxshmfence1 libzvbi-common libzvbi0
  linux-headers-4.2.0-5.slh.1-aptosid-amd64 linux-headers-aptosid-amd64 mysql-common perl perl-base perl-modules pinentry-curses
  polkit-kde-1 polkit-kde-agent-1 python python-gi python-minimal python2.7 python2.7-minimal qml-module-qtquick2 qtcore4-l10n
  sddm shared-mime-info uno-libs3 ure xserver-common xserver-xorg xserver-xorg-core xserver-xorg-input-evdev
  xserver-xorg-input-mouse xserver-xorg-input-synaptics xserver-xorg-input-vmmouse xserver-xorg-video-all xserver-xorg-video-ati
  xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
  xserver-xorg-video-neomagic xserver-xorg-video-nouveau xserver-xorg-video-openchrome xserver-xorg-video-qxl
  xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-savage xserver-xorg-video-siliconmotion
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident xserver-xorg-video-vesa xserver-xorg-video-vmware
Suggested packages:
  binutils-doc cpp-doc gcc-5-locales cups-pdf xpp netcat g++-multilib g++-5-multilib gcc-5-doc libstdc++6-5-dbg gcc-multilib
  manpages-dev autoconf automake libtool flex bison gdb gcc-doc gcc-5-multilib libgcc1-dbg libgomp1-dbg libitm1-dbg
  libatomic1-dbg libasan2-dbg liblsan0-dbg libtsan0-dbg libubsan0-dbg libcilkrts5-dbg libmpx0-dbg libquadmath0-dbg gnupg-doc
  parcimonie xloadimage gvfs irssi-scripts khelpcenter libasound2-plugins rng-tools glew-utils gnutls-bin gpgsm krb5-doc
  krb5-user libvisual-0.4-plugins gstreamer1.0-tools liblcms2-utils libqt4-dev libqt5libqgtk2 qt5-image-formats-plugins
  qtwayland5 libicu52 qt4-qtconfig raptor2-utils rasqal-utils librdf-storage-postgresql librdf-storage-mysql
  librdf-storage-sqlite librdf-storage-virtuoso redland-utils libreoffice-base ocl-icd-libopencl1 libreoffice-style-breeze
  libreoffice-style-hicontrast libreoffice-style-oxygen libreoffice-style-sifr libreoffice-style-tango fonts-crosextra-caladea
  fonts-crosextra-carlito libreoffice-gcj libreoffice-java-common default-jre gcj-jre openjdk-7-jre openjdk-6-jre sun-java5-jre
  sun-java6-jre java5-runtime jre librsvg2-bin libstdc++-5-doc perl-doc libterm-readline-gnu-perl libterm-readline-perl-perl
  libb-lint-perl libcpanplus-dist-build-perl libcpanplus-perl libfile-checktree-perl liblog-message-simple-perl
  liblog-message-perl libobject-accessor-perl pinentry-doc python-doc python-tk python-gi-cairo python2.7-doc binfmt-support
  libpam-kwallet5 xfonts-scalable gpointing-device-settings touchfreeze firmware-linux
Recommended packages:
  avahi-daemon colord cups-browsed dirmngr libpam-cap libglib2.0-data xdg-user-dirs libkf5config-bin libkf5dbusaddons-bin
  libkf5globalaccel-bin libkf5iconthemes-bin sonnet-plugins libkf5xmlgui-bin krb5-locales qpdf qttranslations5-l10n xfonts-mathml
  python3-uno libreoffice-avmedia-backend-gstreamer libreoffice-avmedia-backend-vlc gstreamer1.0-plugins-good geoclue-2.0 rename
  libarchive-extract-perl libmodule-pluggable-perl libpod-latex-perl libterm-ui-perl libtext-soundex-perl libcgi-pm-perl
  libmodule-build-perl libpackage-constants-perl libpam-systemd
The following packages will be REMOVED:
  cpp-4.7 digikam dolphin foomatic-filters freespacenotifier g++-4.7 gcc-4.7 gcc-4.7-base ghostscript-cups gwenview hpijs-ppds
  hplip hplip-gui kaffeine kate katepart kbattleship kcalc kde-baseapps kde-baseapps-bin kde-l10n-de kde-runtime kde-style-oxygen
  kde-window-manager kde-workspace-kgreet-plugins kdeadmin kdebase-runtime kdelibs-bin kdelibs5-plugins kdemultimedia-kio-plugins
  kdepasswd kdepimlibs-kio-plugins kdf kdm kdoctools kfind kgamma kget khelpcenter4 kipi-plugins klipper kmahjongg kmenuedit kmix
  knemo konq-plugins konqueror konsole kpat kppp krdc kremotecontrol kreversi krusader ksnapshot ksysguard ksystemlog ktorrent
  kuser kwalletmanager kwrite libakonadi-contact4 libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4 libakonadiprotocolinternals1
  libarchive12 libattica0 libaudit0 libbluedevil1 libdbusmenu-qt2 libexttextcat0 libgraphite2-2.0.0 libhpmud0 libk3b6
  libk3b6-extracodecs libkabc4 libkactivities-bin libkactivities6 libkateinterfaces4 libkatepartinterfaces4 libkblog4 libkcal4
  libkcalcore4 libkcalutils4 libkcddb4 libkcmutils4 libkdcraw20 libkde3support4 libkdeclarative5 libkdecorations4 libkdecore5
  libkdegames5a libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkexiv2-10 libkfile4 libkggzgames4 libkggzmod4
  libkggznet4 libkholidays4 libkhtml5 libkidletime4 libkimap4 libkimproxy4 libkio5 libkipi8 libkjsapi4 libkjsembed4 libkldap4
  libkleo4 libkmahjongglib4 libkmediaplayer4 libkmime4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkonq-common
  libkonq5abi1 libkonqsidebarplugin4a libkontactinterface4 libkparts4 libkpgp4 libkpimidentities4 libkpimtextedit4 libkpimutils4
  libkprintutils4 libkpty4 libkresources4 libkrosscore4 libksane0 libkscreensaver5 libksgrd4 libksieve4 libksignalplotter4
  libktexteditor4 libktnef4 libktorrent-l10n libktorrent4 libkunitconversion4 libkutils4 libkwineffects1abi3 libkwinglutils1
  libkworkspace4abi1 libkxmlrpcclient4 libmailtransport4 libmarblewidget13 libmessagecore4 libmicroblog4 libmimelib4 libnepomuk4
  libnepomukquery4a libnepomukutils4 libnettle4 libokularcore1 libopencv-calib3d2.3 libopencv-features2d2.3 libopencv-highgui2.3
  libopencv-legacy2.3 libopencv-objdetect2.3 libopenexr6 libperl5.14 libphonon4 libplasma3 libplasmaclock4abi3
  libplasmagenericshell4 libpolkit-qt-1-1 libprocesscore4abi1 libprocessui4a libqt4-dbus libqt4-declarative libqt4-designer
  libqt4-help libqt4-network libqt4-qt3support libqt4-script libqt4-scripttools libqt4-xmlpatterns libqtassistantclient4
  libqtdbus4 libqtruby4shared2 libqtwebkit4 libreoffice-kde libsane-hpaio libsmokekdecore4-3 libsmokekdeui4-3 libsmokekfile3
  libsmokekhtml3 libsmokekio3 libsmokeknewstuff2-3 libsmokeknewstuff3-3 libsmokekparts3 libsmokektexteditor3 libsmokekutils3
  libsmokenepomuk3 libsmokeplasma3 libsmokeqtdbus4-3 libsmokeqtnetwork4-3 libsmokeqtwebkit4-3 libsmokesolid3 libsnmp15 libsolid4
  libsolidcontrol4abi2 libsoprano4 libstdc++6-4.7-dev libstreamanalyzer0 libstreams0 libsyndication4 libtaskmanager4abi3
  libweather-ion6 linux-headers-3.9-0.slh.4-aptosid-amd64 lsof okular phonon phonon-backend-gstreamer
  plasma-scriptengine-javascript plasma-scriptengine-ruby plasma-scriptengine-webkit plasma-widget-folderview
  printer-driver-hpcups printer-driver-hpijs python-qt4 qdbus ruby-kde4 ruby-plasma ruby-qt4 ruby-qt4-webkit skanlite
  soprano-daemon systemsettings xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-chips xserver-xorg-video-i128
  xserver-xorg-video-modesetting xserver-xorg-video-rendition xserver-xorg-video-s3 xserver-xorg-video-s3virge
  xserver-xorg-video-sis xserver-xorg-video-tseng xserver-xorg-video-voodoo yakuake
The following NEW packages will be installed:
  adwaita-icon-theme aptosid-art-sddm-hesperides at-spi2-core coinor-libcbc3 coinor-libcgl1 coinor-libclp1 coinor-libcoinmp1v5
  coinor-libcoinutils3v5 coinor-libosi1v5 cpp-5 cups-core-drivers cups-daemon cups-filters-core-drivers cups-server-common g++-5
  gcc-5 gcc-5-base gnupg-agent gnupg2 gstreamer1.0-plugins-base init-system-helpers libabw-0.1-1 libapparmor1 libasan2
  libasound2-data libassuan0 libatk-bridge2.0-0 libatomic1 libatspi2.0-0 libaudit-common libaudit1 libboost-date-time1.58.0
  libboost-iostreams1.58.0 libboost-system1.58.0 libcap2-bin libcc1-0 libcdr-0.1-1 libcilkrts5 libclucene-contribs1v5
  libclucene-core1v5 libcmis-0.5-5v5 libcolord2 libdb5.3 libdouble-conversion1 libdrm-nouveau2 libe-book-0.1-1 libegl1-mesa
  libeot0 libepoxy0 libetonyek-0.1-1 libevdev2 libexttextcat-2.0-0 libffi6 libfontembed1 libfreehand-0.1-1 libgbm1 libgcc-5-dev
  libgcrypt20 libglew1.10 libgltf-0.0-0v5 libgnutls-deb0-28 libgraphite2-3 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0
  libgtk-3-bin libharfbuzz-icu0 libharfbuzz0b libhogweed4 libicu55 libinput10 libisl13 libjpeg62-turbo libjson-glib-1.0-0
  libjson-glib-1.0-common libkf5attica5 libkf5auth-data libkf5auth5 libkf5codecs-data libkf5codecs5 libkf5completion-data
  libkf5completion5 libkf5config-data libkf5configcore5 libkf5configgui5 libkf5configwidgets-data libkf5configwidgets5
  libkf5coreaddons-data libkf5coreaddons5 libkf5crash5 libkf5dbusaddons-data libkf5dbusaddons5 libkf5globalaccel-data
  libkf5globalaccel5 libkf5guiaddons5 libkf5i18n-data libkf5i18n5 libkf5iconthemes-data libkf5iconthemes5 libkf5itemviews-data
  libkf5itemviews5 libkf5jobwidgets-data libkf5jobwidgets5 libkf5kiocore5 libkf5kiowidgets5 libkf5service-bin libkf5service-data
  libkf5service5 libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5 libkf5textwidgets-data libkf5textwidgets5
  libkf5widgetsaddons-data libkf5widgetsaddons5 libkf5windowsystem-data libkf5windowsystem5 libkf5xmlgui-data libkf5xmlgui5
  libksba8 liblangtag-common liblangtag1 liblapack3 libllvm3.7 liblsan0 libmpc3 libmpx0 libmspub-0.1-1 libmwaw-0.3-3
  libmysqlclient18 libnettle6 libnpth0 libodfgen-0.1-1 libopenjpeg5 liborcus-0.10-0v5 libpagemaker-0.0-0 libpango-1.0-0
  libpangocairo-1.0-0 libpangoft2-1.0-0 libpangox-1.0-0 libpangoxft-1.0-0 libpcre16-3 libperl5.20 libpolkit-qt5-1-1 libpoppler46
  libproxy1v5 libpython-stdlib libpython2.7-minimal libpython2.7-stdlib libqpdf13v5 libqt4-sql-mysql libqt5core5a libqt5dbus5
  libqt5gui5 libqt5network5 libqt5printsupport5 libqt5qml5 libqt5quick5 libqt5script5 libqt5svg5 libqt5widgets5 libqt5x11extras5
  libqt5xcbqpa5 libqt5xml5 librest-0.7-0 librevenge-0.0-0 librsvg2-common libsecret-1-0 libsecret-common libsoup-gnome2.4-1
  libstdc++-5-dev libsystemd0 libtasn1-6 libtiff5 libtsan0 libubsan0 libudev1 libval14 libvisio-0.1-1 libwayland-client0
  libwayland-cursor0 libwayland-egl1-mesa libwayland-server0 libwebp5 libwpd-0.10-10 libwpg-0.3-3 libwps-0.4-4 libxatracker2
  libxcb-dri3-0 libxcb-icccm4 libxcb-image0 libxcb-keysyms1 libxcb-randr0 libxcb-render-util0 libxcb-sync1 libxcb-xfixes0
  libxcb-xkb1 libxkbcommon-x11-0 libxkbcommon0 libxshmfence1 linux-headers-4.2.0-5.slh.1-aptosid-amd64 mysql-common
  pinentry-curses polkit-kde-agent-1 qml-module-qtquick2 qtcore4-l10n sddm
The following packages will be upgraded:
  aptosid-art-kdm-hesperides binutils cpp cups cups-bsd cups-client cups-common cups-filters cups-ppdc dbus dialog dpkg
  fontconfig-config foomatic-db-engine g++ gcc gir1.2-glib-2.0 glib-networking glib-networking-common glib-networking-services
  irssi kate-data kcharselect kde-config-cron libasound2 libatk1.0-0 libatk1.0-data libcairo2 libcups2 libcupscgi1
  libcupsfilters1 libcupsimage2 libcupsmime1 libcupsppdc1 libcurses-perl libdbus-1-3 libdrm2 libexttextcat-data
  libfile-fnmatch-perl libfontconfig1 libfreetype6 libgail-3-0 libgcc1 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgfortran3
  libgirepository-1.0-1 libglib2.0-0 libgmp10 libgpg-error0 libgpgme11 libgssapi-krb5-2 libgtk-3-0 libgtk-3-common
  libhunspell-1.3-0 libio-pty-perl libjavascriptcoregtk-3.0-0 libk5crypto3 libkeyutils1 libkrb5-3 libkrb5support0 liblcms2-2
  liblocale-gettext-perl libmodplug1 libmpfr4 libncurses5 libncursesw5 liborc-0.4-0 libp11-kit0 libpango1.0-0 libpcre3
  libpixman-1-0 libpython2.7 libqt4-opengl libqt4-sql libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml libqtcore4 libqtgui4
  libquadmath0 libraptor2-0 librasqal3 librdf0 libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-impress libreoffice-math libreoffice-style-galaxy libreoffice-writer librsvg2-2 libselinux1
  libsoup2.4-1 libssl1.0.0 libstdc++6 libtalloc2 libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libtinfo5
  libwbclient0 libwebkitgtk-3.0-0 libwebkitgtk-3.0-common libx11-6 libxcb1 libxrandr2 libzvbi-common libzvbi0
  linux-headers-aptosid-amd64 perl perl-base perl-modules polkit-kde-1 python python-gi python-minimal python2.7
  python2.7-minimal shared-mime-info uno-libs3 ure xserver-common xserver-xorg xserver-xorg-core xserver-xorg-input-evdev
  xserver-xorg-input-mouse xserver-xorg-input-synaptics xserver-xorg-input-vmmouse xserver-xorg-video-all xserver-xorg-video-ati
  xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
  xserver-xorg-video-neomagic xserver-xorg-video-nouveau xserver-xorg-video-openchrome xserver-xorg-video-qxl
  xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-savage xserver-xorg-video-siliconmotion
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident xserver-xorg-video-vesa xserver-xorg-video-vmware
152 upgraded, 206 newly installed, 246 to remove and 632 not upgraded.
6 not fully installed or removed.
Need to get 0 B/341 MB of archives.
After this operation, 257 MB of additional disk space will be used.
Do you want to continue [Y/n]?
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 100322 files and directories currently installed.)
Preparing to replace libreoffice-calc 1:3.5.4+dfsg2-1 (using .../libreoffice-calc_1%3a5.0.3~rc1-2_amd64.deb) ...
dpkg-maintscript-helper: error: command dir_to_symlink is unknown
Hint: upgrading dpkg to a newer version might help.

Usage: dpkg-maintscript-helper <command> <parameter>... -- <maintainer>...

Commands:
  supports <command>
        Returns 0 (success) if the given command is supported, 1 otherwise.
  rm_conffile <conffile> [<last> [<package>]]
        Remove obsolete conffile. Must be called in preinst, postinst and
        postrm.
  mv_conffile <old> <new> [<last> [<package>]]
        Rename a conffile. Must be called in preinst, postinst and postrm.
  help
        Display this usage information.
dpkg: error processing /var/cache/apt/archives/libreoffice-calc_1%3a5.0.3~rc1-2_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
dpkg-maintscript-helper: error: command dir_to_symlink is unknown
Hint: upgrading dpkg to a newer version might help.

Usage: dpkg-maintscript-helper <command> <parameter>... -- <maintainer>...

Commands:
  supports <command>
        Returns 0 (success) if the given command is supported, 1 otherwise.
  rm_conffile <conffile> [<last> [<package>]]
        Remove obsolete conffile. Must be called in preinst, postinst and
        postrm.
  mv_conffile <old> <new> [<last> [<package>]]
        Rename a conffile. Must be called in preinst, postinst and postrm.
  help
        Display this usage information.
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 1
Preparing to replace libreoffice-impress 1:3.5.4+dfsg2-1 (using .../libreoffice-impress_1%3a5.0.3~rc1-2_amd64.deb) ...
dpkg-maintscript-helper: error: command dir_to_symlink is unknown
Hint: upgrading dpkg to a newer version might help.

Usage: dpkg-maintscript-helper <command> <parameter>... -- <maintainer>...

Commands:
  supports <command>
        Returns 0 (success) if the given command is supported, 1 otherwise.
  rm_conffile <conffile> [<last> [<package>]]
        Remove obsolete conffile. Must be called in preinst, postinst and
        postrm.
  mv_conffile <old> <new> [<last> [<package>]]
        Rename a conffile. Must be called in preinst, postinst and postrm.
  help
        Display this usage information.
dpkg: error processing /var/cache/apt/archives/libreoffice-impress_1%3a5.0.3~rc1-2_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
dpkg-maintscript-helper: error: command dir_to_symlink is unknown
Hint: upgrading dpkg to a newer version might help.

Usage: dpkg-maintscript-helper <command> <parameter>... -- <maintainer>...

Commands:
  supports <command>
        Returns 0 (success) if the given command is supported, 1 otherwise.
  rm_conffile <conffile> [<last> [<package>]]
        Remove obsolete conffile. Must be called in preinst, postinst and
        postrm.
  mv_conffile <old> <new> [<last> [<package>]]
        Rename a conffile. Must be called in preinst, postinst and postrm.
  help
        Display this usage information.
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 1
Preparing to replace libreoffice-draw 1:3.5.4+dfsg2-1 (using .../libreoffice-draw_1%3a5.0.3~rc1-2_amd64.deb) ...
dpkg-maintscript-helper: error: command dir_to_symlink is unknown
Hint: upgrading dpkg to a newer version might help.

Usage: dpkg-maintscript-helper <command> <parameter>... -- <maintainer>...

Commands:
  supports <command>
        Returns 0 (success) if the given command is supported, 1 otherwise.
  rm_conffile <conffile> [<last> [<package>]]
        Remove obsolete conffile. Must be called in preinst, postinst and
        postrm.
  mv_conffile <old> <new> [<last> [<package>]]
        Rename a conffile. Must be called in preinst, postinst and postrm.
  help
        Display this usage information.
dpkg: error processing /var/cache/apt/archives/libreoffice-draw_1%3a5.0.3~rc1-2_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
dpkg-maintscript-helper: error: command dir_to_symlink is unknown
Hint: upgrading dpkg to a newer version might help.

Usage: dpkg-maintscript-helper <command> <parameter>... -- <maintainer>...

Commands:
  supports <command>
        Returns 0 (success) if the given command is supported, 1 otherwise.
  rm_conffile <conffile> [<last> [<package>]]
        Remove obsolete conffile. Must be called in preinst, postinst and
        postrm.
  mv_conffile <old> <new> [<last> [<package>]]
        Rename a conffile. Must be called in preinst, postinst and postrm.
  help
        Display this usage information.
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/libreoffice-calc_1%3a5.0.3~rc1-2_amd64.deb
 /var/cache/apt/archives/libreoffice-impress_1%3a5.0.3~rc1-2_amd64.deb
 /var/cache/apt/archives/libreoffice-draw_1%3a5.0.3~rc1-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

This is after a clean install, an attempt of "apt-get install dpkg apt", and a few of "apt-get -f install", "depkg --configure -a".

Any ideas on how to proceed?

Edit: By the way, I'm OK with instructions on how to go from a fresh installation, rather than fix the mess I'm in above.
 
 View user's profile Send private message  
Reply with quote Back to top
elishOffline
Post subject: RE: Re: RE: 2015-01 or 2016-01?  PostPosted: 29.10.2015, 11:30



Joined: 2013-11-09
Posts: 33

Status: Offline
This shows a rolling release has its limitations.
When the update size exceeds a certain value, the system becomes unstable.
I'm sure this can be proved mathematically.
Therefore, the base installation must be updated from time to time.
And the claim that only one installation is enough holds only if the updates are infinitesimal.
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: Re: RE: 2015-01 or 2016-01?  PostPosted: 30.10.2015, 14:51



Joined: 2010-09-12
Posts: 391

Status: Offline
@elish: I don't think it is really the size of the update that causes problems, as much as the kind. A lot depends on gcc, making its update affect a huge number of packages. As far as I can remember, since I've started using sidux/aptosid about 6 years ago, this is the first time we have such problematic DU.

But, while you keep rolling, there is not much of a problem (if you follow the instructions posted here). So, the outdated install media only becomes a problem for new installs. (And it seems it is a real problem now!)

@manul: aptosid provides (or provided) an installation media for Debian Sid and (still) provides support. We do have slh's kernels, which are always up to date and patched. I think these are things of value, especially the support, even if it might not seem much... I guess that's a bit of the point of being based on Debian, that there is not much else needed so it is easier to maintain.

I do understand the wish for new releases, and I share them (at least from time to time). But, as long as there is a path from the latest install image to and up to date system, I consider that an annoyance more than a real problem. It is not clear we have such a path at this point, which I think *is* a real problem. But, in all fairness, my post about it probably should not be in this thread, but in its own new one. Maybe, due the nature of the thread, maintainers/developers have not seen it.

I don't want to make excuses for anyone. I just really like aptosid and intend to stick with it while it is supported, at least for my installed systems. If I need new install and aptosid does not provide a path, it will be too bad, but there are other distros out there... Just my 2 cents...
 
 View user's profile Send private message  
Reply with quote Back to top
elishOffline
Post subject: Re: RE: Re: RE: 2015-01 or 2016-01?  PostPosted: 30.10.2015, 17:34



Joined: 2013-11-09
Posts: 33

Status: Offline
      finotti wrote:


But, while you keep rolling, there is not much of a problem (if you follow the instructions posted here). So, the outdated install media only becomes a problem for new installs. (And it seems it is a real problem now!)


My point exactly.

Not releasing a fresh install media is like saying "We don't want new users, only those who installed a long time ago and kept rolling every week or two".
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio