Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
gangstaOffline
Post subject: Problem with Eclipse.  PostPosted: 12.09.2010, 22:02



Joined: 2010-09-12
Posts: 37
Location: Poland
Status: Offline
I had problem with pydev in Eclipse, so I reinstall this program. I did apt-get purge eclipse-platform, and install.
But problem still was. So I did:
      Code:
apt-get purge eclipse* sun-java6*
and I removed some folders for example usr/share/eclipse.
After I did:
      Code:
apt-get install eclipse-platrom sun-java6-plugin sun-java6-jdk

sun-java6-jre and sun-java6-bin installed automaticly.
And now when i try run eclipse i have error. This is log:
      Code:
!SESSION Sun Sep 12 23:41:49 CEST 2010 -----------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2010-09-12 23:41:49.278
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
    at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:556)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1311)


Thanks for any helps.
 
 View user's profile Send private message  
Reply with quote Back to top
gangstaOffline
Post subject: RE: Problem with Eclipse.  PostPosted: 15.09.2010, 12:46



Joined: 2010-09-12
Posts: 37
Location: Poland
Status: Offline
After yesterday upgrade Eclipse work good.
Thanks:)

But when I try install pydev in Eclipse using this guide
http://www.rose-hulman.edu/class/csse/r ... ration.htm
I have error. Log:
      Code:
An error occurred while installing the items
  session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Install, operand=null --> [R]org.eclipse.cvs 1.0.400.v201002111343, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
  Cannot connect to keystore.
  This trust engine is read only.
  The artifact file for osgi.bundle,org.eclipse.cvs,1.0.400.v201002111343 was not found.

Tell me if this problem is independent of aptosid and this is wrong place for this post.
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject: RE: Problem with Eclipse.  PostPosted: 15.09.2010, 13:03



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
the correct packagename is eclipse-pydev and can be installed through apt.

greetz
deil
 
 View user's profile Send private message  
Reply with quote Back to top
gangstaOffline
Post subject: RE: Problem with Eclipse.  PostPosted: 15.09.2010, 13:23



Joined: 2010-09-12
Posts: 37
Location: Poland
Status: Offline
      Code:
E: Package 'eclipse-pydev' has no installation candidate
I have repo from manual.

Thanks for any helps.



EDIT: Ok. I see packagename eclipse-pydev-gcj. But I can't install it.
      Code:
Następujące pakiety mają niespełnione zależności:
 eclipse-pydev-gcj : Wymaga: eclipse-pydev (>= 1.2.5-3) ale nie da się go zainstalować
                     Wymaga: eclipse-platform-gcj ale nie da się go zainstalować
E: Pakiety są uszkodzone


Last edited by gangsta on 15.09.2010, 13:55; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
gangstaOffline
Post subject: Re: RE: Problem with Eclipse.  PostPosted: 15.09.2010, 13:36



Joined: 2010-09-12
Posts: 37
Location: Poland
Status: Offline
There was a repeat slip


Last edited by gangsta on 15.09.2010, 13:57; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject: RE: Problem with Eclipse.  PostPosted: 15.09.2010, 13:39



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
that is strange. apt-cache policy eclipse-pydev says the same here, but:
http://packages.debian.org/search?keywo ... ection=all
claims its in sid. i have now idea right now why that is so.
but you can get the deb from the above link and install with dpkg -i <packagename>

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
gangstaOffline
Post subject: RE: Problem with Eclipse.  PostPosted: 15.09.2010, 14:07



Joined: 2010-09-12
Posts: 37
Location: Poland
Status: Offline
      Code:
# dpkg -i eclipse-pydev_1.2.5-4_all.deb
Zaznaczenie poprzednio niezaznaczonego pakietu eclipse-pydev.
(Odczytywanie bazy danych ... 184733 files and directories currently installed.)
Rozpakowanie eclipse-pydev (z eclipse-pydev_1.2.5-4_all.deb) ...
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie eclipse-pydev:
 eclipse-pydev zależy od eclipse (>= 3.2.1); jednakże:
  Pakiet eclipse nie jest zainstalowany.
 eclipse-pydev zależy od python-dev; jednakże:
  Pakiet python-dev nie jest zainstalowany.
 eclipse-pydev zależy od bicyclerepair; jednakże:
  Pakiet bicyclerepair nie jest zainstalowany.
 eclipse-pydev zależy od jython; jednakże:
  Pakiet jython nie jest zainstalowany.
dpkg: błąd przetwarzania eclipse-pydev (--install):
 problemy z zależnościami - pozostawiony nieskonfigurowany
Wystąpiły błędy podczas przetwarzania:
 eclipse-pydev
This is in Polish language, but I think that You understand it.
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject: RE: Problem with Eclipse.  PostPosted: 15.09.2010, 14:34



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
no, i don't
      Code:
LANG=C dpkg -i eclipse-pydev_1.2.5-4_all.deb
gies EN output

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
gangstaOffline
Post subject: Re: RE: Problem with Eclipse.  PostPosted: 15.09.2010, 14:42



Joined: 2010-09-12
Posts: 37
Location: Poland
Status: Offline
      devil wrote:
no, i don't
sorry
      Code:
# LANG=C dpkg -i eclipse-pydev_1.2.5-4_all.deb
(Reading database ... 184934 files and directories currently installed.)
Preparing to replace eclipse-pydev 1.2.5-4 (using eclipse-pydev_1.2.5-4_all.deb) ...
Unpacking replacement eclipse-pydev ...
dpkg: dependency problems prevent configuration of eclipse-pydev:
 eclipse-pydev depends on eclipse (>= 3.2.1); however:
  Package eclipse is not installed.
 eclipse-pydev depends on python-dev; however:
  Package python-dev is not installed.
 eclipse-pydev depends on bicyclerepair; however:
  Package bicyclerepair is not installed.
 eclipse-pydev depends on jython; however:
  Package jython is not installed.
dpkg: error processing eclipse-pydev (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 eclipse-pydev


Thanks for any helps.
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject: RE: Re: RE: Problem with Eclipse.  PostPosted: 15.09.2010, 15:18



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
using dpkg for install, other than apt, does not satify dependencies. so you need to install those per apt. in your case bycyclerepairand jython.

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio