Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
bytemanOffline
Post subject: Motherboard Asus P5N-MX  PostPosted: 26.10.2010, 08:25



Joined: 2010-10-26
Posts: 11

Status: Offline
I work in a lab with 20 PC equipped whit Asus P5N-MX motherboard.
Previous installation was Sidux 2010-01, and all worked fine.
I attempt to start the new CD-Live Aptosid 2010-02-Xfce and the system stops immediately at boot grub menu.
The same CD-Live works perfectly in others computers of my school.
It is very important for me to fix this problem.
Thanks in advance,
byteman
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
devilOffline
Post subject: RE: Motherboard Asus P5N-MX  PostPosted: 26.10.2010, 08:47



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
as this subforum is for bugs on the iso, i move the thread to hardware.

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject: RE: Motherboard Asus P5N-MX  PostPosted: 26.10.2010, 08:49



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
you need to give more info.
what graphics card is involved?
at a wild guess: remove vga=791 and try to boot

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
bytemanOffline
Post subject: Graphics card on Asus P5N-MX  PostPosted: 26.10.2010, 08:53



Joined: 2010-10-26
Posts: 11

Status: Offline
The graphics card model is: nVidia geForce 7050/nForce 610i
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
bytemanOffline
Post subject: RE: Graphics card on Asus P5N-MX  PostPosted: 26.10.2010, 13:04



Joined: 2010-10-26
Posts: 11

Status: Offline
I will try your advise tomorrow.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
slhOffline
Post subject: RE: Graphics card on Asus P5N-MX  PostPosted: 26.10.2010, 13:27



Joined: 2010-08-25
Posts: 724

Status: Offline
Please boot with "No Quiet" selected withing the boot menu (F5) and let the system sit 5-10 minutes, sometimes the system just has to wait to hit a timeout for some device (still a bug, but then it will become obvious where it fails). A screenshot (serial- or netconsole, or using a digital camera) might help as well.
 
 View user's profile Send private message  
Reply with quote Back to top
bytemanOffline
Post subject: RE: Graphics card on Asus P5N-MX  PostPosted: 27.10.2010, 12:33



Joined: 2010-10-26
Posts: 11

Status: Offline
Hello, today I tried the tips you gave me (vga = 791) (No Quiet F5). But they did not work. You can not use the keyboard to change the "cheatcodes", because as soon as you hit a button, the system reboots.
I tried with other copies of the CD, all checked with md5sum, but the result is the same. Sidux 2010-01 xfce version instead works perfectly.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
bytemanOffline
Post subject:   PostPosted: 28.10.2010, 15:17



Joined: 2010-10-26
Posts: 11

Status: Offline
Help me, please. I follow from the origin this wonderful distribution, ever since it was developed by Kanotix (2005), then during all the updates as Sidux. And I'd do so even now renamed Aptosid. I've already installed at home and on computers of my friends, and it works a treat. I am very sorry for not being able to use it in the lab of my school. I look forward to a solution to the problem.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
broweOffline
Post subject:   PostPosted: 28.10.2010, 17:23



Joined: 2010-09-12
Posts: 152
Location: Canada
Status: Offline
It does sound like some hardware is stuck. If possible try with another cd drive (if you are using sata, try pata drive), or boot from a usb. It also could be a setting in the bios, an updated bios may help. Another thought, if 2010-01 works why not keep using that? Or try 2010-02-kde, your problem might be something specific to 2010-02-Xfce. With that mb I expect you have a 64bit chip... are you installing 32 or 64 bit os?
 
 View user's profile Send private message  
Reply with quote Back to top
bytemanOffline
Post subject:   PostPosted: 28.10.2010, 18:28



Joined: 2010-10-26
Posts: 11

Status: Offline
Thank for your interest. Tomorrow I will do another test with the KDE version, and I will report back the results. Of course the 2010-10 version works fine, but the repositories have been changed from sidux to aptosid, I do not understand what has changed in the transition from sidux 2010-01-xfce to aptosid 2010-02-xfce. I teach operating systems and I would like to give a full explanation to my students. We tried on all 20 PCs in the lab with the same negative results. The oddity is that the older version recognizes the hardware, while the newer locks. We have always worked with 32-bit versions. But I do not think that this might be relevant.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
bytemanOffline
Post subject:   PostPosted: 29.10.2010, 15:48



Joined: 2010-10-26
Posts: 11

Status: Offline
Hello everybody, this morning I made the test even with the Aptosid KDE version, but unfortunately the results are exactly the same. In the old lab equipped with the ASUS P5L-MX motherboard everything works perfectly: Sidux 2010-01 and Aptosid 2010-02. In the new lab equipped with the ASUS P5N-MX motherboard works only Sidux 2010-01, while 2010-02 Aptosid continues to reboot or lock the system. I don't understand what change has occurred in Aptosid 2010-02 that it doesn't work on Asus P5N-MX motherboard.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
slhOffline
Post subject:   PostPosted: 29.10.2010, 16:12



Joined: 2010-08-25
Posts: 724

Status: Offline
The big question is what exactly fails.

The beginning of this thread sounds like you would expect the kernel to be responsible, while your later posts almost suggest that it might be the CD's bootloader (isolinux) instead; I'm not even 100% sure that it isn't something later in the bootprocess. This question needs to be resolved first.

If it's the kernel bailing out, there may be chances to avoid the issue through kernel parameters and updated kernels, which will be in future aptosid versions, may fix it for good. Assuming the bootloader is guilty, there are no workarounds for released version possible, neither would be remote debugging and the only hope would be for future upstream fixes for syslinux (which, due to squeeze being frozen won't tickle into unstable that soon).

Either way, the most important task is finding out which component fails. Right now, a seamless upgrade from Ύπνος would still be possible, but that option is only open for the remainder or this year.
 
 View user's profile Send private message  
Reply with quote Back to top
bytemanOffline
Post subject:   PostPosted: 29.10.2010, 17:04



Joined: 2010-10-26
Posts: 11

Status: Offline
Thank you very much for the suggestions. Assuming the installation of sidux 2010-01 xfce, which is known to work on both mb, updating to aptosid can be made with one command: apt-get dist-upgrade?
But I hope that in the next release of aptosid these problems will be solved completely.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
slhOffline
Post subject:   PostPosted: 29.10.2010, 17:13



Joined: 2010-08-25
Posts: 724

Status: Offline
Maybe, maybe not; as long as we have no idea what might be broken, there's nothing we could fix, other than hoping that respective upstreams change "something" and make it work in new upstream versions shipping in upcoming versions. A bug that can neither be located, nor debugged, usually can't be fixed - unless someone else stumbles over it by chance and finds a solution.
 
 View user's profile Send private message  
Reply with quote Back to top
broweOffline
Post subject:   PostPosted: 29.10.2010, 19:48



Joined: 2010-09-12
Posts: 152
Location: Canada
Status: Offline
You are correct that a dist-upgrade from a 2010-01-xfce install should bring you up to date aptosid. Follow the manual for the upgrade, and include the aptosid keyrings and sources (I belive it's all automated but I added those manually before I did the first aptosid dist-upgrade). 2010-01 had a 2.6.34 kernel and we are at 2.6.36 now, so if there was a problem with the 2010-02 kernel perhaps it is fixed even if nobody else noticed it. Quite a few other things changed since 2010-01, so it's definately worth trying. At least if you have an installed system it's easier to troubleshoot than a live-cd, logs can be checked offline, different kernels can be tried, etc.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio