Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
finottiOffline
Post subject: [solved] screen brightness on Thinkpad T510  PostPosted: 01.12.2010, 12:35



Joined: 2010-09-12
Posts: 294

Status: Offline
Dear all,

I cannot adjust the screen brightness with the Fn keys on my Lenovo Thinkpad. In fact, neither can Power Devil... I could do it with my old Thinkpad T60.

Other Fn keys seem to work, by the way, but not all. I do have the package tpb installed.

      Code:

root@t510[/home/finotti]# apt-cache show tpb
Package: tpb
Priority: extra
Section: utils
Installed-Size: 284
Maintainer: Steve McIntyre <93sam@debian.org>
Architecture: amd64
Version: 0.6.4-6
Depends: adduser, libc6 (>= 2.3), libice6 (>= 1:1.0.0), libsm6, libx11-6, libxext6, libxinerama1, libxosd2 (>= 2.2.13), debconf (>= 0.5) | debconf-2.0
Pre-Depends: debconf | debconf-2.0
Suggests: xfonts-base-transcoded
Filename: pool/main/t/tpb/tpb_0.6.4-6_amd64.deb
Size: 60864
MD5sum: 2b54efcf4243267563cc142381f95bf6
SHA1: 4fce1a1384464573053caeafe7acebb8d3cdd92f
SHA256: 449bbcf943d6009dc24b28d4f8b0d1da758e8a3282b14d5770a496308b881335
Description: program to use the IBM ThinkPad(tm) special keys
 This program enables the IBM Thinkpad(tm) special keys. It is possible to bind
 a program to the ThinkPad button. It has a on-screen display (OSD) to show
 volume, mute and brightness of the LCD.
Tag: admin::configuring, hardware::input, hardware::laptop, role::program, scope::utility, use::configuring


      Code:

root@t510[/home/finotti]# apt-cache policy tpb
tpb:
  Installed: 0.6.4-6
  Candidate: 0.6.4-6
  Version table:
 *** 0.6.4-6 0
        500 http://ftp.us.debian.org/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status


Some hardware info:

      Code:

root@t510[/home/finotti]# infobash -v3
Host/Kernel/OS  "t510" running Linux 2.6.36-1.slh.2-aptosid-amd64 x86_64 [ sidux 2010-01 Ύπνος - kde-full - (201006131622) ]
CPU Info        4x Intel Core i5 M 520 @ 3072 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 2400.000 MHz ]                                       
Videocard       nVidia GT218 [NVS 3100M]  X.Org 1.7.7  [ 1366x768@50.0hz ]                                                                           
Network cards   Intel 82577LM Gigabit                                                                                                               
                Intel Centrino Advanced-N 6200                                                                                                       
Processes 161 | Uptime 34min | Memory 1292.6/3828.8MB | HDD ST9320423AS Size 320GB (22%used) | GLX Renderer NVS 3100M/PCI/SSE2 | GLX Version 3.2.0 NVIDIA 195.36.31 | Client Shell | Infobash v3.34   


I am not sure what else to try... Any suggestions would be greatly appreciated!

Best to all,

Luis


Last edited by finotti on 01.12.2010, 22:33; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject: RE: screen brightness on Thinkpad T510  PostPosted: 01.12.2010, 12:51



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
a workaround for now would be to use xbacklight or let keytouch handle the FN keys.

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: Re: RE: screen brightness on Thinkpad T510  PostPosted: 01.12.2010, 14:51



Joined: 2010-09-12
Posts: 294

Status: Offline
      devil wrote:
a workaround for now would be to use xbacklight or let keytouch handle the FN keys.

greetz
devil


Thanks, Devil. It did not work, giving me the error "No outputs have backlight property". But searching for that error message gave me the answer:

https://bbs.archlinux.org/viewtopic.php?id=93080

EDIT: original fix: http://www.thinkwiki.org/wiki/Category:T510

Basically, there are two things that could be done. Switching to a virtual terminal (Crtl+Alt+F1, for instance) would allow me to change the brightness and it would keep it when going back to X.

To enable it in X, one can add:

      Code:

Option "RegistryDwords" "EnableBrightnessControl=1"


to the "Device" section of (in my case) /etc/X11/xorg.conf.d/20-nvidia.conf. Here is mine:

      Code:

Section "Device"
         Identifier      "Device 0"
         Driver          "nvidia"
#         Driver          "nv"
         Option          "RegistryDwords" "EnableBrightnessControl=1"
EndSection
# This is a trailing line, it is needed so that End Section is not the last line


The reference above mentioned a high pitched noise with the latter solution, but I don't have that problem.

Note that I'm using the binary driver, which might have been the problem in the first place...

Thanks,

Luis
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio