Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
manulOffline
Post subject: [Solved] Virtualbox OSE 4.0.2 Upgrade - apt-get error  PostPosted: 11.02.2011, 23:26



Joined: 2010-09-13
Posts: 77

Status: Offline
Hi,

My apt-get dist-upgrade went fine.
All but virtualbox-ose (to new version 4.0.2) which causes apt-get to exit with error.

However, no matter of the apt-get error, Virtualbox is upgraded and works fine. I can start it and run all my virtual machines.

But how do I fix it so it does not err on apt-get d-u?

The apt-get error I get is below.

I tried removing the virtualbox-ose-qt: it removes fine but I still get the error when running apt-get.
Without virtualbox-ose-qt I don't have VBox in menu, so I reinstalled virtualbox-ose-qt back.

Thanks


      Code:
root@siduxbox:/home/manul# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up virtualbox-ose (4.0.2-dfsg-1) ...
dpkg: error processing virtualbox-ose (--configure):
 subprocess installed post-installation script returned error exit status 1
configured to not write apport reports
                                      dpkg: dependency problems prevent configuration of virtualbox-ose-qt:
 virtualbox-ose-qt depends on virtualbox-ose (= 4.0.2-dfsg-1); however:
  Package virtualbox-ose is not configured yet.
dpkg: error processing virtualbox-ose-qt (--configure):
 dependency problems - leaving unconfigured
configured to not write apport reports
                                      Processing triggers for python-central ...
Errors were encountered while processing:
 virtualbox-ose
 virtualbox-ose-qt
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@siduxbox:/home/manul#                                                           


Last edited by manul on 12.02.2011, 01:17; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject: RE: Virtualbox OSE 4.0.2 Upgrade - apt-get error  PostPosted: 12.02.2011, 00:48



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
go to /var/lib/dpkg/info/virtualbox-ose.postinst, open it and add a new line under the shebang saying exit 0
like:
      Code:
#!/bin/sh
exit 0
set -e

save it and run apt-get -f install.

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
manulOffline
Post subject: RE: Virtualbox OSE 4.0.2 Upgrade - apt-get error  PostPosted: 12.02.2011, 01:16



Joined: 2010-09-13
Posts: 77

Status: Offline
Thank you, devil.
Worked great.
 
 View user's profile Send private message  
Reply with quote Back to top
spacepenguinOffline
Post subject: RE: Virtualbox OSE 4.0.2 Upgrade - apt-get error  PostPosted: 12.02.2011, 04:00



Joined: 2010-09-11
Posts: 98
Location: Germany
Status: Offline
Here the d-u wanted to remove virtualbox-ose-guest-x11... As I don't use vbox very often I let it got and I tried to reinstall afterwards but:

      Code:
virtualbox-ose-guest-x11 : Hängt ab von: xorg-video-abi-6.0 ist aber nicht installierbar
                            Hängt ab von: xserver-xorg-core (>= 2:1.7.6.901) soll aber nicht installiert werden
                            Hängt ab von: xorg-input-abi-7.0 ist aber nicht installierbar


xserver-xorg-core is 2:1.9.4-1

_________________
Susan | Hardware: SysProfile | 32bit
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio