Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
hyOffline
Post subject: virtualvox can not install vbox  PostPosted: 26.12.2010, 19:18



Joined: 2010-09-14
Posts: 163
Location: Costa Teguise
Status: Offline
Hi, I am having problems to install new version of vbox.
infobash:
      Code:

CPU[-Dual Intel Core2 Duo T7300 @ clocked at Min:800.000Mhz Max:2000.000Mhz-]  Kernel[-Linux 2.6.36-2.slh.3-aptosid-686 i686-]  Up[-3:22-]  Mem[-719.5/2017.0MB-]  HDD[-250GB(72%used)-]  Procs[-152-]  Client[Shell]


After todays DU (2010-12-26) I got a message from oracle/sun that there is a new version, so I downloaded
virtualbox-3.2_3.2.12-68302~Debian~squeeze_i386
from their side.

Tried to install it, but it failed:
      Code:

Preparing to replace virtualbox-3.2 3.2.10-66523~Debian~squeeze (using virtualbox-3.2_3.2.12-68302~Debian~squeeze_i386.deb) ...
Stopping VirtualBox kernel modules:done..
Shutting down VirtualBox host networking:done..
Unpacking replacement virtualbox-3.2 ...
Setting up virtualbox-3.2 (3.2.12-68302~Debian~squeeze) ...
Installing new version of config file /etc/init.d/vboxdrv ...
addgroup: The group `vboxusers' already exists as a system group. Exiting.
Stopping VirtualBox kernel modules:done..
Uninstalling old VirtualBox DKMS kernel modules:done..
Trying to register the VirtualBox kernel modules using DKMS:
Failed, trying without DKMS ... failed!
Recompiling VirtualBox kernel modules:
Look at /var/log/vbox-install.log to find out what went wrong ... failed!

/var/log/vbox-install.log:
      Code:

Makefile:170: *** Error: /usr/src/linux (version 2.6.36) does not match the current kernel (version 2.6.36-2.slh.3-aptosid-686).  Stop.

Any help apreciated. TNX
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject: RE: virtualvox can not install vbox  PostPosted: 26.12.2010, 19:36



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
add: EXTRAVERSION = -2.slh.3-aptosid-686 to line 4 of the headers makefile of (uname -r)
then move to line 423 and add: kernelrelease
then save and build the module.
and btw.: vbox 4 has been released Smile

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
hyOffline
Post subject: Re: RE: virtualvox can not install vbox  PostPosted: 26.12.2010, 19:54



Joined: 2010-09-14
Posts: 163
Location: Costa Teguise
Status: Offline
Thanks, but where is the makefile in question?
      devil wrote:

and btw.: vbox 4 has been released :)

where do I get it?
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject: RE: Re: RE: virtualvox can not install vbox  PostPosted: 26.12.2010, 20:29
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
virtualbox-4.0_4.0.0-69151~Debian~squeeze_i386.deb

is available at

http://www.virtualbox.org/wiki/Downloads

_________________
debian sid | apt-get into it
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject: RE: Re: RE: virtualvox can not install vbox  PostPosted: 26.12.2010, 21:23



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
/usr/src/linux-headers-(uname -r)/Makefile

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
hyOffline
Post subject: RE: Re: RE: virtualvox can not install vbox  PostPosted: 26.12.2010, 21:54



Joined: 2010-09-14
Posts: 163
Location: Costa Teguise
Status: Offline
Thanks Piper - I will give it a try

@devil: Thanks Too - I found the file already but wanted to make sure I need to make the change within these header file...
 
 View user's profile Send private message  
Reply with quote Back to top
hyOffline
Post subject:   PostPosted: 26.12.2010, 22:05



Joined: 2010-09-14
Posts: 163
Location: Costa Teguise
Status: Offline
again it doesn't work out:

vbox-install.log:
      Code:

Makefile:170: *** Error: /usr/src/linux (version 2.6.36-2.slh.3-aptosid-686 ) does not match the current kernel (version 2.6.36-2.slh.3-aptosid-686).  Stop.
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject:   PostPosted: 26.12.2010, 22:21
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
does
      Code:
dpkg -i virtualbox-4.0_4.0.0-69151~Debian~squeeze_i386.deb
install the deb or no

_________________
debian sid | apt-get into it
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject:   PostPosted: 26.12.2010, 23:38



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
please show the lines you changed.

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
mint777Offline
Post subject:   PostPosted: 26.12.2010, 23:58



Joined: 2010-12-21
Posts: 7

Status: Offline
Hi, I have successfully installed the virtualbox version 4 of this:
1 .- a) .- I added manually the repository:
      Code:
deb http://download.virtualbox.org/virtualbox/debian squeeze contrib

b) .- I added the key:
      Code:
wget -q http://download.virtualbox.org/virtualbox/debian/oracle_vbox.asc -O- | apt-key add -

c) .- Update:
      Code:
apt-get update


2 .- delete the old virtualbox:
      Code:
apt-get - purge remove "oldvbox"


3 .- install the new virtualbox:
      Code:
apt-get install virtualbox-4.0


all, to this day everything is excellent and works great.
Sorry for my bad English.

_________________
Mi PC:
gateway sx2801 - Sextuple Boot: LMDE Gnome x64 + Sabayon Gnome x64 + Arch Gnome x64 + Aptosid Kde x64 + Chakra x64 + PCLinuxOS Kde
¿Gnome o Kde? Definitivamente AMBOS.
 
 View user's profile Send private message  
Reply with quote Back to top
hyOffline
Post subject:   PostPosted: 27.12.2010, 10:06



Joined: 2010-09-14
Posts: 163
Location: Costa Teguise
Status: Offline
@devil:

/usr/src/linux-headers-2.6.36-2.slh.3-aptosid-686/Makefile:

      Code:

1 VERSION = 2
2 PATCHLEVEL = 6
3 SUBLEVEL = 36
4 EXTRAVERSION = -2.slh.3-aptosid-686
5 NAME = Flesh-Eating Bats with Fangs
[...]
420 no-dot-config-targets := clean mrproper distclean \
421                          cscope TAGS tags help %docs check% coccicheck \
422                          include/linux/version.h headers_% \
423                          kernelversion %src-pkg \
424                          kernelrelease

I added the linenumbers.

Virtualbox 3.2 3.2.12 install fails and
virtualbox 4 does not install as well.
 
 View user's profile Send private message  
Reply with quote Back to top
slamOffline
Post subject:   PostPosted: 27.12.2010, 10:11
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
Hacking Aptosid Headers is something I would really not recommend. Instead, simply follow Towo's hint (2nd post) in this topic. Adapt the 3 Virtualbox makefiles as described there, and re-build the kernel module:
      Code:
/etc/init.d/vboxdrv setup

Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
hyOffline
Post subject:   PostPosted: 27.12.2010, 11:13



Joined: 2010-09-14
Posts: 163
Location: Costa Teguise
Status: Offline
slam: your hint (towos hint) worked. Thanks
Everything solved for now
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio