Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
SordonOffline
15 Post subject: [solved] Slow response from touchpad after dist upgrade  PostPosted: 10.02.2011, 22:39



Joined: 2010-09-13
Posts: 54

Status: Offline
I'm referring to this thread, because I have now the same problem after doing a dist upgrade two hours ago.

I'm using an Asus PRO50 notebook with an Synaptics touchpad and an ATI Mobility graphics card.

Here some information about the notebook
      Code:
Host/Kernel/OS  "aptosidbox" running Linux 2.6.37-0.slh.20-aptosid-686 i686 [ aptosid 2011-01 Γῆρας - kde-lite - (201102051540) ]
CPU Info        (1) Intel Pentium Dual T2330 @ 1024 KB cache flags( sse3 ht nx lm ) clocked at [ 1596.000 MHz ]
                (2) Intel Pentium Dual T2330 @ 1024 KB cache flags( sse3 ht nx lm ) clocked at [ 1064.000 MHz ]
Videocard       ATI Mobility Radeon X2300  X.Org 1.9.4  [ 1280x800@60.0hz ]
Network cards   Realtek RTL-8139/8139C/8139C+
                Atheros AR5001 Wireless
Processes 137 | Uptime 1min | Memory 270.1/2025.8MB | HDD ST9120822AS Size 120GB (40%used) | GLX Renderer Gallium 0.4 on ATI RV515 | GLX Version Yes | Client Shell | Infobash v3.34
and here the information I find in the Xorg logfile
      Code:
[    18.544] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event8)
[    18.544] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[    18.544] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    18.544] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Synaptics class"
[    18.545] (II) Synaptics touchpad driver version 1.3.0
[    18.583] (--) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5472
[    18.583] (--) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4448
[    18.583] (--) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[    18.583] (--) SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[    18.583] (--) SynPS/2 Synaptics TouchPad: buttons: left right double triple
[    18.615] (--) SynPS/2 Synaptics TouchPad: touchpad found
[    18.615] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    18.631] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
[    18.631] (**) SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 5.0
[    18.631] (**) SynPS/2 Synaptics TouchPad: MaxSpeed is now 12.50
[    18.631] (**) SynPS/2 Synaptics TouchPad: AccelFactor is now 0.012
[    18.631] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[    18.631] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[    18.631] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    18.631] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    18.655] (--) SynPS/2 Synaptics TouchPad: touchpad found
[    18.655] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[    18.655] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    18.655] (II) Synaptics touchpad driver version 1.3.0
[    19.059] (EE) SynPS/2 Synaptics TouchPad no synaptics event device found
[    19.067] (--) SynPS/2 Synaptics TouchPad: invalid x-axis range.  defaulting to 1615 - 5685
[    19.067] (--) SynPS/2 Synaptics TouchPad: invalid y-axis range.  defaulting to 1729 - 4171
[    19.067] (--) SynPS/2 Synaptics TouchPad: invalid pressure range.  defaulting to 0 - 256
[    19.067] (--) SynPS/2 Synaptics TouchPad: invalid finger width range.  defaulting to 0 - 16
[    19.087] (EE) Query no Synaptics: 6003C8
[    19.087] (--) SynPS/2 Synaptics TouchPad: no supported touchpad found
[    19.087] (EE) SynPS/2 Synaptics TouchPad Unable to query/initialize Synaptics hardware.
[    19.100] (EE) PreInit failed for input device "SynPS/2 Synaptics TouchPad"

This is what I get from hwinfo
      Code:
  Hardware Class: mouse
  Model: "SynPS/2 Synaptics TouchPad"
  Vendor: 0x0002
  Device: 0x0007 "SynPS/2 Synaptics TouchPad"
  Compatible to: int 0x0210 0x0002
  Device File: /dev/input/mice (/dev/input/mouse0)
  Device Files: /dev/input/mice, /dev/input/mouse0, /dev/input/event8, /dev/input/by-path/platform-i8042-serio-4-event-mouse, /dev/input/by-path/platform-i8042-serio-4-mouse
  Device Number: char 13:63 (char 13:32)
  Driver Info #0:
    Buttons: 2
    Wheels: 0
    XFree86 Protocol: explorerps/2
    GPM Protocol: exps2
  Config Status: cfg=new, avail=yes, need=no, active=unknown

And I have no xorg configuration file.

Best Regards,
Sordon


Last edited by Sordon on 12.02.2011, 22:41; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject: RE: Slow response from touchpad after dist upgrade  PostPosted: 10.02.2011, 22:57
Moderator


Joined: 2010-09-11
Posts: 468

Now I tried it myself.
As root, created /etc/X11/xorg.conf.d directory
# mkdir /etc/X11/xorg.conf.d
then with text editor, created the file /etc/X11/xorg.conf.d/10-synaptics.conf
with this contents:

      Code:

Section "InputClass"
      Identifier "touchpad"
      Driver "synaptics"
      MatchIsTouchpad "on"
    # Speed
    Option "MinSpeed" "0.5"
    Option "MaxSpeed" "20.0"
    Option "AccelFactor" "0.099"
EndSection
#


and restarted X. ("init 3", then "init 5")
and seems mouse movement with touchpad is faster
now you change the values as you like, with some rounds of "try & see" yourself.
 
 View user's profile Send private message  
Reply with quote Back to top
hubiOffline
Post subject: RE: Slow response from touchpad after dist upgrade  PostPosted: 10.02.2011, 23:20
Moderator


Joined: 2010-09-11
Posts: 228
Location: Vienna (AT)
Status: Offline
In KDE you can also set the touchpad in systemsettings. For GTK based desktop environments you can use gpointing-device-settings. Both you can manipulate as user, you don't need to be root.

hubi

_________________
Tilos Rádió Budapest
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
SordonOffline
Post subject:   PostPosted: 10.02.2011, 23:47



Joined: 2010-09-13
Posts: 54

Status: Offline
@muchan: Thanks for your input. Now the touchpad reacts much faster. Even a little bit too fast. Now I have to figure out the right settings. Strange is though that I didn't need the settings file before the dist upgrade.

@hubi: Do you mean the mouse settings in KDE systemsettings? Unfortunately they have no effect on the speed. Or do I have to install some certain package to get a special touchpad configuration in systemsettings?
 
 View user's profile Send private message  
Reply with quote Back to top
Ilinsekt
Post subject:   PostPosted: 10.02.2011, 23:52



Joined: 2010-10-29
Posts: 43

The package is kde-config-touchpad, however, it only allows a maximum speed of 2.
 
 View user's profile Send private message  
Reply with quote Back to top
deachOffline
Post subject:   PostPosted: 11.02.2011, 00:33



Joined: 2010-09-18
Posts: 31

Status: Offline
I had the same issue. The above speeded it up quite a bit, I"m adjusting on it now....@ sordon let me know if you come up with new settings that seem better and I'll do the same
Regards,
Deach
 
 View user's profile Send private message  
Reply with quote Back to top
deachOffline
Post subject:   PostPosted: 11.02.2011, 00:48



Joined: 2010-09-18
Posts: 31

Status: Offline
Actually isn't there already "xorg.conf.d" file in hal for this?? Does that one make no difference now?
 
 View user's profile Send private message  
Reply with quote Back to top
ikeinthaiOffline
Post subject: can you feel that?  PostPosted: 11.02.2011, 05:58



Joined: 2010-09-22
Posts: 119
Location: bigannastybkk
Status: Offline
      muchan wrote:
Now I tried it myself.
As root, created /etc/X11/xorg.conf.d directory
# mkdir /etc/X11/xorg.conf.d
then with text editor, created the file /etc/X11/xorg.conf.d/10-synaptics.conf
with this contents:

      Code:

Section "InputClass"
      Identifier "touchpad"
      Driver "synaptics"
      MatchIsTouchpad "on"
    # Speed
    Option "MinSpeed" "0.5"
    Option "MaxSpeed" "20.0"
    Option "AccelFactor" "0.099"
EndSection
#


and restarted X. ("init 3", then "init 5")
and seems mouse movement with touchpad is faster
now you change the values as you like, with some rounds of "try & see" yourself.


thanks so much muchan!!! the SilverBitch once again responds to the slightest twitch of my finger, and all is right with the World.

aptosid! ike.

_________________
aptosid: magic in action, the point of the spear. bleedin pearls before swine? lets hope not. freesoftware/freedomsoftware=a chance at freedom. participants, engage your vehicle. . . avatar by zenren
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
towoOffline
Post subject:   PostPosted: 11.02.2011, 06:21



Joined: 2010-09-13
Posts: 496
Location: Pößneck / Thüringen
Status: Offline
      deach wrote:
Actually isn't there already "xorg.conf.d" file in hal for this?? Does that one make no difference now?

The xserver does not use hal anymore, since months.
 
 View user's profile Send private message  
Reply with quote Back to top
SordonOffline
Post subject:   PostPosted: 11.02.2011, 09:17



Joined: 2010-09-13
Posts: 54

Status: Offline
      deach wrote:
...@ sordon let me know if you come up with new settings that seem better and I'll do the same ...
It will take some time before I can comeback with my settings, because I'm currently away from home and I do not have the notebook with me.
 
 View user's profile Send private message  
Reply with quote Back to top
hubiOffline
Post subject:   PostPosted: 11.02.2011, 10:00
Moderator


Joined: 2010-09-11
Posts: 228
Location: Vienna (AT)
Status: Offline
      Sordon wrote:
@hubi: Do you mean the mouse settings in KDE systemsettings?


No, I mean the touchpad settings. Here "acceleration" did the job by raising from 0.01 to 0.02 on one laptop.

Click on the image to see it in full size:



hubi

_________________
Tilos Rádió Budapest
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
SordonOffline
Post subject:   PostPosted: 11.02.2011, 10:11



Joined: 2010-09-13
Posts: 54

Status: Offline
      hubi wrote:
... I mean the touchpad settings. ...
OK, I see. I do not have these settings in my KDE systemsettings yet. I will install kde-config-touchpad and check it out.

Will it be necessary to set the "SHMConfig" parameter in the Xorg config to "true", to allow the touchpad configuration in systemsettings to have an effect?
 
 View user's profile Send private message  
Reply with quote Back to top
ToZOffline
Post subject:   PostPosted: 11.02.2011, 11:50



Joined: 2010-09-11
Posts: 26
Location: Toronto, Ontario, Canada
Status: Offline
I noticed when I updated that it was recommended to install gpointing-device-settings. (I use xfce and the xfce4-mouse-settings was no longer working). I installed gpointing-device-settings, tweaked, and all was good again.
 
 View user's profile Send private message  
Reply with quote Back to top
deachOffline
Post subject:   PostPosted: 11.02.2011, 12:37



Joined: 2010-09-18
Posts: 31

Status: Offline
I can confirm that hubi's advice worked after installing the kde-config-touchpad. @ towo Thanks I actually meant the file 51-symaptics-aptosid.conf file. Sorry for the confusion
 
 View user's profile Send private message  
Reply with quote Back to top
hopimetOffline
Post subject: Re: RE: Slow response from touchpad after dist upgrade  PostPosted: 11.02.2011, 12:38



Joined: 2010-10-13
Posts: 62
Location: France
Status: Offline
      muchan wrote:
Now I tried it myself.
As root, created /etc/X11/xorg.conf.d directory
# mkdir /etc/X11/xorg.conf.d
then with text editor, created the file /etc/X11/xorg.conf.d/10-synaptics.conf
with this contents:

      Code:

Section "InputClass"
      Identifier "touchpad"
      Driver "synaptics"
      MatchIsTouchpad "on"
    # Speed
    Option "MinSpeed" "0.5"
    Option "MaxSpeed" "20.0"
    Option "AccelFactor" "0.099"
EndSection
#


and restarted X. ("init 3", then "init 5")
and seems mouse movement with touchpad is faster
now you change the values as you like, with some rounds of "try & see" yourself.


This solved my problem, Thx muchan.
AccelFactor at 0.05 is OK for me (0.099 was too fast).

@ToZ: gpointing-device-settings was not helpful unfortunately (I'm with xfce too, or E17 sometimes). Is there a specific configuration after installation of the package ?
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio