Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
cheekybadgerOffline
Post subject: is there a ftp.debian.org/debian/ sid/main Translation-en_GB  PostPosted: 16.02.2011, 23:06



Joined: 2010-09-16
Posts: 10

Status: Offline
When I do an update I've noticed that the repository hits for debian and aptosid are main Translations-en_US
      Code:
 Hit http://ftp.debian.org sid Release.gpg
Ign http://ftp.debian.org/debian/ sid/main Translation-en
Ign http://ftp.debian.org/debian/ sid/main Translation-en_US
Hit http://aptosid.com sid Release.gpg         
Ign http://aptosid.com/debian/ sid/fix.main Translation-en
Ign http://aptosid.com/debian/ sid/fix.main Translation-en_US
Hit http://ftp.debian.org sid Release         
Ign http://aptosid.com/debian/ sid/main Translation-en
Ign http://aptosid.com/debian/ sid/main Translation-en_US
Hit http://aptosid.com sid Release             
Hit http://ftp.debian.org sid/main i386 Packages/DiffIndex
Hit http://aptosid.com sid/main i386 Packages
Hit http://aptosid.com sid/fix.main i386 Packages
Reading package lists... Done

my Region and language settings are British English. Is there a Ign http://ftp.debian.org/debian/ sid/main Translation-en_GB if so how do I change to it?
Cheers.
 
 View user's profile Send private message  
Reply with quote Back to top
broweOffline
Post subject: RE: is there a ftp.debian.org/debian/ sid/main Translation-e  PostPosted: 17.02.2011, 15:08



Joined: 2010-09-12
Posts: 152
Location: Canada
Status: Offline
As root:

      Code:

dpkg-reconfigure locales


And select en_GB.utf-8. As far as I understand, the english translation was done by a team of mostly Americans and that all english is based on this translation, regardless of region (such as CA, US, GB etc.) So there exists no "translation" per se for the various dialects of english. While editing locales, consider deleting any that you know you won't need since it will reduce downloads and make dist-upgrade go faster.

Also, see here: http://wiki.debian.org/Locale
 
 View user's profile Send private message  
Reply with quote Back to top
DonKultOffline
Post subject: RE: is there a ftp.debian.org/debian/ sid/main Translation-e  PostPosted: 17.02.2011, 15:53
Team Member


Joined: 2010-09-02
Posts: 482

Status: Offline
Hi cheekybadger, just ignore these messages APT prints here. Since version 0.8.11 APT downloads more Translationfiles than previously and expects that an Index file is provided telling him which Translation files (which include translations for long descriptions of packages) exist. As not all repositories have these Index files for all components (debian has it for example only for main so far) currently APT is programmed to play safe if it can't get a Index file and requests all Translation files which would be useful on your system without knowing if they really exist (the non-existing Index file would tell APT if they exist and would therefore not request non-existent ones). The messages will disappear after the repositories have been updated to provide such a file (which can take a while), especially as they doesn't hurt it isn't top-priority.

P.S.: Have a look at locales as browe suggests and the output of the command 'locale' It looks for me as your system is configured as LANG=en_US.

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
cheekybadgerOffline
Post subject:   PostPosted: 20.02.2011, 23:35



Joined: 2010-09-16
Posts: 10

Status: Offline
Hi Browe and DonKilt.
have changed the system locale to en_GB.utf-8 so now no more having to change the defult language in programmes, which is great. APT now looks up Ing.....sid/fix.main Translation-en_GB.
but I noticed after changing the locales as browe said I had this message after
      Code:
 root@cheeky-badger:/home/robert# dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LANG = "en_US.utf8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales (this might take a while)...
is this ok?
 
 View user's profile Send private message  
Reply with quote Back to top
broweOffline
Post subject:   PostPosted: 22.02.2011, 15:56



Joined: 2010-09-12
Posts: 152
Location: Canada
Status: Offline
It's not ok, the output should have no messages, only a CR. I have changed mine to en_CA.utf8 and it shows up as such under LANGUAGE, LC_ALL and LANG. First, as root try running update-locale to see if that fixes the problem. Then see the file /etc/default/locales and the command locale and locale -a to confirm the language you choose is installed.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio