Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
Ilinsekt
Post subject: [solved]Notebook fails to suspend with kernels 37.slh.25&  PostPosted: 17.02.2011, 02:28



Joined: 2010-10-29
Posts: 43

Hey,

my notebook can not suspend-to-ram with the kernels 2.6.37.slh.25 and slh.26. It locks the session, switches to the virtual console and then back to X. If I move my mouse, the KDE unlock-session dialog pops up. If I reboot to slh.23 and try it there, suspend-to-ram succeeds.

Here's what dmesg says on slh.26:
      Code:

[   79.501721] PM: Syncing filesystems ... done.
[   79.538411] Freezing user space processes ... (elapsed 0.01 seconds) done.
[   79.549109] Freezing remaining freezable tasks ... (elapsed 0.01 seconds) done.
[   79.560132] Suspending console(s) (use no_console_suspend to debug)
[   79.564151] sd 4:0:0:0: [sdb] Synchronizing SCSI cache
[   79.564228] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[   79.564317] sd 4:0:0:0: [sdb] Stopping disk
[   79.640106] tpm_tis 00:0e: Operation Timed out
[   79.640114] legacy_suspend(): pnp_bus_suspend+0x0/0x70 returns -62
[   79.640117] PM: Device 00:0e failed to suspend: error -62
[   79.920977] sd 0:0:0:0: [sda] Stopping disk
[   80.265821] PM: Some devices failed to suspend
[   80.266030] sd 0:0:0:0: [sda] Starting disk
[   80.266213] sd 4:0:0:0: [sdb] Starting disk
[   80.873157] PM: resume of devices complete after 607.332 msecs
[   80.873276] Restarting tasks ... done.
[   80.877205] video LNXVIDEO:00: Restoring backlight state


I am using an Asus M70VN notebook:
      Code:

Host/Kernel/OS  "StargateCommand" running Linux 2.6.37-0.slh.26-aptosid-686 i686 [ aptosid 2010-02 Κῆρες - kde-lite - (201009132215) ]
CPU Info        (1) Intel Core2 Duo T9400 @ 6144 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 800.000 MHz ]                         
                (2) Intel Core2 Duo T9400 @ 6144 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 2534.000 MHz ]                         
Videocard       nVidia G96 [GeForce 9650M GT]  X.Org 1.9.4  [ 1920x1200@50.0hz ]                                                         
Network cards   Realtek RTL8111/8168B PCI Express Gigabit                                                                               
                Intel WiFi Link 5100                                                                                                     
Processes 145 | Uptime 7min | Memory 657.7/3041.6MB | HDD ST9250320AS,ST9250320AS Size 500GB (28%used) | GLX Renderer GeForce 9650M GT/PCI/SSE2 | GLX Version 3.3.0 NVIDIA 260.19.36 | Client Shell | Infobash v3.34


/e: fixed with 2.6.37-1.slh.2. Thx


Last edited by Ilinsekt on 20.02.2011, 22:46; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
Ilinsekt
Post subject:   PostPosted: 18.02.2011, 07:23



Joined: 2010-10-29
Posts: 43

*bump*
problem persists with 2.6.37-1.slh.1
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio