Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
mclienOffline
Post subject: [SOLVED] sony vaio VPCF12 (VPCF12A4E) no network (sk98lin)  PostPosted: 24.02.2011, 19:35



Joined: 2011-02-24
Posts: 4

Status: Offline
I try this notebook from my mother, so far I've tested several Debian based distros (Lenny, squeeze, Puppylinux..)

aptosid is the partial winner so far, becaus it got most of the stuff work "out of the box". Lots of thanks for that!

BUT: most annoying the networkcard is not recognized!
according to all I found it is a 88E8057 and should work with the sk98lin driver from marvell. But it doesn't compile.
(log is attached)

I'm willing to edit any of these files from marvell, but need hints which one and how.

Strange thing is: with one of the puppy versions I got the network running, but with the sky2 driver!
(but with that I got no sound , no touchpad...

EDIT:
oh, sorry: I'm running Version 201101 amd64


Last edited by mclien on 25.02.2011, 19:37; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
leonOffline
Post subject:   PostPosted: 25.02.2011, 06:18



Joined: 2010-09-21
Posts: 6

Status: Offline
Hello mclien,

have a sony vaio vpcf13m1e working fine here with win7 / 2.6.36-2.slh.3-aptosid-amd64 and

      Quote:

sam@aptosidbox:~$ lspci | grep Ethernet
04:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8057 PCI-E Gigabit Ethernet Controller (rev 10)

That should be the same as yours and what I've done I haven't compiled anything only installed aptosid and using ceni. > that's it.
Maybe you should give it a second try!
by
leon
 
 View user's profile Send private message  
Reply with quote Back to top
mclienOffline
Post subject:   PostPosted: 25.02.2011, 17:45



Joined: 2011-02-24
Posts: 4

Status: Offline
so you have the aptosid 2010-03 then, I think. But I only can find the 2011-01 realse, which doesn't work, and can't find any mirror, which still holds a 2010-03 iso....
 
 View user's profile Send private message  
Reply with quote Back to top
leonOffline
Post subject:   PostPosted: 25.02.2011, 18:50



Joined: 2010-09-21
Posts: 6

Status: Offline
Hello mclien,

you haven't mentioned the aptosid's version in your first post, so sorry for that, and yes I am using :
      Quote:

sam@aptosidbox:~$ infobash -v3
Host/Kernel/OS "aptosidbox" running Linux 2.6.36-2.slh.3-aptosid-amd64 x86_64 [ aptosid 2010-03 Ἀπάτη - kde-full - (201012262151) ]


by
leon
 
 View user's profile Send private message  
Reply with quote Back to top
mclienOffline
Post subject:   PostPosted: 25.02.2011, 19:36



Joined: 2011-02-24
Posts: 4

Status: Offline
Hi leon,

yes I didn't mention that and in this case I was a RTFM canditate Wink
Because I'm mainly used to debian I didn't understand what you ment with ceni. Now that I read the manual and used it it works!

Thanks for that hint.
So everything I tested, works (sky2 driver)

ToDo:
test the microphone
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio