Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
muchan
Post subject: [solved] python-sip removes python-qt4, calibre, etc.  PostPosted: 25.02.2011, 08:15
Moderator


Joined: 2010-09-11
Posts: 468

(amd64)

Today's new python-sip (4.12.1-1) wants to remove python-qt4,
in my case also calibre, which depends python-qt4.

I think python-qt4 needs to depends <sip-api-8.0>.
(for now <sip-api-7.0>)

I'll hold python-sip until python-qt4 gets new version.


Last edited by muchan on 02.03.2011, 08:06; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject: RE: 2011-02-25 python-sip removes python-qt4, calibre, etc.  PostPosted: 26.02.2011, 09:56
Moderator


Joined: 2010-09-11
Posts: 468

problem is not solved. but I noticed, on my i386 system,
python-sip is automatically held at dist-upgrade.
(I can't confirm it on amd64, because it's on other location)

if I try "apt-get install -s python-sip", it would still remove
python-qt4 and calibre.
 
 View user's profile Send private message  
Reply with quote Back to top
nh2Offline
22 Post subject: Re: RE: 2011-02-25 python-sip removes python-qt4, calibre, e  PostPosted: 26.02.2011, 21:05



Joined: 2011-01-28
Posts: 25
Location: Tlemcen, Algeria
Status: Offline
      muchan wrote:
I noticed, on my i386 system,
python-sip is automatically held at dist-upgrade.

On mine too. Can someone briefly explain us why?
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
detaosOffline
Post subject:   PostPosted: 27.02.2011, 17:59
Team Member


Joined: 2010-08-26
Posts: 166
Location: floating in the ether
Status: Offline
      Code:
# apt-get dist-upgrade -d
...
The following packages will be REMOVED:
  plasma-scriptengine-python python-kde4 python-qt4


no hold here on amd64.

_________________
#aptosid-art ftw!
(what would cleary do?)
 
 View user's profile Send private message Send e-mail Visit poster's website  
Reply with quote Back to top
DonKultOffline
Post subject: Re: RE: 2011-02-25 python-sip removes python-qt4, calibre, e  PostPosted: 27.02.2011, 18:30
Team Member


Joined: 2010-09-02
Posts: 482

Status: Offline
      nh2 wrote:
      muchan wrote:
I noticed, on my i386 system,
python-sip is automatically held at dist-upgrade.

On mine too. Can someone briefly explain us why?

I did it in the german offspin of this thread: http://aptosid.de/index.php?name=PNphpB ... &t=671

In short: The decisions APT makes depend on your system: If more packages depend on python-qt4 than on python-sip the decision is different to the reverse situation. So it happens that for some APT decides to hold the package back while for others it decides to upgrade the package (and therefore remove the ones that can't cope with the new one).

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
muchan
Post subject: RE: Re: RE: 2011-02-25 python-sip removes python-qt4, calibr  PostPosted: 27.02.2011, 18:46
Moderator


Joined: 2010-09-11
Posts: 468

Interesting, but on my i386 and amd64, both python-qt4 and calibre are only packages
that would be removed when python-sip is upgrade... so mistery remains...
 
 View user's profile Send private message  
Reply with quote Back to top
bmorencyOffline
Post subject:   PostPosted: 27.02.2011, 19:49



Joined: 2010-10-22
Posts: 71

Status: Offline
      detaos wrote:
      Code:
# apt-get dist-upgrade -d
...
The following packages will be REMOVED:
  plasma-scriptengine-python python-kde4 python-qt4


no hold here on amd64.



I have the same packages here that want to be removed. I am also on amd64. No packages on hold either.
 
 View user's profile Send private message  
Reply with quote Back to top
DonKultOffline
Post subject: RE: Re: RE: 2011-02-25 python-sip removes python-qt4, calibr  PostPosted: 27.02.2011, 19:55
Team Member


Joined: 2010-09-02
Posts: 482

Status: Offline
      Code:
apt-get dist-upgrade -o Debug::pkgProblemResolver=1 -s

No mystery. Its more complicated than noted above: Recommends/Suggests come into play, as well as priority and the scores of the first-level reverse-dependencies… Its easiest to apply a "just don't care" marker as its hard to describe the exact behavior of the resolver with all its cornercases.

If APT decides to hold something back you are just "lucky" in this case (in many other cases you are unlucky - which occurs more likely in bigger dist-upgrades). If it decides to remove them - my bad. Just hold it yourself if you care or wait a bit longer.

APT asks if its okay what it has decided surely because it isn't unfailable, so some decisions can be wrong and its your job to decide if its okay. The simplification for you is just that you just need to check the proposed solution - you don't need to work out a solution on your own. So if you don't like the solution don't accept the solution and wait.

(And yes, finding a solution is much harder than deciding if a solution is okay. Every idiot can check if a solved sudoku is correctly solved (if he knows the rules), but not everyone can find a solution to a given sudoku problem.)

And for the record: "My" APT holds it back. Wink

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
slamOffline
Post subject: Re: RE: Re: RE: 2011-02-25 python-sip removes python-qt4, ca  PostPosted: 27.02.2011, 20:53
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
      DonKult wrote:
[code]...Every idiot can check if a solved sudoku is correctly solved (if he knows the rules), but not everyone can find a solution to a given sudoku problem....
That's why he is the apt man, trust him.
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
DonKultOffline
Post subject: Re: RE: Re: RE: 2011-02-25 python-sip removes python-qt4, ca  PostPosted: 27.02.2011, 21:12
Team Member


Joined: 2010-09-02
Posts: 482

Status: Offline
      slam wrote:
      DonKult wrote:
...Every idiot can check if a solved sudoku is correctly solved (if he knows the rules), but not everyone can find a solution to a given sudoku problem....
That's why he is the apt man, trust him.

Oh dear, the "trust him" argument… Wink

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
x-un-i
Post subject: Re: RE: Re: RE: 2011-02-25 python-sip removes python-qt4, ca  PostPosted: 28.02.2011, 16:39
Team Member


Joined: 2010-08-26
Posts: 170

      DonKult wrote:
      slam wrote:
      DonKult wrote:
...Every idiot can check if a solved sudoku is correctly solved (if he knows the rules), but not everyone can find a solution to a given sudoku problem....
That's why he is the apt man, trust him.

Oh dear, the "trust him" argument… Wink


shit happens .... Rolling Eyes

_________________
Why do strong arms fatigue themselves with frivolous dumbbells?
To dig a vineyard is worthier exercise for men.
Marcus Valerius Martialis, römischer Satiriker und Epigrammdichter

Será que o diabo perdeu a virgindade?
 
 View user's profile Send private message  
Reply with quote Back to top
rick1053Offline
Post subject: Re: RE: Re: RE: 2011-02-25 python-sip removes python-qt4, ca  PostPosted: 28.02.2011, 20:17



Joined: 2010-12-08
Posts: 23
Location: Bauru, SP, Brazil
Status: Offline
      DonKult wrote:
      Code:
apt-get dist-upgrade -o Debug::pkgProblemResolver=1 -s

And for the record: "My" APT holds it back. Wink


Mine is on hold too. (32bit)

Thanks for all the work you have done to help us with APT.
I personally read your posts, when I have time, even if it does not relate to a specific problem I am having. I learn something every time. Thanks

Rick
 
 View user's profile Send private message  
Reply with quote Back to top
taxilemiOffline
Post subject:   PostPosted: 01.03.2011, 23:22



Joined: 2010-11-14
Posts: 6
Location: München
Status: Offline
Hello, I have the same problem

but the listed pde line won't solve the problem on my AMD64-Aptosid.
      Code:
root@BLECHTROTTEL:/home/alemi/quatsch/alevt-1.6.2# apt-get dist-upgrade -o Debug::pkgProblemResolver=1 -s
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Statusinformationen werden eingelesen... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Starting
Starting 2
Investigating (0) python-qt4 [ amd64 ] <4> ( python )
Broken python-qt4:amd64 Hängt ab von on sip-api-7.1 [ amd64 ] <none> ( none )
  Considering python-sip:amd64 4 as a solution to python-qt4:amd64 6
  Added python-sip:amd64 to the remove list
  Fixing python-qt4:amd64 via keep of python-sip:amd64
 Try to Re-Instate (0) python-sip:amd64
Done
Fertig
Die folgenden Pakete sind zurückgehalten worden:
  python-sip
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 1 nicht aktualisiert.
root@BLECHTROTTEL:/home/alemi/quatsch/alevt-1.6.2#

Sorry for the German answers of Aptosid, but my default language is German, since I was hacking my playpen Very Happy and Linux does, what you tell him.

Ulrich Lehmkühler
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 02.03.2011, 08:05
Moderator


Joined: 2010-09-11
Posts: 468

This morning, new python-qt4 depending new sip-api-8.1 arrived.
So python-sip can now be installed without conflict.

marked "solved".
 
 View user's profile Send private message  
Reply with quote Back to top
spacepenguinOffline
Post subject:   PostPosted: 04.03.2011, 21:49



Joined: 2010-09-11
Posts: 98
Location: Germany
Status: Offline
When I try to update python-sip/python-qt4 it will remove plasma-scriptengine-python, plasma-scriptengines, python-kde4 and synce-kpm.

_________________
Susan | Hardware: SysProfile | 32bit
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio