Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
penguinloverOffline
Post subject: chroot - issues  PostPosted: 01.03.2011, 04:46



Joined: 2011-03-01
Posts: 3

Status: Offline
I have installed aptosid - 2011 xfce and it is rocking! There is one small issue..

I have to install wireless driver for ipw2100 which was detected by fw-hdetect..

To do so , I tried to chroot from my Ubuntu install ..When I issue

1. mount --bind /dev /mnt/dev
2.mount --bind /sys /mnt/sys
3.mount --bind /proc /mnt/proc

4.cp/etc/resolv.conf /mnt/etc/resolv.conf (mounted sid partition in mnt)


I get error in this step

cannot copy to dangling symlink


How to resolve this?

H
 
 View user's profile Send private message  
Reply with quote Back to top
OppaErichOffline
Post subject: RE: chroot - issues  PostPosted: 01.03.2011, 07:55



Joined: 2010-09-13
Posts: 28
Location: Essen, Germany
Status: Offline
I ran into this too, /mnt/etc/resolv.conf is a symlink pointing at nothing at this time.

What I did:
      Code:

ls -l /mnt/etc/resolv.conf  # write down to restore later
rm /mnt/etc/resolv.conf
cp /etc/resolv.conf /mnt/etc/resolv.conf

Then do what you want to do &
Restore that sysmlink after booting

Probably not the most elegant way but did the job for me.
 
 View user's profile Send private message  
Reply with quote Back to top
nadirOffline
Post subject: RE: chroot - issues  PostPosted: 07.03.2011, 13:18



Joined: 2011-03-01
Posts: 1
Location: germany
Status: Offline
Try
mount -t proc /proc /mnt/proc
too. Not related to your issue, but still.

I did never cp resolv.conf, are you sure you need to?
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio