Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
bmorencyOffline
Post subject: [Solved] python-sip removes python-kde4, etc.  PostPosted: 02.03.2011, 12:01



Joined: 2010-10-22
Posts: 71

Status: Offline
      muchan wrote:
This morning, new python-qt4 depending new sip-api-8.1 arrived.
So python-sip can now be installed without conflict.

marked "solved".


Python-qt is being installed for me this morning but plasma-scriptengine-python and python-kde4 still want to be removed. Are these two packages related or is it another issue? I am on amd64.

Thanks
 
 View user's profile Send private message  
Reply with quote Back to top
agaidaOffline
Post subject:   PostPosted: 02.03.2011, 18:43



Joined: 2011-01-16
Posts: 22
Location: Bielefeld
Status: Offline
Is another issue. python-kde4 has sip-7.1 as dependency, but still is not buildable.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
taxilemiOffline
Post subject:   PostPosted: 02.03.2011, 23:33



Joined: 2010-11-14
Posts: 6
Location: München
Status: Offline
Where Do You have got the sip-api-8.1? I get only the message
      Code:
python-kde4:
 Hängt ab von: sip-api-7.1  but it is not installable
after upgrading the repos.

Ulrich Lehmkühler
 
 View user's profile Send private message  
Reply with quote Back to top
agaidaOffline
Post subject:   PostPosted: 03.03.2011, 00:14



Joined: 2011-01-16
Posts: 22
Location: Bielefeld
Status: Offline
Build it from the Ground. It's a little bit tricky and doesn't work 100% because of some issues in kdebindings (imho false references), but from tody i'm running aptosid with qt4.7.1 Wink and without python-kde4 Sad. phyton-sip:

      Code:

sip4 (4.12.1-1.1) unstable; urgency=low

  * Non-maintainer upload.
  * mysip

 -- Alf Gaida <info>  Wed, 02 Mar 2011 17:58:55 +0100

sip4 (4.12.1-1) unstable; urgency=low

  * Team upload.

  [ Michael Casadevall ]
  * Merged in patch from Per W for Python 3 support, thank you.
  * Add lintian overrides for incorrect warnings

  [ Michał Zając ]
  * New upstream release
  * Added Python 3 support (Closes: #587072)
   - support default Python 3 interpreter only for now
   - debian/rules: added dh_python3
   - debian/rules: added install-arch-3.%
   - debian/rules: added substvars to keep provides up-to-date
   - debian/control: python-sip provides sip-api-8.0 and 8.1
   - debian/control: python3-sip provides sip-py3api-8.0 and 8.1
  * Added configure.py.patch, fixes FTBFS
  * debian/patches/siputils_debian_changes.diff
   - Refreshed
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
rick1053Offline
Post subject:   PostPosted: 03.03.2011, 16:34



Joined: 2010-12-08
Posts: 23
Location: Bauru, SP, Brazil
Status: Offline
This thread needs a title edit adding amd64. It is solved for amd64 only. This is not fixed on 32bit. APT wants to remove plasma-scriptengine-python python-kde4 frescobaldi. Probably frescobaldi is not relevant for most users but plasma-scriptengine-python and python-kde4 are needed for most users with 32bit kde4 installed.

Hold back these pkgs and d-u "python-qt4 python-sip kept back"

Regards,
Rick
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 03.03.2011, 18:10
Moderator


Joined: 2010-09-11
Posts: 468

Initially I created thread with problem on my non-KDE system.
mainly, I needed to hold it so that calibre won't be removed.
so for me, problem has solved ans thus marked...

I'd edit "partially solved" but the length of title is limited,
I need to shorten it to add more info...

(can't the limitation of title length be increased?)

edit:
{ as a moderator of this forum, I spilited the thread with
new title "python-sip removes python-kde4, etc."
not yet marked as solved. and original thread as [solved].
hope all of you are happy about this spilit. }
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 03.03.2011, 18:22
Moderator


Joined: 2010-09-11
Posts: 468

      taxilemi wrote:
Where Do You have got the sip-api-8.1? I get only the message
      Code:
python-kde4:
 Hängt ab von: sip-api-7.1  but it is not installable
after upgrading the repos.

Ulrich Lehmkühler


The answer is, the new version of python-sip provides sip-api-8.1. The older (installed) version provides sip-api-7.1.
Because of that, if you upgrade python-sip, then the packages depends on 7.1 but can't cope with 8.1 would be removed.
Thus this thread.
 
 View user's profile Send private message  
Reply with quote Back to top
agaidaOffline
Post subject:   PostPosted: 07.03.2011, 21:27



Joined: 2011-01-16
Posts: 22
Location: Bielefeld
Status: Offline
Issue is solved with python-kde4 (4:4.4.5-4), todays build.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
rick1053Offline
Post subject:   PostPosted: 08.03.2011, 18:14



Joined: 2010-12-08
Posts: 23
Location: Bauru, SP, Brazil
Status: Offline
      muchan wrote:
Initially I created thread with problem on my non-KDE system.
mainly, I needed to hold it so that calibre won't be removed.
so for me, problem has solved ans thus marked...

I'd edit "partially solved" but the length of title is limited,
I need to shorten it to add more info...

(can't the limitation of title length be increased?)

edit:
{ as a moderator of this forum, I spilited the thread with
new title "python-sip removes python-kde4, etc."
not yet marked as solved. and original thread as [solved].
hope all of you are happy about this spilit. }


@muchan - Thanks for the very clear explanation. It is much easier to get help in aptosid that it was in sidux.
Thanks to all developers, moderators, the whole team. This distro has no equal.
Regards,
Rick
 
 View user's profile Send private message  
Reply with quote Back to top
rick1053Offline
Post subject:   PostPosted: 08.03.2011, 18:27



Joined: 2010-12-08
Posts: 23
Location: Bauru, SP, Brazil
Status: Offline
Just did d-u with pkgs off hold. Updated without removing a thing.
Regards,
Rick
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio