Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
ankscorekOffline
Post subject: xfce4:login screeen  PostPosted: 10.03.2011, 16:46



Joined: 2010-09-29
Posts: 40

Status: Offline
hi guys i am a newbie as far as xfce4..

after a dist-upgrade i lost my kde desktp but managed to install xfce4

however i have to type a startx to get to this destop

can some one suggest so that i can have a login screen?
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject: RE: xfce4:login screeen  PostPosted: 10.03.2011, 17:41
Moderator


Joined: 2010-09-11
Posts: 468

you need to install and configure display manager. (gdm3, slim, etc., if not kdm)
# apt-get install gdm3
then set that it stops when you enter init 3.

Or you can downgrade qt4 and reinstall KDE/KDM from stable...

{ edit: testing -> stable, because KDE on testing seems already broken

to restore removed KDE, at least working order
1) activate stable repository in debian.list
2) # apt-get update
3) # apt-get install -t stable libqt4-core kde-standard kdm
seems working...
}


Last edited by muchan on 11.03.2011, 08:53; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
ankscorekOffline
Post subject:   PostPosted: 11.03.2011, 01:18



Joined: 2010-09-29
Posts: 40

Status: Offline
it has give me this


      Code:
apt-get -t stable install libqt4-core kde-standard kdm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kde-standard : Depends: kde-plasma-desktop (>= 5:66) but it is not going to be installed or
                         kde-plasma-netbook (>= 5:66) but it is not going to be installed
                Depends: polkit-kde-1 but it is not going to be installed
                Depends: ark (>= 4:4.4.3) but it is not going to be installed
                Depends: dragonplayer (>= 4:4.4.3) but it is not going to be installed
                Depends: gwenview (>= 4:4.4.3) but it is not going to be installed
                Depends: juk (>= 4:4.4.3) but it is not going to be installed
                Depends: kate (>= 4:4.4.3) but it is not going to be installed
                Depends: kcalc (>= 4:4.4.3) but it is not going to be installed
                Depends: kmail (>= 4:4.4.3) but it is not going to be installed
                Depends: akregator (>= 4:4.4.3) but it is not going to be installed
                Depends: kaddressbook (>= 4:4.4.3) but it is not going to be installed
                Depends: kdeplasma-addons (>= 4:4.4.3) but it is not going to be installed
                Depends: knotes (>= 4:4.4.3) but it is not going to be installed
                Depends: kwalletmanager (>= 4:4.4.3) but it is not going to be installed
                Depends: korganizer (>= 4:4.4.3) but it is not going to be installed
                Depends: kopete (>= 4:4.4.3) but it is not going to be installed
                Depends: kmix (>= 4:4.4.3) but it is not going to be installed
                Depends: ksnapshot (>= 4:4.4.3) but it is not going to be installed
                Depends: kscreensaver (>= 4:4.4.3) but it is not going to be installed
                Depends: okular (>= 4:4.4.3) but it is not going to be installed
                Depends: sweeper (>= 4:4.4.3) but it is not going to be installed
                Depends: khelpcenter4 (>= 4:4.4.3) but it is not going to be installed
 kdm : Depends: kdebase-runtime but it is not going to be installed
       Depends: libkworkspace4 (= 4:4.4.5-7) but it is not going to be installed
       Depends: kdebase-workspace-kgreet-plugins (= 4:4.4.5-7) but 4:4.4.5-8 is to be installed
 libqt4-core : Depends: libqtcore4 (= 4:4.6.3-4) but 4:4.7.2-1 is to be installed
               Depends: libqt4-network (= 4:4.6.3-4) but 4:4.7.2-1 is to be installed
               Depends: libqt4-script (= 4:4.6.3-4) but 4:4.7.2-1 is to be installed
               Depends: libqt4-xml (= 4:4.6.3-4) but 4:4.7.2-1 is to be installed
               Depends: libqt4-dbus (= 4:4.6.3-4) but 4:4.7.2-1 is to be installed
               Depends: libqt4-test (= 4:4.6.3-4) but 4:4.7.2-1 is to be installed
E: Broken packages
 
 View user's profile Send private message  
Reply with quote Back to top
detaosOffline
Post subject:   PostPosted: 11.03.2011, 01:51
Team Member


Joined: 2010-08-26
Posts: 166
Location: floating in the ether
Status: Offline
the best thing you can do at this point is wait for sid to settle out. just give it a couple days and things will return to normal. sid's in the middle of a very rough transition to qt 4.7.

_________________
#aptosid-art ftw!
(what would cleary do?)
 
 View user's profile Send private message Send e-mail Visit poster's website  
Reply with quote Back to top
ankscorekOffline
Post subject:   PostPosted: 11.03.2011, 06:20



Joined: 2010-09-29
Posts: 40

Status: Offline
anyways i am using xfce4 ..however i am unable to lock the screen even though i installed xscreensaver..

ctrl+alt+del not working


it works...

      Code:
xscreensaver-demo


Last edited by ankscorek on 11.03.2011, 06:37; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject:   PostPosted: 11.03.2011, 06:29



Joined: 2010-09-13
Posts: 497
Location: Pößneck / Thüringen
Status: Offline
For screen lock, you need the package xlockmore.
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 11.03.2011, 08:51
Moderator


Joined: 2010-09-11
Posts: 468

      detaos wrote:
the best thing you can do at this point is wait for sid to settle out. just give it a couple days and things will return to normal. sid's in the middle of a very rough transition to qt 4.7.


sure, but here (in this thread) is about the user who has already removed KDE by proceeding d-u... 8(


      ankscorek wrote:

apt-get -t stable install libqt4-core kde-standard kdm
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
...

Have you activated stable repository? apt-get is telling it's going to install the version of libqt4-core on the sid, not stable as told...
 
 View user's profile Send private message  
Reply with quote Back to top
ankscorekOffline
Post subject:   PostPosted: 11.03.2011, 12:57



Joined: 2010-09-29
Posts: 40

Status: Offline
i did enable stable repos

can u please share the repo stable incase its different

here is my squeeze.list file

      Code:
deb http://debian.lcs.mit.edu/debian/ squeeze main contrib non-free
#deb-src http://debian.lcs.mit.edu/debian/ squeeze main contrib non-free
#
#deb http://security.debian.org/ squeeze/updates main contrib non-free
#deb-src http://security.debian.org/ squeeze/updates main contrib non-free
#
# deb http://volatile.debian.org/debian-volatile/ squeeze/volatile main contrib non-free
# deb-src http://volatile.debian.org/debian-volatile/ squeeze/volatile main contrib non-free
#
# deb ftp://ftp.gr.debian.org/debian squeeze/stable-proposed-updates main contrib non-free
# deb-src ftp://ftp.gr.debian.org/debian squeeze/stable-proposed-updates main contrib non-free
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 11.03.2011, 15:04
Moderator


Joined: 2010-09-11
Posts: 468

why don't you do it in debian.list file?

then I'm not sure if you did not disactivate the sid in debian.list...
and make sure you did #apt-get update before...
 
 View user's profile Send private message  
Reply with quote Back to top
ankscorekOffline
Post subject:   PostPosted: 11.03.2011, 19:07



Joined: 2010-09-29
Posts: 40

Status: Offline
i deactivated all sid repos and i also did an update
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 11.03.2011, 21:32
Moderator


Joined: 2010-09-11
Posts: 468

no. you should NOT deactivate the sid. and do update, then the command.
 
 View user's profile Send private message  
Reply with quote Back to top
ankscorekOffline
Post subject:   PostPosted: 12.03.2011, 05:08



Joined: 2010-09-29
Posts: 40

Status: Offline
ok i followed the instructions and used aptosid repo as well as squeeze repo and the results are

      Code:
apt-get -t stable install libqt4-core kde-standard kdm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kde-standard : Depends: kde-plasma-desktop (>= 5:66) but it is not going to be installed or
                         kde-plasma-netbook (>= 5:66) but it is not going to be installed
                Depends: polkit-kde-1 but it is not going to be installed
                Depends: ark (>= 4:4.4.3) but it is not going to be installed
                Depends: dragonplayer (>= 4:4.4.3) but it is not going to be installed
                Depends: gwenview (>= 4:4.4.3) but it is not going to be installed
                Depends: juk (>= 4:4.4.3) but it is not going to be installed
                Depends: kate (>= 4:4.4.3) but it is not going to be installed
                Depends: kcalc (>= 4:4.4.3) but it is not going to be installed
                Depends: kmail (>= 4:4.4.3) but it is not going to be installed
                Depends: akregator (>= 4:4.4.3) but it is not going to be installed
                Depends: kaddressbook (>= 4:4.4.3) but it is not going to be installed
                Depends: kdeplasma-addons (>= 4:4.4.3) but it is not going to be installed
                Depends: knotes (>= 4:4.4.3) but it is not going to be installed
                Depends: kwalletmanager (>= 4:4.4.3) but it is not going to be installed
                Depends: korganizer (>= 4:4.4.3) but it is not going to be installed
                Depends: kopete (>= 4:4.4.3) but it is not going to be installed
                Depends: kmix (>= 4:4.4.3) but it is not going to be installed
                Depends: ksnapshot (>= 4:4.4.3) but it is not going to be installed
                Depends: kscreensaver (>= 4:4.4.3) but it is not going to be installed
                Depends: okular (>= 4:4.4.3) but it is not going to be installed
                Depends: sweeper (>= 4:4.4.3) but it is not going to be installed
                Depends: khelpcenter4 (>= 4:4.4.3) but it is not going to be installed
 kdm : Depends: kdebase-runtime but it is not going to be installed
       Depends: libkworkspace4 (= 4:4.4.5-7) but it is not going to be installed
       Depends: kdebase-workspace-kgreet-plugins (= 4:4.4.5-7) but 4:4.4.5-8 is to be installed
 libqt4-core : Depends: libqtcore4 (= 4:4.6.3-4) but 4:4.7.2-1 is to be installed
               Depends: libqt4-network (= 4:4.6.3-4) but 4:4.7.2-1 is to be installed
               Depends: libqt4-script (= 4:4.6.3-4) but 4:4.7.2-1 is to be installed
               Depends: libqt4-xml (= 4:4.6.3-4) but 4:4.7.2-1 is to be installed
               Depends: libqt4-dbus (= 4:4.6.3-4) but 4:4.7.2-1 is to be installed
               Depends: libqt4-test (= 4:4.6.3-4) but 4:4.7.2-1 is to be installed
E: Broken packages
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 12.03.2011, 10:16
Moderator


Joined: 2010-09-11
Posts: 468

Situation has changed since I posted the command...
Now on 32bit system, without stable repo (and without "-t stable")
you can install KDE from sid. just

# apt-get install kde-standard
or
# apt-get install kde-full

I can't confirm it on 64bit system

{ edit: for the record, I sought the reason of failure...
on my (non-KDE) system, the command worked, because libqt4 was not upgraded yet.
After the version of libqt4 libraries are upgraded, apt-get with "-t stable" does not consider
automatically downgrading. So dependencies are not met.
The write command to restore kde from stable --- now not required when KDE on sid is adopted ---
is to enumerate all the libqt4 libraries from stable, to explicitely downgrade them,
and install kde from stable. but it won't be neccessary any more... }
 
 View user's profile Send private message  
Reply with quote Back to top
ankscorekOffline
Post subject:   PostPosted: 13.03.2011, 12:09



Joined: 2010-09-29
Posts: 40

Status: Offline
i am a bit happy with xfce4 but i am unable to install LinEAK and also i am getting this error whenever i try to run kernel remover env: -c: No such file or directory
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 13.03.2011, 12:24
Moderator


Joined: 2010-09-11
Posts: 468

As far as I can see, LinEAK on Debian is only on unofficial port for avr32 and m68k architecture,
not for i386 and amd64, which aptosid supports.
http://packages.debian.org/sid/liblineak-0.9-0 (scroll down to the end)
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio