Actualizar con el LiveCD

No es posible realizar una actualización mediante el LiveCD de una instalación anterior de aptosid. Antes de proceder a instalar aptosid de nuevo, RESPALDE SUS DATOS! incluyendo los enlaces, los favoritos del navegador web y su correo electrónico.

Se recomienda insistentemente que tenga una partición separada para los datos. Los beneficios en términos de recuperación después de un desastre y para la estabilidad de sus datos son enormes.

De cualquier manera, el $HOME es un lugar donde se guardan las configuraciones básicas. O, dicho de otra manera, un contenedor para que las aplicaciones guarden allí sus configuraciones.

SIEMPRE RESPALDE SUS DATOS, incluyendo los enlaces, favoritos del web y su correo electrónico!

Actualización de la distribución (dist-upgrade) de una instalación en el Disco Duro

Ha actualizado la instalación con el último LiveCD y ahora desea asegurarse de tener las versiones y actualizaciones de seguridad más recientes.

En aptosid a esto se le llama 'dist-upgrade', y se hace en línea. [Es mejor con conexión de banda ancha]

El único método admisible y apoyado es el siguiente:

NUNCA realice un "upgrade" ni "dist-upgrade" mientras esté en el ambiente gráfico X
Antes, siempre, revise la sección "Current Warnings" en la página web principal de aptosid. Estos avisos están allí por razón de la naturaleza de "Debian Sid/Unstable" y son actualizados diariamente.
## Salga de KDE.
## Entre al modo texto presionando Ctrl+Alt+F1
## entonces haga login como "root" y después teclee:
init 3
apt-get update
apt-get dist-upgrade
apt-get clean
init 5 && exit"
NUNCA HAGA EL DIST-UPGRADE [ni UPGRADE] con adept, aptitude o synaptic. VER: Actualización de un Sistema Instalado

¿Por qué recomendamos SOLAMENTE "apt-get" para "dist-upgrade"?

Los gestores de paquetes "adept", "aptitude", "synaptic" y "kpackage" no son siempre capaces de acomodarse a los muchos cambios que suceden en Sid (cambios de dependencias, de nombres, en los scripts de los mantenedores, etcétera). Esto no es un fallo de los desarrolladores ni de estas herramientas, que son excelentes para la rama estable de Debian. Simplemente, no son aptas para las necesidades especiales de Debian Sid.

Utilice lo que más le agrade para buscar paquetes, pero recomendamos utilizar el "apt-get" para "install", "remove", "purge" y "dist-upgrade".

Los gestores de paquetes "adept", "aptitude", "synaptic" y "kpackage" no son determinísticos para selecciones complejas de paquetes: cuando estas se mezclan con un conjunto de paquetes tan cambiantes como hay en Sid, y aún peor, un repositorio externo de calidad cuestionable (no lo recomendamos, pero ésta es una realidad en algunos sistemas de usuarios) se estará acercando al desastre. Otra cosa a notar es que todos estos gestores de paquetes necesitan ejecutarse en el nivel 5, y/o en X, y hacer un dist-upgrade (ni siquiera upgrade) en nivel 5 ó en X está desaconsejado. Puede dañar el sistema hasta un punto irreparable, quizás no hoy ni mañana, pero dentro de algún tiempo sucederá.

Por otro lado "apt-get" hace exactamente lo que se espera de él. Si hay alguna rotura puede encontrar el lugar del error para depurar y arreglar la causa. Si acaso "apt-get" quiere borrar la mitad del sistema (debido a transiciones de librerias) es una decisión que el administrador (probablemente usted) tendrá que tomar después de leer todos los mensajes.

Esta es la razón por la que el sistema "Debian builds" utiliza apt-get y ninguna otra de las demás herramientas de paquetes.

Contenido modificado el 14/08/2010 0100 UTC